net-im/py-matrix-synapse: Update to 1.58.1
This commit is contained in:
parent
a763817090
commit
5f0906db0f
5 changed files with 36 additions and 19 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
PORTNAME= matrix-synapse
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.57.1
|
||||
DISTVERSION= 1.58.1
|
||||
CATEGORIES= net-im python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
|
@ -12,10 +12,13 @@ COMMENT= Matrix protocol reference homeserver
|
|||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}poetry2setup>=1.0.0:devel/py-poetry2setup@${PY_FLAVOR}
|
||||
|
||||
# Keep the RUN_DEPENDS layout similar to the master/synapse/python_dependencies.py file
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}frozendict>=1:devel/py-frozendict@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=1.1.0:devel/py-unpaddedbase64@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=2.1.0:devel/py-unpaddedbase64@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}canonicaljson>=1.4.0:devel/py-canonicaljson@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}signedjson>=1.1.0:security/py-signedjson@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pynacl>=1.2.1:security/py-pynacl@${PY_FLAVOR} \
|
||||
|
@ -34,13 +37,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
|
|||
${PYTHON_PKGNAMEPREFIX}msgpack>=0.5.2:devel/py-msgpack@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}phonenumbers>=8.2.0:devel/py-phonenumbers@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}prometheus-client>=0.4.0:net-mgmt/py-prometheus-client@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}attrs>19.2.0:devel/py-attrs@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}attrs>=19.2.0:devel/py-attrs@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}netaddr>=0.7.18:net/py-netaddr@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.0:devel/py-Jinja2@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}bleach>=1.4.3:www/py-bleach@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.10.0:devel/py-typing-extensions@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ijson>=3.1.4:devel/py-ijson@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyjwt>=1.7.0:www/py-pyjwt@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=16.1:devel/py-packaging@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}matrix-common>=1.1.0:devel/py-matrix-common@${PY_FLAVOR} \
|
||||
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
|
||||
|
@ -74,13 +77,15 @@ PLIST_FILES= "@sample ${ETCDIR}/log.config.sample"
|
|||
DOCS= README.rst UPGRADE.rst CHANGES.md docs/postgres.md
|
||||
PORTDOCS= ${DOCS:T}
|
||||
|
||||
OPTIONS_DEFINE= DOCS LDAP OIDC PGSQL REDIS SQLITE URLPREVIEW
|
||||
OPTIONS_DEFINE= DOCS JWT LDAP OIDC PGSQL REDIS SQLITE URLPREVIEW
|
||||
OPTIONS_DEFAULT= PGSQL SQLITE
|
||||
|
||||
JWT_DESC= Add dependencies for JSON web tokens
|
||||
OIDC_DESC= Add dependencies for OpenID Connect based logins
|
||||
REDIS_DESC= Add support replication over Redis for synapse workers
|
||||
URLPREVIEW_DESC= Add dependencies necessary for URL previews
|
||||
|
||||
JWT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.6.4:www/py-pyjwt@${PY_FLAVOR}
|
||||
LDAP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matrix-synapse-ldap3>=0.1:net/py-matrix-synapse-ldap3@${PY_FLAVOR}
|
||||
OIDC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}authlib>=0.14.0:security/py-authlib@${PY_FLAVOR}
|
||||
PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>2.8:databases/py-psycopg2@${PY_FLAVOR}
|
||||
|
@ -96,6 +101,9 @@ URLPREVIEW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=4.2.0:devel/py-lxml@${PY_FL
|
|||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=1.4:devel/py-importlib-metadata@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && poetry2setup > setup.py
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${ETCDIR}
|
||||
${INSTALL_DATA} ${WRKDIR}/log.config ${STAGEDIR}${ETCDIR}/log.config.sample
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1650652816
|
||||
SHA256 (matrix-org-synapse-v1.57.1_GH0.tar.gz) = 07926e1601bd2973ea16baabd41268939ceeb90f6a8c98b31a3610de61dc5ad1
|
||||
SIZE (matrix-org-synapse-v1.57.1_GH0.tar.gz) = 7834623
|
||||
TIMESTAMP = 1651864723
|
||||
SHA256 (matrix-org-synapse-v1.58.1_GH0.tar.gz) = 3e64e102ee9e848c70b923a68001990541bb749e9fb3fe2cf4f643ad40955add
|
||||
SIZE (matrix-org-synapse-v1.58.1_GH0.tar.gz) = 7881275
|
||||
|
|
11
net-im/py-matrix-synapse/files/patch-pyproject.toml
Normal file
11
net-im/py-matrix-synapse/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pyproject.toml.orig 2022-05-07 18:29:37 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -146,7 +146,7 @@ bleach = ">=1.4.3"
|
||||
typing-extensions = ">=3.10.0"
|
||||
# We enforce that we have a `cryptography` version that bundles an `openssl`
|
||||
# with the latest security patches.
|
||||
-cryptography = ">=3.4.7"
|
||||
+cryptography = "*"
|
||||
# ijson 3.1.4 fixes a bug with "." in property names
|
||||
ijson = ">=3.1.4"
|
||||
matrix-common = "~=1.1.0"
|
|
@ -1,11 +0,0 @@
|
|||
--- synapse/python_dependencies.py.orig 2022-04-20 00:17:17 UTC
|
||||
+++ synapse/python_dependencies.py
|
||||
@@ -82,7 +82,7 @@ REQUIREMENTS = [
|
||||
"typing-extensions>=3.10.0",
|
||||
# We enforce that we have a `cryptography` version that bundles an `openssl`
|
||||
# with the latest security patches.
|
||||
- "cryptography>=3.4.7",
|
||||
+ "cryptography",
|
||||
# ijson 3.1.4 fixes a bug with "." in property names
|
||||
"ijson>=3.1.4",
|
||||
"matrix-common~=1.1.0",
|
|
@ -74,4 +74,13 @@ section of the configuration file, is set to true. See the upgrade notes[1] for
|
|||
[1] https://matrix-org.github.io/synapse/v1.56/upgrade#change-in-behaviour-for-postgresql-databases-with-unsafe-locale
|
||||
EOM
|
||||
}
|
||||
{ type: upgrade
|
||||
maximum_version: 1.62.0
|
||||
message: <<EOM
|
||||
Starting with synapse 1.62.0, this port will no longer ship with sqlite support
|
||||
by default. If you rely on sqlite for your setup, please either migrate to
|
||||
postfix, install the sqlite dependency manually or build a custom flavor of the
|
||||
port.
|
||||
EOM
|
||||
}
|
||||
]
|
||||
|
|
Loading…
Reference in a new issue