* Update exim-4.12 -> exim-4.14:
This is a maintenance release, but there are a few edge cases where backward compatibikity in the configure file was broken. While upgrading is recommended, administrators are encouraged to Update exim-4.12 -> exim-4.14: This is a maintenance release, but there are a few edge cases where backward compatibikity in the configure file was broken. While upgrading is recommended, administrators are encouraged to examine the README.UPDATING file in the distribution. * Catch up to changes in the ports tree with respect to available OpenLDAP releases. While backward compatibility is preserved, administrators may use WITH_OPENLDAP1, WITH_OPENLDAP20 and WITH_OPENLDAP21 for more fine-grained control of the OpenLDAP release on which to depend. Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com>
This commit is contained in:
parent
276acc56c3
commit
5f0e3b5298
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77824
5 changed files with 44 additions and 67 deletions
|
@ -7,7 +7,6 @@
|
|||
|
||||
PORTNAME= exim
|
||||
PORTVERSION= ${EXIM_VERSION}
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/ \
|
||||
http://www.exim.org/ftp/exim4/ \
|
||||
|
@ -28,9 +27,9 @@ USE_BZIP2= yes
|
|||
USE_PERL5= yes
|
||||
MAN8= exim.8
|
||||
|
||||
EXIM_VERSION= 4.12
|
||||
EXIM_VERSION= 4.14
|
||||
EXIM_DOCVERSION= 4.10
|
||||
EXISCAN_VERSION= 4.12-25
|
||||
EXISCAN_VERSION= 4.14-26
|
||||
|
||||
PLIST_SUB+= EXIM_VERSION="${EXIM_VERSION}"
|
||||
|
||||
|
@ -51,12 +50,11 @@ POSTGRESQL_PORT?= databases/postgresql7
|
|||
# email content scanner support.
|
||||
#WITHOUT_EXISCAN= yes
|
||||
|
||||
# Define WITH_TCP_WRAPPERS, WITH_LDAP, WITH_MYSQL, and WITH_PGSQL to
|
||||
# link against libwrap, an LDAP library (see below), liblibmysqlclient
|
||||
# and libpq respectively. Define WITH_PWCHECK to link against libsasl
|
||||
# for SMTP AUTH authentication via the Cyrus SASL pwcheck daemon.
|
||||
# Define WITH_TCP_WRAPPERS, WITH_MYSQL, and WITH_PGSQL to link against
|
||||
# libwrap, liblibmysqlclient and libpq respectively. Define
|
||||
# WITH_PWCHECK to link against libsasl for SMTP AUTH authentication
|
||||
# via the Cyrus SASL pwcheck daemon.
|
||||
#WITH_TCP_WRAPPERS= yes
|
||||
#WITH_LDAP= yes
|
||||
#WITH_MYSQL= yes
|
||||
#WITH_PGSQL= yes
|
||||
#WITH_PWCHECK= yes
|
||||
|
@ -67,11 +65,13 @@ POSTGRESQL_PORT?= databases/postgresql7
|
|||
# be necessary.
|
||||
#WITHOUT_IPV6= yes
|
||||
|
||||
# If WITH_LDAP is defined, LDAP_LIB_TYPE must be either OPENLDAP1 or
|
||||
# OPENLDAP2. UMICHIGAN is an alias for OPENLDAP1. Exim also supports
|
||||
# NETSCAPE and SOLARIS7 lookup types, but no client libraries exist
|
||||
# for these in the ports tree.
|
||||
LDAP_LIB_TYPE?=OPENLDAP1
|
||||
# Define WITH_OPENLDAP1, WITH_OPENLDAP20 or WITH_OPENLDAP21 to link
|
||||
# against the respective OpenLDAP library.
|
||||
# Exim also supports NETSCAPE and SOLARIS7 lookup types, but no
|
||||
# client libraries exist for these in the ports tree.
|
||||
#WITH_OPENLDAP1= yes
|
||||
#WITH_OPENLDAP20= yes
|
||||
#WITH_OPENLDAP21= yes
|
||||
|
||||
# DB_LIB_VERSION is the version of the Berkeley DB library to use, and
|
||||
# may be 1, which corresponds to version 1.85 in the base system, or 4
|
||||
|
@ -118,7 +118,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/eximon:${PORTSDIR}/mail/exim-monitor
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
PORTDOC_FILES= Exim3.upgrade Exim4.upgrade OptionLists.txt README \
|
||||
dbm.discuss.txt filter.txt pcre.txt pcretest.txt \
|
||||
dbm.discuss.txt filter.txt pcrepattern.txt pcretest.txt \
|
||||
spec.txt
|
||||
.if !defined(WITHOUT_EXISCAN)
|
||||
PORTDOC_FILES+= exiscan-readme.txt
|
||||
|
@ -151,13 +151,37 @@ SEDLIST+= -e 's,XX_TCP_WRAPPERS_LIBS_XX,,'
|
|||
.endif
|
||||
|
||||
.if defined(WITH_LDAP)
|
||||
LDAP_LIB_TYPE?=OPENLDAP1
|
||||
.if (${LDAP_LIB_TYPE} == OPENLDAP1) || (${LDAP_LIB_TYPE} == UMICHIGAN)
|
||||
LIB_DEPENDS+= lber.1:${PORTSDIR}/net/openldap12
|
||||
WITH_OPENLDAP1= yes
|
||||
.elif ${LDAP_LIB_TYPE} == OPENLDAP2
|
||||
LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap20
|
||||
WITH_OPENLDAP2= yes
|
||||
.else
|
||||
.error LDAP_LIB_TYPE must be either OPENLDAP1 or OPENLDAP2
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENLDAP1) && ( defined(WITH_OPENLDAP2) || \
|
||||
defined(WITH_OPENLDAP20) || defined(WITH_OPENLDAP21) )
|
||||
.error please select only one OpenLDAP version
|
||||
.elif defined(WITH_OPENLDAP20) && defined(WITH_OPENLDAP21)
|
||||
.error OpenLDAP 2.0 and 2.1 are mutually exclusive
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENLDAP21)
|
||||
LDAP_LIB_TYPE= OPENLDAP2
|
||||
LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap21
|
||||
.elif defined(WITH_OPENLDAP2) || defined(WITH_OPENLDAP20)
|
||||
LDAP_LIB_TYPE= OPENLDAP2
|
||||
LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap20
|
||||
.elif defined(WITH_OPENLDAP1)
|
||||
LDAP_LIB_TYPE= OPENLDAP1
|
||||
LIB_DEPENDS+= lber.1:${PORTSDIR}/net/openldap12
|
||||
.elif defined(LDAP_LIB_TYPE)
|
||||
.error please choose the OpenLDAP version you want to use
|
||||
.endif
|
||||
|
||||
.if defined(LDAP_LIB_TYPE)
|
||||
SEDLIST+= -e 's,XX_LDAP_LIBS_XX,-L${LOCALBASE}/lib -llber -lldap,' \
|
||||
-e 's,XX_LDAP_INCLUDE_XX,-I${LOCALBASE}/include,' \
|
||||
-e 's,XX_LDAP_TYPE_XX,${LDAP_LIB_TYPE},' \
|
||||
|
@ -224,7 +248,7 @@ SEDLIST+= -e 's,XX_PGSQL_[^ ]*_XX,,'
|
|||
SEDLIST+= -e 's,^\# HAVE_IPV6=,HAVE_IPV6=,'
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL) && !defined(WITH_LDAP) && \
|
||||
.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL) && !defined(LDAP_LIB_TYPE) && \
|
||||
${DB_LIB_VERSION} == 1
|
||||
SEDLIST+= -e 's,^LOOKUP_LIBS=,\#LOOKUP_LIBS=,' \
|
||||
-e 's,^LOOKUP_INCLUDE=,\#LOOKUP_INCLUDE=,'
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (exim-4.12.tar.bz2) = 7aed2a66295a7702b9a9394ec2bc5ffd
|
||||
MD5 (exim-4.14.tar.bz2) = 81d0e304289f84a57144b66030ab9329
|
||||
MD5 (exim-texinfo-4.10.tar.bz2) = 2a2a34a2457d249d568a58e985f263c0
|
||||
MD5 (exiscan-4.12-25.tar.bz2) = 260c6d87d6b2599be7043d531fb6fc60
|
||||
MD5 (exiscan-4.14-26.tar.bz2) = edaabf47ad42dc7b26949fe1390abfff
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/dbfn.c.orig Wed Dec 18 12:28:01 2002
|
||||
+++ src/dbfn.c Tue Jan 21 12:17:02 2003
|
||||
@@ -148,7 +148,7 @@
|
||||
sprintf(CS buffer, "%s/db/%s", spool_directory, name);
|
||||
EXIM_DBOPEN(buffer, flags, EXIMDB_MODE, &(dbblock->dbptr));
|
||||
|
||||
-if (dbblock->dbptr == NULL && errno == ENOENT)
|
||||
+if (dbblock->dbptr == NULL && errno == ENOENT && flags == O_RDWR)
|
||||
{
|
||||
DEBUG(D_hints_lookup)
|
||||
debug_printf("%s appears not to exist: trying to create\n", buffer);
|
|
@ -1,36 +0,0 @@
|
|||
*** src/rda.c.orig Wed Dec 18 10:28:03 2002
|
||||
--- src/rda.c Wed Dec 18 11:35:25 2002
|
||||
***************
|
||||
*** 489,494 ****
|
||||
--- 489,495 ----
|
||||
int yield, status;
|
||||
pid_t pid;
|
||||
uschar *data;
|
||||
+ void (*oldsignal)(int);
|
||||
|
||||
DEBUG(D_route) debug_printf("rda_interpret (%s): %s\n",
|
||||
(rdata->isfile)? "file" : "string", rdata->string);
|
||||
***************
|
||||
*** 542,547 ****
|
||||
--- 543,553 ----
|
||||
log_write(0, LOG_MAIN|LOG_PANIC_DIE, "creation of pipe for filter or "
|
||||
":include: failed for %s: %s", rname, strerror(errno));
|
||||
|
||||
+ /* Ensure that SIGCHLD is set to SIG_DFL before forking, so that the child
|
||||
+ process can be waited for. We sometimes get here with it set otherwise. Save
|
||||
+ the old state for resetting on the wait. */
|
||||
+
|
||||
+ oldsignal = signal(SIGCHLD, SIG_DFL);
|
||||
if ((pid = fork()) == 0)
|
||||
{
|
||||
header_line *waslast = header_last; /* Save last header */
|
||||
***************
|
||||
*** 831,836 ****
|
||||
--- 837,843 ----
|
||||
}
|
||||
|
||||
close(fd);
|
||||
+ signal(SIGCHLD, oldsignal); /* restore */
|
||||
return yield;
|
||||
|
||||
/* Come here is there's a shambles in transferring the data over the pipe. */
|
|
@ -24,7 +24,7 @@ sbin/exiqsumm
|
|||
%%PORTDOCS%%share/doc/exim/README
|
||||
%%PORTDOCS%%share/doc/exim/dbm.discuss.txt
|
||||
%%PORTDOCS%%share/doc/exim/filter.txt
|
||||
%%PORTDOCS%%share/doc/exim/pcre.txt
|
||||
%%PORTDOCS%%share/doc/exim/pcrepattern.txt
|
||||
%%PORTDOCS%%share/doc/exim/pcretest.txt
|
||||
%%PORTDOCS%%share/doc/exim/spec.txt
|
||||
%%PORTDOCS%%%%EXISCAN%%share/doc/exim/exiscan-readme.txt
|
||||
|
|
Loading…
Reference in a new issue