Add nfsshell, a userland NFS command tool.

PR:		ports/77153
Submitted by:	johans@stack.nl
This commit is contained in:
Volker Stolz 2005-02-09 11:14:39 +00:00
parent 20c185d932
commit 5f2dbec2db
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128362
5 changed files with 43 additions and 0 deletions

View file

@ -401,6 +401,7 @@
SUBDIR += nettest
SUBDIR += netwib
SUBDIR += newsbot
SUBDIR += nfsshell
SUBDIR += ng_daphne
SUBDIR += ng_netflow
SUBDIR += ngrep

26
net/nfsshell/Makefile Normal file
View file

@ -0,0 +1,26 @@
# New ports collection makefile for: nfsshell
# Date created: 5 February 2005
# Whom: johans@stack.nl
#
# $FreeBSD$
#
PORTNAME= nfsshell
PORTVERSION= 19980519
CATEGORIES= net
MASTER_SITES= http://www.cs.vu.nl/pub/leendert/
DISTNAME= ${PORTNAME}
MAINTAINER= johans@stack.nl
COMMENT= Userland NFS command tool
WRKSRC= ${WRKDIR}/nfs
ALL_TARGET= nfs
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DREADLINE" LIBS="-lreadline"
PLIST_FILES= bin/nfsshell
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nfs ${PREFIX}/bin/nfsshell
.include <bsd.port.mk>

2
net/nfsshell/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (nfsshell.tar.gz) = d447235518691fc3176ce89a6d836ce7
SIZE (nfsshell.tar.gz) = 29213

View file

@ -0,0 +1,10 @@
--- nfs.c.orig Sat Feb 5 23:17:18 2005
+++ nfs.c Sat Feb 5 23:17:09 2005
@@ -50,7 +50,6 @@
#include <netinet/in.h>
#include <arpa/inet.h>
#include <sys/time.h>
-#include <sys/sysmacros.h>
#include "mount.h"
#include "nfs_prot.h"
#include <netinet/in_systm.h>

4
net/nfsshell/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
nfs shell provides user level access to an NFS server, over UDP or TCP,
supports source routing and "secure" (privileged port) mounts. It's a
useful tool to manually check (or show) security problems after a security
scanner has detected them.