Add gnet-glib2 after a repo copy from gnet. gnet-glib2 provides the Gnet

API built on Glib 2.
This commit is contained in:
Joe Marcus Clarke 2003-02-23 17:34:03 +00:00
parent 3366242122
commit 5f6b9c279a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76281
20 changed files with 272 additions and 132 deletions

View file

@ -1,24 +1,29 @@
# New ports collection makefile for: gnet
# Date created: 16 February 2000
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
# New ports collection makefile for: gnet-glib2
# Date created: 15 February 2003
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnet
PORTVERSION= 1.1.4
PORTVERSION= 1.1.8
CATEGORIES= net
MASTER_SITES= http://www.gnetlibrary.org/src/
MAINTAINER= nakai@FreeBSD.org
MAINTAINER= gnome@FreeBSD.org
COMMENT= A simple network library built upon Glib
LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
LATEST_LINK= gnet-glib2
USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gnomehack glib12
USE_GNOME= gnomehack
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-glib2
MAN1= gnet-config.1
MAN1= gnet-glib2-config.1
post-patch:
# fix pthreads detection
@ -30,14 +35,30 @@ post-patch:
# don't install gnet-config script with odd name. We will install it ourselves
@${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
${WRKSRC}/Makefile.in
# install gnet-config.1 man (not another name). Revise at EVERY port update
@${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
# don't install any of the config files. We will do it ourselves.
@${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E -e 's|^[[:space:]]+install-pkgconfigDATA$$||' \
${WRKSRC}/Makefile.in
# don't install the manpage. We will do it ourselves.
@${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1 install-data-local|' \
${WRKSRC}/doc/Makefile.in
# install configincludedir correctly
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)-glib2|' \
${WRKSRC}/Makefile.in
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
@${MKDIR} -p ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin/gnet-glib2-config
@${MKDIR} -p ${PREFIX}/share/aclocal
@${INSTALL_DATA} ${WRKSRC}/gnet.m4 ${PREFIX}/share/aclocal/gnet-glib2.m4
@${INSTALL_DATA} ${WRKSRC}/gnetconfig.h \
${PREFIX}/include/gnet-glib2
@${MKDIR} -p ${PREFIX}/libdata/pkgconfig
@${INSTALL_DATA} ${WRKSRC}/gnet.pc \
${PREFIX}/libdata/pkgconfig/gnet-glib2.pc
@${MKDIR} -p ${PREFIX}/man/man1
@${INSTALL_DATA} ${WRKSRC}/doc/gnet-config.1 \
${PREFIX}/man/man1/gnet-glib2-config.1
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gnet-1.1.4.tar.gz) = dbd03fc1bd34d611671a83564a225bb1
MD5 (gnet-1.1.8.tar.gz) = da2b5de278e96a5b907c2e2304bf6542

View file

@ -0,0 +1,10 @@
--- Makefile.in.orig Sun Feb 16 15:47:35 2003
+++ Makefile.in Sun Feb 16 15:48:54 2003
@@ -94,7 +94,7 @@
VERSION = @VERSION@
pthread_libs = @pthread_libs@
-SUBDIRS = src examples tests doc
+SUBDIRS = src doc
EXTRA_DIST = TODO HACKING BUGS README.macosx gnetconfig.h.in README.win32 GNET.DSP config.h.win32 gnet.def gnet.m4 gnet.spec gnet.spec.in gnet.pc.in examples/makefile.mingw src/makefile.mingw src/gnet-private.h src/socks-private.h tests/makefile.mingw

View file

@ -1,6 +1,3 @@
$FreeBSD$
--- configure 2002/07/20 11:29:10 1.1
+++ configure 2002/07/20 11:29:19
@@ -6725,6 +6725,7 @@

View file

@ -0,0 +1,10 @@
--- doc/Makefile.in.orig Sun Feb 16 15:39:15 2003
+++ doc/Makefile.in Sun Feb 16 15:41:14 2003
@@ -104,7 +104,7 @@
# The directory containing the source code (if it contains documentation).
DOC_SOURCE_DIR = ..
-HTML_DIR = $(prefix)/share/doc/libgnet$(GNET_MAJOR_VERSION).$(GNET_MINOR_VERSION)-dev/html
+HTML_DIR = $(prefix)/share/doc/libgnet$(GNET_MAJOR_VERSION).$(GNET_MINOR_VERSION)-glib2-dev/html
TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)

View file

@ -0,0 +1,10 @@
--- gnet.pc.in.orig Sun Feb 16 15:17:15 2003
+++ gnet.pc.in Sun Feb 16 15:17:39 2003
@@ -6,5 +6,5 @@
Name: Gnet
Description: A network compatibility layer library
Version: @VERSION@
-Libs: -L${libdir} -lgnet @GLIB_LIBS@ @GTHREAD_LIBS@
-Cflags: -I${includedir}/gnet -I${libdir}/gnet/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@
+Libs: -L${libdir} -lgnet-glib2 @GLIB_LIBS@ @GTHREAD_LIBS@
+Cflags: -I${includedir}/gnet-glib2 -I${libdir}/gnet-glib2/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@

View file

@ -0,0 +1,23 @@
--- src/Makefile.in.orig Sun Feb 16 15:07:57 2003
+++ src/Makefile.in Sun Feb 16 15:09:08 2003
@@ -97,9 +97,9 @@
INCLUDES = -DG_LOG_DOMAIN=\"GNet\" @GNET_DEBUG_FLAGS@ $(GLIB_CFLAGS) $(GTHREAD_CFLAGS)
-gnetincludedir = $(includedir)/gnet
+gnetincludedir = $(includedir)/gnet-glib2
-lib_LTLIBRARIES = libgnet.la
+lib_LTLIBRARIES = libgnet-glib2.la
libgnet_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(GLIB_LIBS) $(GTHREAD_LIBS)
@@ -220,7 +220,7 @@
maintainer-clean-libtool:
-libgnet.la: $(libgnet_la_OBJECTS) $(libgnet_la_DEPENDENCIES)
+libgnet-glib2.la: $(libgnet_la_OBJECTS) $(libgnet_la_DEPENDENCIES)
$(LINK) -rpath $(libdir) $(libgnet_la_LDFLAGS) $(libgnet_la_OBJECTS) $(libgnet_la_LIBADD) $(LIBS)
install-gnetincludeHEADERS: $(gnetinclude_HEADERS)

View file

@ -1 +0,0 @@
A simple network library built upon Glib

View file

@ -1,3 +1,3 @@
A simple network library built upon glib.
A simple network library built upon glib2.
WWW: http://www.gnetlibrary.org/

View file

@ -1,50 +1,50 @@
bin/gnet-config
include/gnet/conn.h
include/gnet/gnet.h
include/gnet/gnetconfig.h
include/gnet/inetaddr.h
include/gnet/iochannel.h
include/gnet/mcast.h
include/gnet/md5.h
include/gnet/pack.h
include/gnet/server.h
include/gnet/sha.h
include/gnet/socks.h
include/gnet/tcp.h
include/gnet/udp.h
include/gnet/unix.h
include/gnet/url.h
lib/libgnet.a
lib/libgnet.so
lib/libgnet.so.1
libdata/pkgconfig/gnet.pc
share/aclocal/gnet.m4
share/doc/libgnet1.1-dev/html/book1.html
share/doc/libgnet1.1-dev/html/gnet-conn.html
share/doc/libgnet1.1-dev/html/gnet-developers-tips.html
share/doc/libgnet1.1-dev/html/gnet-developers.html
share/doc/libgnet1.1-dev/html/gnet-examples.html
share/doc/libgnet1.1-dev/html/gnet-gnet.html
share/doc/libgnet1.1-dev/html/gnet-inetaddr.html
share/doc/libgnet1.1-dev/html/gnet-iochannel.html
share/doc/libgnet1.1-dev/html/gnet-mcast.html
share/doc/libgnet1.1-dev/html/gnet-md5.html
share/doc/libgnet1.1-dev/html/gnet-overview.html
share/doc/libgnet1.1-dev/html/gnet-pack.html
share/doc/libgnet1.1-dev/html/gnet-server.html
share/doc/libgnet1.1-dev/html/gnet-sha.html
share/doc/libgnet1.1-dev/html/gnet-socks.html
share/doc/libgnet1.1-dev/html/gnet-tcp.html
share/doc/libgnet1.1-dev/html/gnet-udp.html
share/doc/libgnet1.1-dev/html/gnet-unix.html
share/doc/libgnet1.1-dev/html/gnet-url.html
share/doc/libgnet1.1-dev/html/hfetch.html
share/doc/libgnet1.1-dev/html/index.html
share/doc/libgnet1.1-dev/html/index.sgml
share/doc/libgnet1.1-dev/html/libgnet-reference.html
share/doc/libgnet1.1-dev/html/sdr.html
share/doc/libgnet1.1-dev/html/tests.html
@dirrm share/doc/libgnet1.1-dev/html
@dirrm share/doc/libgnet1.1-dev
bin/gnet-glib2-config
include/gnet-glib2/conn.h
include/gnet-glib2/gnet.h
include/gnet-glib2/gnetconfig.h
include/gnet-glib2/inetaddr.h
include/gnet-glib2/iochannel.h
include/gnet-glib2/mcast.h
include/gnet-glib2/md5.h
include/gnet-glib2/pack.h
include/gnet-glib2/server.h
include/gnet-glib2/sha.h
include/gnet-glib2/socks.h
include/gnet-glib2/tcp.h
include/gnet-glib2/udp.h
include/gnet-glib2/unix.h
include/gnet-glib2/url.h
lib/libgnet-glib2.a
lib/libgnet-glib2.so
lib/libgnet-glib2.so.7
libdata/pkgconfig/gnet-glib2.pc
share/aclocal/gnet-glib2.m4
share/doc/libgnet1.1-glib2-dev/html/book1.html
share/doc/libgnet1.1-glib2-dev/html/gnet-conn.html
share/doc/libgnet1.1-glib2-dev/html/gnet-developers-tips.html
share/doc/libgnet1.1-glib2-dev/html/gnet-developers.html
share/doc/libgnet1.1-glib2-dev/html/gnet-examples.html
share/doc/libgnet1.1-glib2-dev/html/gnet-gnet.html
share/doc/libgnet1.1-glib2-dev/html/gnet-inetaddr.html
share/doc/libgnet1.1-glib2-dev/html/gnet-iochannel.html
share/doc/libgnet1.1-glib2-dev/html/gnet-mcast.html
share/doc/libgnet1.1-glib2-dev/html/gnet-md5.html
share/doc/libgnet1.1-glib2-dev/html/gnet-overview.html
share/doc/libgnet1.1-glib2-dev/html/gnet-pack.html
share/doc/libgnet1.1-glib2-dev/html/gnet-server.html
share/doc/libgnet1.1-glib2-dev/html/gnet-sha.html
share/doc/libgnet1.1-glib2-dev/html/gnet-socks.html
share/doc/libgnet1.1-glib2-dev/html/gnet-tcp.html
share/doc/libgnet1.1-glib2-dev/html/gnet-udp.html
share/doc/libgnet1.1-glib2-dev/html/gnet-unix.html
share/doc/libgnet1.1-glib2-dev/html/gnet-url.html
share/doc/libgnet1.1-glib2-dev/html/hfetch.html
share/doc/libgnet1.1-glib2-dev/html/index.html
share/doc/libgnet1.1-glib2-dev/html/index.sgml
share/doc/libgnet1.1-glib2-dev/html/libgnet-reference.html
share/doc/libgnet1.1-glib2-dev/html/sdr.html
share/doc/libgnet1.1-glib2-dev/html/tests.html
@dirrm share/doc/libgnet1.1-glib2-dev/html
@dirrm share/doc/libgnet1.1-glib2-dev
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
@dirrm include/gnet
@dirrm include/gnet-glib2

View file

@ -1,24 +1,29 @@
# New ports collection makefile for: gnet
# Date created: 16 February 2000
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
# New ports collection makefile for: gnet-glib2
# Date created: 15 February 2003
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnet
PORTVERSION= 1.1.4
PORTVERSION= 1.1.8
CATEGORIES= net
MASTER_SITES= http://www.gnetlibrary.org/src/
MAINTAINER= nakai@FreeBSD.org
MAINTAINER= gnome@FreeBSD.org
COMMENT= A simple network library built upon Glib
LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
LATEST_LINK= gnet-glib2
USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gnomehack glib12
USE_GNOME= gnomehack
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-glib2
MAN1= gnet-config.1
MAN1= gnet-glib2-config.1
post-patch:
# fix pthreads detection
@ -30,14 +35,30 @@ post-patch:
# don't install gnet-config script with odd name. We will install it ourselves
@${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
${WRKSRC}/Makefile.in
# install gnet-config.1 man (not another name). Revise at EVERY port update
@${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
# don't install any of the config files. We will do it ourselves.
@${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E -e 's|^[[:space:]]+install-pkgconfigDATA$$||' \
${WRKSRC}/Makefile.in
# don't install the manpage. We will do it ourselves.
@${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1 install-data-local|' \
${WRKSRC}/doc/Makefile.in
# install configincludedir correctly
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)-glib2|' \
${WRKSRC}/Makefile.in
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
@${MKDIR} -p ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin/gnet-glib2-config
@${MKDIR} -p ${PREFIX}/share/aclocal
@${INSTALL_DATA} ${WRKSRC}/gnet.m4 ${PREFIX}/share/aclocal/gnet-glib2.m4
@${INSTALL_DATA} ${WRKSRC}/gnetconfig.h \
${PREFIX}/include/gnet-glib2
@${MKDIR} -p ${PREFIX}/libdata/pkgconfig
@${INSTALL_DATA} ${WRKSRC}/gnet.pc \
${PREFIX}/libdata/pkgconfig/gnet-glib2.pc
@${MKDIR} -p ${PREFIX}/man/man1
@${INSTALL_DATA} ${WRKSRC}/doc/gnet-config.1 \
${PREFIX}/man/man1/gnet-glib2-config.1
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gnet-1.1.4.tar.gz) = dbd03fc1bd34d611671a83564a225bb1
MD5 (gnet-1.1.8.tar.gz) = da2b5de278e96a5b907c2e2304bf6542

View file

@ -0,0 +1,10 @@
--- Makefile.in.orig Sun Feb 16 15:47:35 2003
+++ Makefile.in Sun Feb 16 15:48:54 2003
@@ -94,7 +94,7 @@
VERSION = @VERSION@
pthread_libs = @pthread_libs@
-SUBDIRS = src examples tests doc
+SUBDIRS = src doc
EXTRA_DIST = TODO HACKING BUGS README.macosx gnetconfig.h.in README.win32 GNET.DSP config.h.win32 gnet.def gnet.m4 gnet.spec gnet.spec.in gnet.pc.in examples/makefile.mingw src/makefile.mingw src/gnet-private.h src/socks-private.h tests/makefile.mingw

View file

@ -1,6 +1,3 @@
$FreeBSD$
--- configure 2002/07/20 11:29:10 1.1
+++ configure 2002/07/20 11:29:19
@@ -6725,6 +6725,7 @@

View file

@ -0,0 +1,10 @@
--- doc/Makefile.in.orig Sun Feb 16 15:39:15 2003
+++ doc/Makefile.in Sun Feb 16 15:41:14 2003
@@ -104,7 +104,7 @@
# The directory containing the source code (if it contains documentation).
DOC_SOURCE_DIR = ..
-HTML_DIR = $(prefix)/share/doc/libgnet$(GNET_MAJOR_VERSION).$(GNET_MINOR_VERSION)-dev/html
+HTML_DIR = $(prefix)/share/doc/libgnet$(GNET_MAJOR_VERSION).$(GNET_MINOR_VERSION)-glib2-dev/html
TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)

View file

@ -0,0 +1,10 @@
--- gnet.pc.in.orig Sun Feb 16 15:17:15 2003
+++ gnet.pc.in Sun Feb 16 15:17:39 2003
@@ -6,5 +6,5 @@
Name: Gnet
Description: A network compatibility layer library
Version: @VERSION@
-Libs: -L${libdir} -lgnet @GLIB_LIBS@ @GTHREAD_LIBS@
-Cflags: -I${includedir}/gnet -I${libdir}/gnet/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@
+Libs: -L${libdir} -lgnet-glib2 @GLIB_LIBS@ @GTHREAD_LIBS@
+Cflags: -I${includedir}/gnet-glib2 -I${libdir}/gnet-glib2/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@

View file

@ -0,0 +1,23 @@
--- src/Makefile.in.orig Sun Feb 16 15:07:57 2003
+++ src/Makefile.in Sun Feb 16 15:09:08 2003
@@ -97,9 +97,9 @@
INCLUDES = -DG_LOG_DOMAIN=\"GNet\" @GNET_DEBUG_FLAGS@ $(GLIB_CFLAGS) $(GTHREAD_CFLAGS)
-gnetincludedir = $(includedir)/gnet
+gnetincludedir = $(includedir)/gnet-glib2
-lib_LTLIBRARIES = libgnet.la
+lib_LTLIBRARIES = libgnet-glib2.la
libgnet_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(GLIB_LIBS) $(GTHREAD_LIBS)
@@ -220,7 +220,7 @@
maintainer-clean-libtool:
-libgnet.la: $(libgnet_la_OBJECTS) $(libgnet_la_DEPENDENCIES)
+libgnet-glib2.la: $(libgnet_la_OBJECTS) $(libgnet_la_DEPENDENCIES)
$(LINK) -rpath $(libdir) $(libgnet_la_LDFLAGS) $(libgnet_la_OBJECTS) $(libgnet_la_LIBADD) $(LIBS)
install-gnetincludeHEADERS: $(gnetinclude_HEADERS)

View file

@ -1 +0,0 @@
A simple network library built upon Glib

View file

@ -1,3 +1,3 @@
A simple network library built upon glib.
A simple network library built upon glib2.
WWW: http://www.gnetlibrary.org/

View file

@ -1,50 +1,50 @@
bin/gnet-config
include/gnet/conn.h
include/gnet/gnet.h
include/gnet/gnetconfig.h
include/gnet/inetaddr.h
include/gnet/iochannel.h
include/gnet/mcast.h
include/gnet/md5.h
include/gnet/pack.h
include/gnet/server.h
include/gnet/sha.h
include/gnet/socks.h
include/gnet/tcp.h
include/gnet/udp.h
include/gnet/unix.h
include/gnet/url.h
lib/libgnet.a
lib/libgnet.so
lib/libgnet.so.1
libdata/pkgconfig/gnet.pc
share/aclocal/gnet.m4
share/doc/libgnet1.1-dev/html/book1.html
share/doc/libgnet1.1-dev/html/gnet-conn.html
share/doc/libgnet1.1-dev/html/gnet-developers-tips.html
share/doc/libgnet1.1-dev/html/gnet-developers.html
share/doc/libgnet1.1-dev/html/gnet-examples.html
share/doc/libgnet1.1-dev/html/gnet-gnet.html
share/doc/libgnet1.1-dev/html/gnet-inetaddr.html
share/doc/libgnet1.1-dev/html/gnet-iochannel.html
share/doc/libgnet1.1-dev/html/gnet-mcast.html
share/doc/libgnet1.1-dev/html/gnet-md5.html
share/doc/libgnet1.1-dev/html/gnet-overview.html
share/doc/libgnet1.1-dev/html/gnet-pack.html
share/doc/libgnet1.1-dev/html/gnet-server.html
share/doc/libgnet1.1-dev/html/gnet-sha.html
share/doc/libgnet1.1-dev/html/gnet-socks.html
share/doc/libgnet1.1-dev/html/gnet-tcp.html
share/doc/libgnet1.1-dev/html/gnet-udp.html
share/doc/libgnet1.1-dev/html/gnet-unix.html
share/doc/libgnet1.1-dev/html/gnet-url.html
share/doc/libgnet1.1-dev/html/hfetch.html
share/doc/libgnet1.1-dev/html/index.html
share/doc/libgnet1.1-dev/html/index.sgml
share/doc/libgnet1.1-dev/html/libgnet-reference.html
share/doc/libgnet1.1-dev/html/sdr.html
share/doc/libgnet1.1-dev/html/tests.html
@dirrm share/doc/libgnet1.1-dev/html
@dirrm share/doc/libgnet1.1-dev
bin/gnet-glib2-config
include/gnet-glib2/conn.h
include/gnet-glib2/gnet.h
include/gnet-glib2/gnetconfig.h
include/gnet-glib2/inetaddr.h
include/gnet-glib2/iochannel.h
include/gnet-glib2/mcast.h
include/gnet-glib2/md5.h
include/gnet-glib2/pack.h
include/gnet-glib2/server.h
include/gnet-glib2/sha.h
include/gnet-glib2/socks.h
include/gnet-glib2/tcp.h
include/gnet-glib2/udp.h
include/gnet-glib2/unix.h
include/gnet-glib2/url.h
lib/libgnet-glib2.a
lib/libgnet-glib2.so
lib/libgnet-glib2.so.7
libdata/pkgconfig/gnet-glib2.pc
share/aclocal/gnet-glib2.m4
share/doc/libgnet1.1-glib2-dev/html/book1.html
share/doc/libgnet1.1-glib2-dev/html/gnet-conn.html
share/doc/libgnet1.1-glib2-dev/html/gnet-developers-tips.html
share/doc/libgnet1.1-glib2-dev/html/gnet-developers.html
share/doc/libgnet1.1-glib2-dev/html/gnet-examples.html
share/doc/libgnet1.1-glib2-dev/html/gnet-gnet.html
share/doc/libgnet1.1-glib2-dev/html/gnet-inetaddr.html
share/doc/libgnet1.1-glib2-dev/html/gnet-iochannel.html
share/doc/libgnet1.1-glib2-dev/html/gnet-mcast.html
share/doc/libgnet1.1-glib2-dev/html/gnet-md5.html
share/doc/libgnet1.1-glib2-dev/html/gnet-overview.html
share/doc/libgnet1.1-glib2-dev/html/gnet-pack.html
share/doc/libgnet1.1-glib2-dev/html/gnet-server.html
share/doc/libgnet1.1-glib2-dev/html/gnet-sha.html
share/doc/libgnet1.1-glib2-dev/html/gnet-socks.html
share/doc/libgnet1.1-glib2-dev/html/gnet-tcp.html
share/doc/libgnet1.1-glib2-dev/html/gnet-udp.html
share/doc/libgnet1.1-glib2-dev/html/gnet-unix.html
share/doc/libgnet1.1-glib2-dev/html/gnet-url.html
share/doc/libgnet1.1-glib2-dev/html/hfetch.html
share/doc/libgnet1.1-glib2-dev/html/index.html
share/doc/libgnet1.1-glib2-dev/html/index.sgml
share/doc/libgnet1.1-glib2-dev/html/libgnet-reference.html
share/doc/libgnet1.1-glib2-dev/html/sdr.html
share/doc/libgnet1.1-glib2-dev/html/tests.html
@dirrm share/doc/libgnet1.1-glib2-dev/html
@dirrm share/doc/libgnet1.1-glib2-dev
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
@dirrm include/gnet
@dirrm include/gnet-glib2