This program has not been updated by developer, and broken (depends on old
gd library), since 1999. Remove from tree.
This commit is contained in:
parent
bbd0418619
commit
5f925bcd6a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40544
12 changed files with 0 additions and 685 deletions
|
@ -1,41 +0,0 @@
|
|||
# New ports collection makefile for: tgd
|
||||
# Date created: 22 February 1999
|
||||
# Whom: mharo@area51.fremont.ca.us
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tgd
|
||||
PORTVERSION= 1.2c
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://probe.nalusda.gov/pub/treegenes/ \
|
||||
ftp://dendrome.ucdavis.edu/pub/tgd/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= mharo@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
|
||||
|
||||
BROKEN= gd changes
|
||||
FORBIDDEN= author hadn\'t had time to update for gd changes
|
||||
|
||||
ALL_TARGET= tgd
|
||||
DOCS= README arc.gif cap.gif char.gif fill.gif fontdemo \
|
||||
fontdemo.gif gd.html gifcap.pl helloworld.gif \
|
||||
helloworld.pl keygifcap.gif keypad.gif keypad.html \
|
||||
keypad.inp keypad.map keypad.pl poly.gif polydemo \
|
||||
rainbow.gif rainbow.pl tgd.gif tgd.html
|
||||
pre-build:
|
||||
${CP} ${FILESDIR}/tgdcommand.h ${WRKSRC}/
|
||||
${CP} ${FILESDIR}/tgdgd.h ${WRKSRC}/
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/tgd ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} -m 755 ${PREFIX}/share/doc/tgd
|
||||
.for file in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/${file} ${PREFIX}/share/doc/tgd
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (tgd1.2c.tar.gz) = 17842473dee8bb1f1cd09e68fd137f6a
|
|
@ -1,30 +0,0 @@
|
|||
--- Makefile.orig Mon Oct 7 15:31:25 1996
|
||||
+++ Makefile Sat Apr 3 11:15:32 1999
|
||||
@@ -26,11 +26,10 @@
|
||||
#
|
||||
PROG = tgd
|
||||
HOME = .
|
||||
-GDHOME = $(HOME)/gd1.2
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
CDEFS =
|
||||
-INCLUDE = -I$(HOME) -I$(GDHOME)
|
||||
-GDLIB = $(GDHOME)/libgd.a
|
||||
+INCLUDE = -I$(HOME) -I${PREFIX}/include/gd
|
||||
+GDLIB = ${PREFIX}/lib/libgd.a
|
||||
#
|
||||
# Some debugging/profiling options
|
||||
# CFLAGS = -p $(CDEFS) $(INCLUDE)
|
||||
@@ -40,10 +39,10 @@
|
||||
#
|
||||
# CFLAGS = -g $(CDEFS) $(INCLUDE)
|
||||
# LDFLAGS = -g -n
|
||||
-CFLAGS = $(CDEFS) $(INCLUDE)
|
||||
+CFLAGS += $(CDEFS) $(INCLUDE)
|
||||
LDFLAGS =
|
||||
|
||||
-LDLIBS = -L$(GDHOME) -lgd -lm
|
||||
+LDLIBS = -L${PREFIX}/lib -lgd -lm
|
||||
MAKEFILE = Makefile
|
||||
FONT1 = tgdFont10x20.c tgdFont12x24.c tgdFont5x8.c tgdFont6x10.c
|
||||
FONT2 = tgdFont6x12.c tgdFont6x13.c tgdFont6x13bold.c tgdFont6x9.c
|
|
@ -1,157 +0,0 @@
|
|||
--- tgd.c.orig Mon Oct 7 15:31:25 1996
|
||||
+++ tgd.c Sat Apr 3 11:41:37 1999
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <strings.h>
|
||||
#endif
|
||||
#include <ctype.h>
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#include "gd.h"
|
||||
#include "gdfontl.h"
|
||||
#include "gdfonts.h"
|
||||
@@ -40,6 +40,7 @@
|
||||
#include "gdfontt.h"
|
||||
#include "tgdsamfont.h"
|
||||
#include "tgd.h"
|
||||
+#include "tgdcommand.h"
|
||||
|
||||
static char SCCS[] = "@(#)tgd.c 1.6 10/13/95 tgd";
|
||||
static char *Current_file; /* Name of current input file */
|
||||
@@ -54,9 +55,11 @@
|
||||
COLOUR *colourbyname();
|
||||
TIM *timbyname();
|
||||
static void tgdgo();
|
||||
-static init();
|
||||
+static void init();
|
||||
+static void loadfonts();
|
||||
+static void unloadfonts();
|
||||
|
||||
-main( argc, argv )
|
||||
+int main( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -79,7 +82,7 @@
|
||||
fclose( fp );
|
||||
}
|
||||
}
|
||||
- exit( 0 );
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
|
||||
@@ -87,7 +90,7 @@
|
||||
* Unrecoverable error, terminate program with
|
||||
* a message.
|
||||
*/
|
||||
-die( s )
|
||||
+void die( char *s )
|
||||
{
|
||||
char buf[BUFSIZ];
|
||||
sprintf( buf, "tgd error is [%s]. Near line %d in file %s.\n",
|
||||
@@ -101,7 +104,7 @@
|
||||
* Setting Ldebug less than 0 will completely
|
||||
* shut program up.
|
||||
*/
|
||||
-tgdputs( s )
|
||||
+void tgdputs( s )
|
||||
char *s;
|
||||
{
|
||||
if ( Ldebug >= 0 )
|
||||
@@ -111,7 +114,7 @@
|
||||
/* --
|
||||
* All error reports should go through here.
|
||||
*/
|
||||
-tgdputerr( s )
|
||||
+void tgdputerr( char *s )
|
||||
{
|
||||
fprintf( Fp_err, "%s\n", s );
|
||||
}
|
||||
@@ -120,7 +123,7 @@
|
||||
* (Re)Initialize datastructures for each input file.
|
||||
*/
|
||||
static
|
||||
-init()
|
||||
+void init()
|
||||
{
|
||||
int i, j;
|
||||
|
||||
@@ -236,13 +239,14 @@
|
||||
}
|
||||
}
|
||||
die( "too many images" );
|
||||
+ return 0; /* turn off compiler warning */
|
||||
}
|
||||
|
||||
/* --
|
||||
* Called when we read in an image to synchronize
|
||||
* our conception of the image with the GD library.
|
||||
*/
|
||||
-timset( tim )
|
||||
+void timset( tim )
|
||||
TIM *tim;
|
||||
{
|
||||
int colors;
|
||||
@@ -306,7 +310,7 @@
|
||||
* off all standard output, including that from
|
||||
* printing functions.
|
||||
*/
|
||||
-tgddebug( argc, argv )
|
||||
+void tgddebug( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -316,7 +320,7 @@
|
||||
/* --
|
||||
* center the string on the given x y coords. (see imagestring)
|
||||
*/
|
||||
-tgdstringcenter( argc, argv )
|
||||
+void tgdstringcenter( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -347,7 +351,7 @@
|
||||
* Note that "macros" can be built
|
||||
* up out of text commands.
|
||||
*/
|
||||
-tgdstockimage( argc, argv )
|
||||
+void tgdstockimage( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -418,7 +422,7 @@
|
||||
/* --
|
||||
* Release argv strings
|
||||
*/
|
||||
-tgdargdestroy( argc, argv )
|
||||
+void tgdargdestroy( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -434,7 +438,7 @@
|
||||
/* --
|
||||
* Report on the current comand.
|
||||
*/
|
||||
-tgdshowvector( argc, argv )
|
||||
+void tgdshowvector( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -510,7 +514,7 @@
|
||||
* Font names are case-insenstive to user, so make names
|
||||
* all lower case here (cf. fontbyname() ).
|
||||
*/
|
||||
-loadfonts()
|
||||
+static void loadfonts()
|
||||
{
|
||||
/* Font kludge XXX */
|
||||
strcpy( Font[0].name, "gdfontsmall" );
|
||||
@@ -562,7 +566,7 @@
|
||||
/* --
|
||||
* Eventually will dump fonts out of memory
|
||||
*/
|
||||
-unloadfonts()
|
||||
+static void unloadfonts()
|
||||
{
|
||||
/* XXX */
|
||||
}
|
|
@ -1,19 +0,0 @@
|
|||
--- tgd.h.orig Sat Apr 3 11:26:30 1999
|
||||
+++ tgd.h Sat Apr 3 12:01:55 1999
|
||||
@@ -35,4 +35,16 @@
|
||||
COLOUR colour[MAXCOLOUR]; /* Map colour names to gd id's */
|
||||
} TIM; /* Map user supplied image name to a gd image pointer */
|
||||
|
||||
+/* prototypes */
|
||||
+void die( char * );
|
||||
+void tgdstringcenter( int, char ** );
|
||||
+void tgdputerr( char * );
|
||||
+void tgdstockimage( int, char ** );
|
||||
+void tgddebug( int, char ** );
|
||||
+void tgdargdestroy( int, char ** );
|
||||
+void tgdshowvector( int, char ** );
|
||||
+int tgdtokenize( char *, char** );
|
||||
+void tgdputs( char * );
|
||||
+void timset( TIM * );
|
||||
+
|
||||
#endif /* TGD_H */ /* End of file tgd.h */
|
|
@ -1,49 +0,0 @@
|
|||
--- tgdcommand.c.orig Sat Apr 3 11:38:42 1999
|
||||
+++ tgdcommand.c Sat Apr 3 12:12:23 1999
|
||||
@@ -8,6 +8,12 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <ctype.h>
|
||||
+#include <string.h>
|
||||
+#include "gd.h"
|
||||
+#include "tgd.h"
|
||||
+#include "tgdcommand.h"
|
||||
+#include "tgdgd.h"
|
||||
|
||||
static char SCCS[] = "@(#)tgdcommand.c 1.4 10/5/95 tgd";
|
||||
|
||||
@@ -170,6 +176,7 @@
|
||||
|
||||
strcat( buf, " is not a known command" );
|
||||
die( buf );
|
||||
+ return 0; /* turn off compiler warning */
|
||||
}
|
||||
|
||||
/* --
|
||||
@@ -184,6 +191,7 @@
|
||||
if ( cmd->id == id )
|
||||
return cmd;
|
||||
die( "command not found" ); /* XXX return NULL ? */
|
||||
+ return 0; /* turn off compiler warning */
|
||||
}
|
||||
|
||||
/* --
|
||||
@@ -205,7 +213,7 @@
|
||||
CMD *cmd;
|
||||
|
||||
if ( cmd_id == TGDBLANKLINE )
|
||||
- return;
|
||||
+ return 0; /* potential bug: value should be ignored */
|
||||
/* one character in argcheck for each argument */
|
||||
cmd = cmdbyid( cmd_id );
|
||||
for ( s = cmd->argcheck, count = 0; *s; s++, count++ ) {
|
||||
@@ -250,7 +258,7 @@
|
||||
/* --
|
||||
* Find the routine to handle the command.
|
||||
*/
|
||||
-tgdcommand( argc, argv )
|
||||
+void tgdcommand( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
|
@ -1,300 +0,0 @@
|
|||
--- tgdgd.c.orig Sat Apr 3 11:44:32 1999
|
||||
+++ tgdgd.c Sat Apr 3 12:02:18 1999
|
||||
@@ -16,8 +16,10 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include "gd.h"
|
||||
#include "tgd.h"
|
||||
+#include "tgdgd.h"
|
||||
|
||||
static char SCCS[] = "@(#)tgdgd.c 1.4 10/7/96 tgd";
|
||||
|
||||
@@ -32,7 +34,7 @@
|
||||
/* --
|
||||
* ... handle cx cy w h start_degrees end_degrees color
|
||||
*/
|
||||
-imagearc( argc, argv )
|
||||
+void imagearc( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -56,7 +58,7 @@
|
||||
/* --
|
||||
* handle color
|
||||
*/
|
||||
-imageblue( argc, argv )
|
||||
+void imageblue( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -96,7 +98,7 @@
|
||||
* ... handle font x y c color
|
||||
* (not sure whether char should be an integer, string for now.)
|
||||
*/
|
||||
-imagechar( argc, argv )
|
||||
+void imagechar( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -119,7 +121,7 @@
|
||||
/* --
|
||||
* ... handle font x y c color
|
||||
*/
|
||||
-imagecharup( argc, argv )
|
||||
+void imagecharup( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -142,7 +144,7 @@
|
||||
/* --
|
||||
* ... handle colorname red green blue
|
||||
*/
|
||||
-imagecolorallocate( argc, argv )
|
||||
+void imagecolorallocate( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -171,7 +173,7 @@
|
||||
* Prints closest user colorname to specified rgb.
|
||||
* ... handle r g b
|
||||
*/
|
||||
-imagecolorclosest( argc, argv )
|
||||
+void imagecolorclosest( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -217,7 +219,7 @@
|
||||
* Prints color name matching r g b,
|
||||
* or "-1" if no match.
|
||||
*/
|
||||
-imagecolorexact( argc, argv )
|
||||
+void imagecolorexact( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -246,7 +248,7 @@
|
||||
/* --
|
||||
* ... handle color
|
||||
*/
|
||||
-imagecolortransparent( argc, argv )
|
||||
+void imagecolortransparent( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -310,7 +312,7 @@
|
||||
/* --
|
||||
* ... handle x y
|
||||
*/
|
||||
-imagecreate( argc, argv )
|
||||
+void imagecreate( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -323,7 +325,7 @@
|
||||
/* --
|
||||
* ... handle filename
|
||||
*/
|
||||
-imagecreatefromgd( argc, argv )
|
||||
+void imagecreatefromgd( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -345,7 +347,7 @@
|
||||
/* --
|
||||
* ... handle filename
|
||||
*/
|
||||
-imagecreatefromgif( argc, argv )
|
||||
+void imagecreatefromgif( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -367,7 +369,7 @@
|
||||
* ... handle filename.xbm
|
||||
* XXX Not working?
|
||||
*/
|
||||
-imagecreatefromxbm( argc, argv )
|
||||
+void imagecreatefromxbm( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -388,7 +390,7 @@
|
||||
/* --
|
||||
* ... handle
|
||||
*/
|
||||
-imagecolorstotal( argc, argv )
|
||||
+void imagecolorstotal( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -403,7 +405,7 @@
|
||||
/* --
|
||||
* supposedly defunct in 1.1.1 kept for backwards compatibility
|
||||
*/
|
||||
-imagedashedline( argc, argv )
|
||||
+void imagedashedline( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -426,7 +428,7 @@
|
||||
/* --
|
||||
* ... handle
|
||||
*/
|
||||
-imagedestroy( argc, argv )
|
||||
+void imagedestroy( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -490,7 +492,7 @@
|
||||
/* --
|
||||
* ... handle x1, y1, x2, y2, color
|
||||
*/
|
||||
-imagefilledrectangle( argc, argv )
|
||||
+void imagefilledrectangle( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -511,7 +513,7 @@
|
||||
/* --
|
||||
* ... handle filename
|
||||
*/
|
||||
-imagegd( argc, argv )
|
||||
+void imagegd( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -537,7 +539,7 @@
|
||||
* ... handle
|
||||
* print 1 if interlaced 0 otherwise
|
||||
*/
|
||||
-imagegetinterlaced( argc, argv )
|
||||
+void imagegetinterlaced( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -553,7 +555,7 @@
|
||||
/* --
|
||||
* ... handle x y
|
||||
*/
|
||||
-imagegetpixel( argc, argv )
|
||||
+void imagegetpixel( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -561,7 +563,6 @@
|
||||
int x, y;
|
||||
int cdex;
|
||||
COLOUR *color;
|
||||
- char buf[100];
|
||||
if ( NULL == ( tim = timbyname( argv[1] ) ) )
|
||||
die( argv[1] );
|
||||
x = atoi( argv[2] );
|
||||
@@ -577,7 +578,7 @@
|
||||
/* --
|
||||
* Print user name for color which is transparent for this image.
|
||||
*/
|
||||
-imagegettransparent( argc, argv )
|
||||
+void imagegettransparent( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -600,7 +601,7 @@
|
||||
/*
|
||||
* imagegif handle filename
|
||||
*/
|
||||
-imagegif( argc, argv )
|
||||
+void imagegif( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -625,7 +626,7 @@
|
||||
/* --
|
||||
* ... handle color
|
||||
*/
|
||||
-imagegreen( argc, argv )
|
||||
+void imagegreen( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -664,7 +665,7 @@
|
||||
/* --
|
||||
* ... handle x1 y1 x2 y2 color
|
||||
*/
|
||||
-imageline( argc, argv )
|
||||
+void imageline( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -686,7 +687,7 @@
|
||||
/* --
|
||||
* handle x1 y1 ... xn yn n color
|
||||
*/
|
||||
-imagefilledpolygon( argc, argv )
|
||||
+void imagefilledpolygon( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -760,7 +761,7 @@
|
||||
/* --
|
||||
* ... handle color
|
||||
*/
|
||||
-imagered( argc, argv )
|
||||
+void imagered( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -779,7 +780,7 @@
|
||||
/* --
|
||||
* ... handle
|
||||
*/
|
||||
-imagesx( argc, argv )
|
||||
+void imagesx( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -796,7 +797,7 @@
|
||||
/* --
|
||||
* ... handle
|
||||
*/
|
||||
-imagesy( argc, argv )
|
||||
+void imagesy( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -815,7 +816,7 @@
|
||||
* ... handle brush_handle
|
||||
* Set a special color as the brush
|
||||
*/
|
||||
-imagesetbrush( argc, argv )
|
||||
+void imagesetbrush( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -894,7 +895,7 @@
|
||||
/* --
|
||||
* handle tile_handle
|
||||
*/
|
||||
-imagesettile( argc, argv )
|
||||
+void imagesettile( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -910,7 +911,7 @@
|
||||
/* --
|
||||
* ... handle font x y s color
|
||||
*/
|
||||
-imagestring( argc, argv )
|
||||
+void imagestring( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
||||
@@ -934,7 +935,7 @@
|
||||
/* --
|
||||
* ... handle font x y s color
|
||||
*/
|
||||
-imagestringup( argc, argv )
|
||||
+void imagestringup( argc, argv )
|
||||
int argc;
|
||||
char *argv[];
|
||||
{
|
|
@ -1,6 +0,0 @@
|
|||
#ifndef TGDCOMMAND_H
|
||||
#define TGDCOMMAND_H
|
||||
|
||||
void tgdcommand( int, char ** );
|
||||
|
||||
#endif
|
|
@ -1,47 +0,0 @@
|
|||
#ifndef TGDGD_H
|
||||
#define TGDGD_H
|
||||
|
||||
void imagearc( int, char ** );
|
||||
void imageblue( int, char ** );
|
||||
void imageboundssafe( int, char ** );
|
||||
void imagechar( int, char ** );
|
||||
void imagecolorallocate( int, char ** );
|
||||
void imagecolordeallocate( int, char ** );
|
||||
void imagecolorclosest( int, char ** );
|
||||
void imagecolorexact( int, char ** );
|
||||
void imagecolortransparent( int, char ** );
|
||||
void imagecopy( int, char ** );
|
||||
void imagecopyresized( int, char ** );
|
||||
void imagecreate( int, char ** );
|
||||
void imagecreatefromgd( int, char ** );
|
||||
void imagecreatefromgif( int, char ** );
|
||||
void imagecreatefromxbm( int, char ** );
|
||||
void imagecolorstotal( int, char ** );
|
||||
void imagedashedline( int, char ** );
|
||||
void imagedestroy( int, char ** );
|
||||
void imagefill( int, char ** );
|
||||
void imagefilltoborder( int, char ** );
|
||||
void imagefilledrectangle( int, char ** );
|
||||
void imagegd( int, char ** );
|
||||
void imagegetinterlaced( int, char ** );
|
||||
void imagegetpixel( int, char ** );
|
||||
void imagegettransparent( int, char ** );
|
||||
void imagegif( int, char ** );
|
||||
void imagegreen( int, char ** );
|
||||
void imageinterlace( int, char ** );
|
||||
void imageline( int, char ** );
|
||||
void imagefilledpolygon( int, char ** );
|
||||
void imagepolygon( int, char ** );
|
||||
void imagerectangle( int, char ** );
|
||||
void imagered( int, char ** );
|
||||
void imagesx( int, char ** );
|
||||
void imagesy( int, char ** );
|
||||
void imagesetbrush( int, char ** );
|
||||
void imagesetpixel( int, char ** );
|
||||
void imagesetstyle( int, char ** );
|
||||
void imagesettile( int, char ** );
|
||||
void imagestring( int, char ** );
|
||||
void imagestringup( int, char ** );
|
||||
void imagecharup( int, char ** );
|
||||
|
||||
#endif
|
|
@ -1 +0,0 @@
|
|||
A text based tool for creating and manipulating GIF images
|
|
@ -1,9 +0,0 @@
|
|||
tgd reads text files and writes GIF files. Typically, in a Unix
|
||||
environment, it would be at the end of a pipe: my_program | tgd. It
|
||||
can also be invoked on a file: tgd my_text_file. By using the special
|
||||
file handle stdout, it can be used in WWW applications to push images
|
||||
to a browser. It was born out of a desire to learn the gd graphics
|
||||
library and Perl simultaneously (but it can be used with any scripting
|
||||
language).
|
||||
|
||||
WWW: http://dendrome.ucdavis.edu/tgd/tgd.html
|
|
@ -1,25 +0,0 @@
|
|||
bin/tgd
|
||||
share/doc/tgd/README
|
||||
share/doc/tgd/arc.gif
|
||||
share/doc/tgd/cap.gif
|
||||
share/doc/tgd/char.gif
|
||||
share/doc/tgd/fill.gif
|
||||
share/doc/tgd/fontdemo
|
||||
share/doc/tgd/fontdemo.gif
|
||||
share/doc/tgd/gd.html
|
||||
share/doc/tgd/gifcap.pl
|
||||
share/doc/tgd/helloworld.gif
|
||||
share/doc/tgd/helloworld.pl
|
||||
share/doc/tgd/keygifcap.gif
|
||||
share/doc/tgd/keypad.gif
|
||||
share/doc/tgd/keypad.html
|
||||
share/doc/tgd/keypad.inp
|
||||
share/doc/tgd/keypad.map
|
||||
share/doc/tgd/keypad.pl
|
||||
share/doc/tgd/poly.gif
|
||||
share/doc/tgd/polydemo
|
||||
share/doc/tgd/rainbow.gif
|
||||
share/doc/tgd/rainbow.pl
|
||||
share/doc/tgd/tgd.gif
|
||||
share/doc/tgd/tgd.html
|
||||
@dirrm share/doc/tgd
|
Loading…
Reference in a new issue