Add new port novawm - A window manager for X, developed with speed, size,
and style in mind PR: ports/39572 Submitted by: Alexey Dokuchaev <danfe@regency.nsu.ru>
This commit is contained in:
parent
a820709400
commit
5fa9212a8b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61862
7 changed files with 80 additions and 0 deletions
|
@ -57,6 +57,7 @@
|
||||||
SUBDIR += metacity-setup
|
SUBDIR += metacity-setup
|
||||||
SUBDIR += mlvwm
|
SUBDIR += mlvwm
|
||||||
SUBDIR += mosfet-liquid
|
SUBDIR += mosfet-liquid
|
||||||
|
SUBDIR += novawm
|
||||||
SUBDIR += olvwm
|
SUBDIR += olvwm
|
||||||
SUBDIR += openbox
|
SUBDIR += openbox
|
||||||
SUBDIR += oroborus
|
SUBDIR += oroborus
|
||||||
|
|
32
x11-wm/novawm/Makefile
Normal file
32
x11-wm/novawm/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
# New ports collection makefile for: novawm
|
||||||
|
# Date created: 20 June 2002
|
||||||
|
# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= novawm
|
||||||
|
PORTVERSION= 0.7
|
||||||
|
CATEGORIES= x11-wm
|
||||||
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||||
|
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||||
|
DISTNAME= ${PORTNAME}-${PORTVERSION}_alpha
|
||||||
|
|
||||||
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
|
USE_XPM= yes
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
USE_X_PREFIX= yes
|
||||||
|
|
||||||
|
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
|
||||||
|
.if !defined(NOPORTDOCS)
|
||||||
|
@${MKDIR} ${DOCSDIR}
|
||||||
|
.for file in README COPYING AUTHORS ChangeLog INSTALL TODO
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||||
|
.endfor
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
x11-wm/novawm/distinfo
Normal file
1
x11-wm/novawm/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (novawm-0.7_alpha.tar.gz) = a98fde6d329588f6313ef87434250590
|
24
x11-wm/novawm/files/patch-Makefile.in
Normal file
24
x11-wm/novawm/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
--- src/Makefile.in.orig Wed Jun 5 11:22:00 2002
|
||||||
|
+++ src/Makefile.in Sun Jun 23 21:09:00 2002
|
||||||
|
@@ -73,10 +73,10 @@
|
||||||
|
PACKAGE_PIXMAPS_DIR = @PACKAGE_PIXMAPS_DIR@
|
||||||
|
VERSION = @VERSION@
|
||||||
|
|
||||||
|
-INCLUDES = -I/usr/X11R6/include
|
||||||
|
+INCLUDES = -I${X11BASE}/include
|
||||||
|
|
||||||
|
|
||||||
|
-CXXFLAGS = -D_WIN_GNOME_SUPPORT -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes -O2
|
||||||
|
+CXXFLAGS += -D_WIN_GNOME_SUPPORT -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes
|
||||||
|
|
||||||
|
|
||||||
|
bin_PROGRAMS = novawm
|
||||||
|
@@ -84,7 +84,7 @@
|
||||||
|
novawm_SOURCES = main.cpp events.cpp menu.cpp novawm.h winmgr.cpp bar.cpp config.cpp icon_close.xpm icon_hide.xpm icon_stretch.xpm
|
||||||
|
|
||||||
|
|
||||||
|
-novawm_LDFLAGS = -L/usr/X11R6/lib
|
||||||
|
+novawm_LDFLAGS = -L${X11BASE}/lib
|
||||||
|
|
||||||
|
|
||||||
|
novawm_LDADD = -lX11 -lXpm
|
1
x11-wm/novawm/pkg-comment
Normal file
1
x11-wm/novawm/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
A window manager for X, developed with speed, size, and style in mind
|
13
x11-wm/novawm/pkg-descr
Normal file
13
x11-wm/novawm/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
NovaWM is a new window manager for the X Windows System (X11). It is
|
||||||
|
developed with speed, size, and style in mind. NovaWM takes on its own
|
||||||
|
style that is different than ANY window manager. NovaWM isn't too large
|
||||||
|
and toyish like many popular window managers like the desktops (KDE and
|
||||||
|
GNOME). Also like some window managers NovaWM has its own toolkit that
|
||||||
|
is much easier to understand and develop with than most others though
|
||||||
|
NovaWM itself doesn't use the toolkit to create its interface, reducing
|
||||||
|
the dependency on other libraries. NovaWM was also developed with the
|
||||||
|
idea of integration and digital media in mind and so future versions of
|
||||||
|
NovaWM are planned to support easy application integration and have
|
||||||
|
support for integration of digital media applications.
|
||||||
|
|
||||||
|
WWW: http://novawm.sourceforge.net/
|
8
x11-wm/novawm/pkg-plist
Normal file
8
x11-wm/novawm/pkg-plist
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
bin/novawm
|
||||||
|
%%PORTDOCS%%share/doc/novawm/AUTHORS
|
||||||
|
%%PORTDOCS%%share/doc/novawm/COPYING
|
||||||
|
%%PORTDOCS%%share/doc/novawm/ChangeLog
|
||||||
|
%%PORTDOCS%%share/doc/novawm/INSTALL
|
||||||
|
%%PORTDOCS%%share/doc/novawm/README
|
||||||
|
%%PORTDOCS%%share/doc/novawm/TODO
|
||||||
|
%%PORTDOCS%%@dirrm share/doc/novawm
|
Loading…
Reference in a new issue