* Fix build on amd64
- use va_copy - Compile shared library with -fPIC * Respect CFLAGS
This commit is contained in:
parent
f77d3f13d3
commit
5faa5fa457
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116915
3 changed files with 31 additions and 9 deletions
|
@ -17,11 +17,7 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= An irc daeemon based on Bahamut and hybrid-7
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= md5sum.1
|
||||
MAN5= ircd.conf.5
|
||||
MAN8= ircd.8
|
||||
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --localstatedir=/var \
|
||||
--libdir=${PREFIX}/lib/tr-ircd \
|
||||
|
@ -30,6 +26,10 @@ CONFIGURE_ARGS= --localstatedir=/var \
|
|||
--enable-root \
|
||||
--with-fakehost-postfix=COM
|
||||
|
||||
MAN1= md5sum.1
|
||||
MAN5= ircd.conf.5
|
||||
MAN8= ircd.8
|
||||
|
||||
.if !defined(WITHOUT_SSL)
|
||||
USE_OPENSSL= yes
|
||||
CONFIGURE_ARGS+=--enable-openssl=${OPENSSLBASE}
|
||||
|
@ -41,14 +41,13 @@ CONFIGURE_ARGS+=--enable-small-nets
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
BROKEN= "Does not compile on amd64"
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
|
||||
CONFIGURE_ARGS+=--enable-ipv6
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s,-O2,${CFLAGS}," ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
@${ECHO} "Installing ${PREFIX}/etc/rc.d/tr-ircd.sh.sample startup file."
|
||||
@${INSTALL_SCRIPT} ${FILESDIR}/tr-ircd.sh \
|
||||
|
|
12
irc/tr-ircd/files/patch-ircsprintf.c
Normal file
12
irc/tr-ircd/files/patch-ircsprintf.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/ircsprintf.c.orig Sat Aug 21 13:36:50 2004
|
||||
+++ src/ircsprintf.c Sat Aug 21 13:37:15 2004
|
||||
@@ -316,7 +316,8 @@
|
||||
const char *format = pattern;
|
||||
char *buf = str;
|
||||
int len = 0;
|
||||
- va_list ap = vl;
|
||||
+ va_list ap;
|
||||
+ va_copy(ap,vl);
|
||||
|
||||
while (*format) {
|
||||
switch (*format) {
|
11
irc/tr-ircd/files/patch-wordfilter-Makefile.in
Normal file
11
irc/tr-ircd/files/patch-wordfilter-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- contrib/wordfilter/Makefile.in.orig Sat Aug 21 13:34:23 2004
|
||||
+++ contrib/wordfilter/Makefile.in Sat Aug 21 13:34:39 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
RANLIB = @RANLIB@
|
||||
MD5SUMS = @MD5SUMS@
|
||||
LEXLIB = @LEXLIB@
|
||||
-CFLAGS = @IRC_CFLAGS@ -DBASENAME=\"$(BN1)$(BN2)$(BN3)\" -DIRCD_PREFIX=\"@prefix@\"
|
||||
+CFLAGS = @IRC_CFLAGS@ -DBASENAME=\"$(BN1)$(BN2)$(BN3)\" -DIRCD_PREFIX=\"@prefix@\" -fPIC
|
||||
LDFLAGS = @LDFLAGS@
|
||||
MKDEP = @MKDEP@ -DBASENAME=\"$(BN1)$(BN2)$(BN3)\" -DIRCD_PREFIX=\"@prefix@\"
|
||||
MV = @MV@
|
Loading…
Reference in a new issue