- Update to 2.2

Submitted by:	Kurt Jaeger <pi@complx.LF.net>, krion
Approved by:	maintainer
This commit is contained in:
Kirill Ponomarev 2003-08-16 16:12:08 +00:00
parent 7409a9c423
commit 5fcd8f8072
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=87067
4 changed files with 54 additions and 30 deletions

View file

@ -6,21 +6,19 @@
#
PORTNAME= lft
PORTVERSION= 2.0
PORTVERSION= 2.2
CATEGORIES= net
MASTER_SITES= http://www.mainnerve.com/lft/ \
http://www.drkangel.org/sw/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= drkangel@drkangel.org
COMMENT= Layer 4 Traceroute program
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= Makefile.bsd
GNU_CONFIGURE= yes
MAN8= lft.8
do-install:
${INSTALL} -c -s -m 0555 -o root -g wheel ${WRKSRC}/lft ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/lft ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/lft.8 ${PREFIX}/man/man8
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (lft-2.0-src.tar.gz) = d7ae3bd202257f961bc24c2415d9a8bc
MD5 (lft-2.2.tar.gz) = 75d2a4f0e224733156a668ca04881c4b

View file

@ -1,20 +1,56 @@
--- lft.c.orig Wed Mar 5 16:16:09 2003
+++ lft.c Wed Mar 5 16:16:21 2003
@@ -928,7 +928,7 @@
// return; /* not for us */
--- lft.c.orig Thu May 8 00:43:30 2003
+++ lft.c Fri Aug 15 13:50:43 2003
@@ -76,6 +76,12 @@
#ifdef BSD
#include <machine/limits.h>
#endif
+#ifdef BSD_IP_STACK
+#include <errno.h>
+#include <sys/ioctl.h>
+#include <net/bpf.h>
+#include <pcap-int.h>
+#endif
#ifdef sun
#include <limits.h>
@@ -961,7 +967,7 @@
return; * not for us */
- if (noisy) printf ("ICMP %u\n", ntohl (tcp->th_seq));
+ if (noisy) printf ("ICMP %lu\n", ntohl (tcp->th_seq));
- if (noisy) printf ("ICMP SEQ=%u received\n", ntohl (tcp->th_seq));
+ if (noisy) printf ("ICMP SEQ=%lu received\n", ntohl (tcp->th_seq));
recv_packet (ntohl (tcp->th_seq) , orig_ip->ip_src,
(icmp->icmp_type == ICMP_TIMXCEED) ? -2 : icmp->icmp_code);
break;
@@ -949,7 +949,7 @@
if (noisy) printf (" ACK ");
if (tcp->th_flags & TH_SYN)
if (noisy) printf (" SYN ");
- if (noisy) printf (" seq %u ack %u ", ntohl (tcp->th_seq), ntohl (tcp->th_ack));
+ if (noisy) printf (" seq %lu ack %lu ", ntohl (tcp->th_seq), ntohl (tcp->th_ack));
if (noisy) printf ("from %s\n", inet_ntoa (ip->ip_src));
@@ -1046,6 +1052,9 @@
"LFT version 2.2 2003/05/07 compiled for " HOST_SYSTEM_TYPE "\n\n"
" Compile-time options:\n\n"
#if defined(BSD_IP_STACK)
+ " + BSDSTACK\n"
+#endif
+#if defined(BSD)
" + BSD\n"
#endif
#if defined(linux)
@@ -1111,6 +1120,7 @@
int use_fins = 0;
char *cp;
struct timeval tb;
+ unsigned int bpfimmflag;
//if (ntohl(tcp->th_ack) < seq_start || ntohl(tcp->th_ack) > seq_start + trace_packet_info_length + 1)
setbuf (stdout, NULL);
@@ -1311,6 +1321,13 @@
fprintf (stderr, "%s\n", ebuf);
exit (1);
}
+#ifdef BSD_IP_STACK
+ bpfimmflag = 1;
+ if ( ioctl(pd->fd, BIOCIMMEDIATE, &bpfimmflag) < 0) {
+ fprintf(stderr, "BIOCIMMEDIATE: %s",
+ pcap_strerror(errno));
+ }
+#endif
#endif
init_address (hostname, pcap_dev);
open_sockets ();

View file

@ -1,10 +0,0 @@
--- lft_ifname.c.orig Wed Mar 5 16:16:49 2003
+++ lft_ifname.c Wed Mar 5 16:17:05 2003
@@ -19,6 +19,7 @@
#ifndef linux
#include <sys/sockio.h>
#endif
+#include <netinet/in.h>
#include <arpa/inet.h>
#include <netinet/in.h>
#include <net/if.h>