x11/xpra-html5: Update to 11.0
Reported by: portscout!
This commit is contained in:
parent
be962746bf
commit
600442ff68
3 changed files with 24 additions and 4 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= xpra-html5
|
PORTNAME= xpra-html5
|
||||||
PORTVERSION= 10.1
|
PORTVERSION= 11.0
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
CATEGORIES= x11
|
CATEGORIES= x11
|
||||||
|
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1702808196
|
TIMESTAMP = 1707565309
|
||||||
SHA256 (Xpra-org-xpra-html5-v10.1_GH0.tar.gz) = cea097b38ad57d5119be729f1378c5bad7b99e99c035e792241d383975154368
|
SHA256 (Xpra-org-xpra-html5-v11.0_GH0.tar.gz) = f306707377702f47898fec308f6c0dd18b1b7f96f8ef19d35e2ad44c08c3c215
|
||||||
SIZE (Xpra-org-xpra-html5-v10.1_GH0.tar.gz) = 2354055
|
SIZE (Xpra-org-xpra-html5-v11.0_GH0.tar.gz) = 2354981
|
||||||
|
|
20
x11/xpra-html5/files/patch-setup.py
Normal file
20
x11/xpra-html5/files/patch-setup.py
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
--- setup.py.orig 2024-01-31 12:10:11 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -50,7 +50,7 @@ def get_output_line(cmd: str) -> str:
|
||||||
|
out, _ = proc.communicate()
|
||||||
|
if proc.returncode != 0:
|
||||||
|
print(f"Error: {cmd} returned {proc.returncode}")
|
||||||
|
- return None
|
||||||
|
+ return ""
|
||||||
|
return out.splitlines()[0]
|
||||||
|
|
||||||
|
|
||||||
|
@@ -316,7 +316,7 @@ def install_html5(root="/", install_dir="/usr/share/xp
|
||||||
|
jar = yuicompressor.get_jar_filename()
|
||||||
|
java_cmd = os.environ.get("JAVA", "java")
|
||||||
|
minify_cmd = [java_cmd, "-jar", jar]
|
||||||
|
- except OSError:
|
||||||
|
+ except:
|
||||||
|
minify_cmd = ["yuicompressor"]
|
||||||
|
minify_cmd += [
|
||||||
|
fsrc,
|
Loading…
Reference in a new issue