Adding cd-control version 2.3.
A curses-based console CD player. PR: 15152 Submitted by: Julian C. Dunn <jdunn@aquezada.com>
This commit is contained in:
parent
119254c786
commit
600ae94e73
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24051
8 changed files with 81 additions and 0 deletions
|
@ -6,6 +6,7 @@
|
|||
SUBDIR += aumix
|
||||
SUBDIR += bladeenc
|
||||
SUBDIR += cam
|
||||
SUBDIR += cd-control
|
||||
SUBDIR += cdd
|
||||
SUBDIR += cdindex
|
||||
SUBDIR += cdplay
|
||||
|
|
16
audio/cd-console/Makefile
Normal file
16
audio/cd-console/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# New ports collection makefile for: cd-console
|
||||
# Version required: 2.1
|
||||
# Date created: Sun Nov 28 19:55:19 EST 1999
|
||||
# Whom: jdunn@aquezada.com
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= cd-console-2.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.cs.helsinki.fi/~salerma/cd-console/ \
|
||||
ftp://ftp.aquezada.com/pub/cd-console/
|
||||
|
||||
MAINTAINER= jdunn@aquezada.com
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/cd-console/distinfo
Normal file
1
audio/cd-console/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (cd-console-2.3.tar.gz) = b5b9b75b8dbb89a970cdc380e4cc54ec
|
41
audio/cd-console/files/patch-aa
Normal file
41
audio/cd-console/files/patch-aa
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- Makefile.orig Sun Nov 28 20:08:56 1999
|
||||
+++ Makefile Sun Nov 28 20:14:20 1999
|
||||
@@ -5,17 +5,17 @@
|
||||
# very welcome).
|
||||
|
||||
# for linux
|
||||
-DEFS = -DOS_LINUX
|
||||
-EXTRA_OBJS = cd_ll_linux.o
|
||||
+#DEFS = -DOS_LINUX
|
||||
+#EXTRA_OBJS = cd_ll_linux.o
|
||||
|
||||
# for bsd. only tested on freebsd
|
||||
-#DEFS = -DOS_BSD
|
||||
-#EXTRA_OBJS = cd_ll_bsd.o
|
||||
-
|
||||
+DEFS = -DOS_BSD
|
||||
+EXTRA_OBJS = cd_ll_bsd.o
|
||||
+CDDEVICE=\"/dev/acd0c\"
|
||||
|
||||
# you shouldn't have to change anything below this line
|
||||
|
||||
-
|
||||
+BINPATH=${PREFIX}/bin/
|
||||
OBJS=cd-console.o cd.o $(EXTRA_OBJS)
|
||||
LIBS = -lncurses
|
||||
|
||||
@@ -38,10 +38,13 @@
|
||||
$(CC) -c cd_ll_linux.cpp $(CFLAGS)
|
||||
|
||||
cd_ll_bsd.o: cd_ll.h cd_ll_bsd.h cd_ll_bsd.cpp
|
||||
- $(CC) -c cd_ll_bsd.cpp $(CFLAGS)
|
||||
+ $(CC) -c -DDEVICE=$(CDDEVICE) cd_ll_bsd.cpp $(CFLAGS)
|
||||
|
||||
cd.o: cd.h cd.cpp
|
||||
$(CC) -c cd.cpp $(CFLAGS)
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) cd-console
|
||||
+
|
||||
+install:
|
||||
+ @$(BSD_INSTALL_PROGRAM) cd-console $(BINPATH)
|
12
audio/cd-console/files/patch-ab
Normal file
12
audio/cd-console/files/patch-ab
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- cd_ll_bsd.cpp.orig Sun Nov 28 20:14:31 1999
|
||||
+++ cd_ll_bsd.cpp Sun Nov 28 20:15:29 1999
|
||||
@@ -10,7 +10,9 @@
|
||||
#include "cd_ll_bsd.h"
|
||||
|
||||
// the cd-rom device file
|
||||
+#ifndef DEVICE
|
||||
#define DEVICE "/dev/acd0c"
|
||||
+#endif
|
||||
|
||||
cd_ll_bsd::cd_ll_bsd()
|
||||
: m_fd(-1)
|
1
audio/cd-console/pkg-comment
Normal file
1
audio/cd-console/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A curses-based console CD player
|
8
audio/cd-console/pkg-descr
Normal file
8
audio/cd-console/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
A curses-based console CD player, with two viewing modes,
|
||||
one suitable for a 7x41 xterm.
|
||||
|
||||
WWW: http://www.cs.helsinki.fi/~salerma/cd-console/
|
||||
Author: Osku Salerma, osku@iki.fi
|
||||
|
||||
- Julian
|
||||
jdunn@aquezada.com
|
1
audio/cd-console/pkg-plist
Normal file
1
audio/cd-console/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/cd-console
|
Loading…
Reference in a new issue