Add a \0-terminating patch
Submitted by: Andriy Gapon Make portlint a little happier. Bump PORTREVISION.
This commit is contained in:
parent
1c08b00624
commit
60100449d8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=290721
3 changed files with 14 additions and 6 deletions
|
@ -7,24 +7,26 @@
|
|||
|
||||
PORTNAME= libfpx
|
||||
PORTVERSION= 1.2.0.12
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= ehaupt
|
||||
|
||||
PATCHFILES= fpx.mega-patch.2007-11-01.bz2
|
||||
PATCH_SITES= http://aldan.algebra.com/~mi/
|
||||
|
||||
MAINTAINER= mi@aldan.algebra.com
|
||||
COMMENT= Library routines for working with Flashpix images
|
||||
|
||||
MAKE_ARGS+= -j`${SYSCTL} -n hw.ncpu`
|
||||
USE_BZIP2= yes
|
||||
|
||||
post-patch:
|
||||
${RM} ${WRKSRC}/ri_image/wchar.c ${WRKSRC}/fpx/fpxlib.h
|
||||
|
||||
PLIST_FILES=lib/libfpx.so.2 lib/libfpx.so lib/libfpx.a include/fpxlib.h
|
||||
USE_LDCONFIG= yes
|
||||
MAKEFILE= ${FILESDIR}/Makefile.bsd
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
||||
|
|
10
graphics/libfpx/files/patch-aa
Normal file
10
graphics/libfpx/files/patch-aa
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- fpx/f_fpxvw.cpp 2005-02-25 21:23:05.000000000 -0500
|
||||
+++ fpx/f_fpxvw.cpp 2012-01-19 19:44:34.425688599 +0200
|
||||
@@ -613,6 +613,7 @@ HRESULT OleRegGetUserType(REFCLSID clsid
|
||||
const OLECHAR *src=OLESTR("Flashpix Toolkit Application");
|
||||
OLECHAR *dest=*pszUserType;
|
||||
while(*src) *dest++=*src++;
|
||||
+ *dest=(OLECHAR)0;
|
||||
|
||||
return S_OK;
|
||||
}
|
|
@ -1,4 +0,0 @@
|
|||
lib/libfpx.so.2
|
||||
lib/libfpx.so
|
||||
lib/libfpx.a
|
||||
include/fpxlib.h
|
Loading…
Reference in a new issue