Update to 2.3.16.
This commit is contained in:
parent
35596508ea
commit
60366b3953
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246372
12 changed files with 102 additions and 54 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= cyrus-imapd
|
||||
PORTVERSION= 2.3.15
|
||||
PORTVERSION= 2.3.16
|
||||
#PORTREVISION= 0
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus/ \
|
||||
|
@ -118,7 +118,8 @@ CONFIGURE_ARGS+=--enable-netscapehack
|
|||
|
||||
.if defined(WITH_DRAC)
|
||||
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cmulocal::ucdsnmp.m4 \
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cmulocal::sasl2.m4 \
|
||||
${FILESDIR}/extra-patch-cmulocal::ucdsnmp.m4 \
|
||||
${FILESDIR}/extra-patch-configure.in
|
||||
USE_AUTOTOOLS= autoconf:262 autoheader:262
|
||||
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (cyrus-imapd-2.3.15.tar.gz) = d89cb1b55023188938f332b7ef120fae
|
||||
SHA256 (cyrus-imapd-2.3.15.tar.gz) = 66d94f442356bd14f0d21dea63a5138ca1197a603646dbaab596ab5453b85e7a
|
||||
SIZE (cyrus-imapd-2.3.15.tar.gz) = 2370826
|
||||
MD5 (cyrus-imapd-2.3.16.tar.gz) = 6a37feb1985974eee8a4a4b2932dd54c
|
||||
SHA256 (cyrus-imapd-2.3.16.tar.gz) = e020ac79403a683bddc136c25887fe501edcc8d73b308982f4b68ec828ab63d2
|
||||
SIZE (cyrus-imapd-2.3.16.tar.gz) = 2359349
|
||||
|
|
22
mail/cyrus-imapd23/files/extra-patch-cmulocal::sasl2.m4
Normal file
22
mail/cyrus-imapd23/files/extra-patch-cmulocal::sasl2.m4
Normal file
|
@ -0,0 +1,22 @@
|
|||
Index: cmulocal/sasl2.m4
|
||||
diff -u cmulocal/sasl2.m4.orig cmulocal/sasl2.m4
|
||||
--- cmulocal/sasl2.m4.orig 2009-05-20 21:24:48.000000000 +0900
|
||||
+++ cmulocal/sasl2.m4 2009-12-22 00:31:16.153536453 +0900
|
||||
@@ -105,7 +105,7 @@
|
||||
if test "$gss_impl" = "auto" -o "$gss_impl" = "heimdal"; then
|
||||
gss_failed=0
|
||||
AC_CHECK_LIB(gssapi,gss_unwrap,gss_impl="heimdal",gss_failed=1,
|
||||
- ${GSSAPIBASE_LIBS} -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err ${LIB_SOCKET})
|
||||
+ ${GSSAPIBASE_LIBS} -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err ${LIB_SOCKET} -lhx509)
|
||||
if test "$gss_impl" != "auto" -a "$gss_failed" = "1"; then
|
||||
gss_impl="failed"
|
||||
fi
|
||||
@@ -173,7 +173,7 @@
|
||||
GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_LIBS $gssapi_dir/libgssapi_krb5.a $gssapi_dir/libkrb5.a $gssapi_dir/libk5crypto.a $gssapi_dir/libcom_err.a ${K5SUPSTATIC}"
|
||||
elif test "$gss_impl" = "heimdal"; then
|
||||
CPPFLAGS="$CPPFLAGS -DKRB5_HEIMDAL"
|
||||
- GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err"
|
||||
+ GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err -lhx509"
|
||||
GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_STATIC_LIBS $gssapi_dir/libgssapi.a $gssapi_dir/libkrb5.a $gssapi_dir/libasn1.a $gssapi_dir/libroken.a $gssapi_dir/libcom_err.a ${LIB_CRYPT}"
|
||||
elif test "$gss_impl" = "cybersafe03"; then
|
||||
# Version of CyberSafe with two libraries
|
|
@ -1,13 +1,13 @@
|
|||
Index: configure.in
|
||||
diff -u configure.in.orig configure.in
|
||||
--- configure.in.orig Sat May 29 04:59:21 2004
|
||||
+++ configure.in Sat May 29 05:03:04 2004
|
||||
@@ -933,7 +933,7 @@
|
||||
dnl add perl cccdlflags when building libraries -- this ensures that the
|
||||
--- configure.in.orig 2009-12-21 23:17:00.962723262 +0900
|
||||
+++ configure.in 2009-12-21 23:18:07.032701766 +0900
|
||||
@@ -1145,7 +1145,7 @@
|
||||
dnl libraries will be compiled as PIC if perl requires PIC objects
|
||||
dnl -- this is needed on NetBSD, but seems to cause problems on atleast Solaris --
|
||||
-dnl eval `${PERL} -V:cccdlflags`
|
||||
+ eval `${PERL} -V:cccdlflags`
|
||||
PERL_CCCDLFLAGS="$cccdlflags"
|
||||
AC_SUBST(PERL_CCCDLFLAGS)
|
||||
fi
|
||||
dnl -- this is needed on NetBSD and Linux, but seems to cause problems on atleast Solaris --
|
||||
case "${target_os}" in
|
||||
- linux*|netbsd*)
|
||||
+ linux*|netbsd*|freebsd*)
|
||||
AC_MSG_CHECKING(for perl cccdlflags needed on "${target_os}")
|
||||
eval `${PERL} -V:cccdlflags`
|
||||
PERL_CCCDLFLAGS="$cccdlflags"
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
Index: configure
|
||||
diff -u configure.orig configure
|
||||
--- configure.orig 2009-03-13 21:19:01.000000000 +0900
|
||||
+++ configure 2009-03-15 16:16:50.000000000 +0900
|
||||
--- configure.orig 2009-12-21 23:20:56.817376076 +0900
|
||||
+++ configure 2009-12-21 23:21:49.196653299 +0900
|
||||
@@ -642,6 +642,7 @@
|
||||
IMAP_COM_ERR_LIBS
|
||||
LIB_RT
|
||||
|
@ -9,16 +9,17 @@ diff -u configure.orig configure
|
|||
+LDFLAGS_UCDSNMP
|
||||
SNMP_CONFIG
|
||||
LIB_WRAP
|
||||
CMU_LIB_SUBDIR
|
||||
@@ -19030,6 +19031,7 @@
|
||||
EXTRA_SUBDIRS="${EXTRA_SUBDIRS} perl"
|
||||
SNMP_SUBDIRS
|
||||
@@ -20173,7 +20174,7 @@
|
||||
PERL_SUBDIRS="imap"
|
||||
PERL="${with_perl}"
|
||||
+ eval `${PERL} -V:cccdlflags`
|
||||
PERL_CCCDLFLAGS="$cccdlflags"
|
||||
|
||||
fi
|
||||
@@ -19984,7 +19986,9 @@
|
||||
case "${target_os}" in
|
||||
- linux*|netbsd*)
|
||||
+ linux*|netbsd*|freebsd*)
|
||||
{ $as_echo "$as_me:$LINENO: checking for perl cccdlflags needed on \"${target_os}\"" >&5
|
||||
$as_echo_n "checking for perl cccdlflags needed on \"${target_os}\"... " >&6; }
|
||||
eval `${PERL} -V:cccdlflags`
|
||||
@@ -20749,7 +20750,9 @@
|
||||
|
||||
if test -n "$SNMP_LIBS" && test -n "$SNMP_PREFIX"; then
|
||||
CPPFLAGS="$CPPFLAGS -I${SNMP_PREFIX}/include"
|
||||
|
@ -29,7 +30,7 @@ diff -u configure.orig configure
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_NETSNMP 1
|
||||
@@ -20224,7 +20228,7 @@
|
||||
@@ -21135,7 +21138,7 @@
|
||||
#define HAVE_UCDSNMP 1
|
||||
_ACEOF
|
||||
|
||||
|
|
|
@ -53,7 +53,7 @@ case $2 in
|
|||
echo
|
||||
else
|
||||
echo
|
||||
echo "** Please add an entry for the sieve protocol (2000/tcp)"
|
||||
echo "** Please add an entry for the sieve protocol (4190/tcp)"
|
||||
echo " to /etc/services"
|
||||
echo
|
||||
fi
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= cyrus-imapd
|
||||
PORTVERSION= 2.3.15
|
||||
PORTVERSION= 2.3.16
|
||||
#PORTREVISION= 0
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus/ \
|
||||
|
@ -118,7 +118,8 @@ CONFIGURE_ARGS+=--enable-netscapehack
|
|||
|
||||
.if defined(WITH_DRAC)
|
||||
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cmulocal::ucdsnmp.m4 \
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cmulocal::sasl2.m4 \
|
||||
${FILESDIR}/extra-patch-cmulocal::ucdsnmp.m4 \
|
||||
${FILESDIR}/extra-patch-configure.in
|
||||
USE_AUTOTOOLS= autoconf:262 autoheader:262
|
||||
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (cyrus-imapd-2.3.15.tar.gz) = d89cb1b55023188938f332b7ef120fae
|
||||
SHA256 (cyrus-imapd-2.3.15.tar.gz) = 66d94f442356bd14f0d21dea63a5138ca1197a603646dbaab596ab5453b85e7a
|
||||
SIZE (cyrus-imapd-2.3.15.tar.gz) = 2370826
|
||||
MD5 (cyrus-imapd-2.3.16.tar.gz) = 6a37feb1985974eee8a4a4b2932dd54c
|
||||
SHA256 (cyrus-imapd-2.3.16.tar.gz) = e020ac79403a683bddc136c25887fe501edcc8d73b308982f4b68ec828ab63d2
|
||||
SIZE (cyrus-imapd-2.3.16.tar.gz) = 2359349
|
||||
|
|
22
mail/cyrus-imapd24/files/extra-patch-cmulocal::sasl2.m4
Normal file
22
mail/cyrus-imapd24/files/extra-patch-cmulocal::sasl2.m4
Normal file
|
@ -0,0 +1,22 @@
|
|||
Index: cmulocal/sasl2.m4
|
||||
diff -u cmulocal/sasl2.m4.orig cmulocal/sasl2.m4
|
||||
--- cmulocal/sasl2.m4.orig 2009-05-20 21:24:48.000000000 +0900
|
||||
+++ cmulocal/sasl2.m4 2009-12-22 00:31:16.153536453 +0900
|
||||
@@ -105,7 +105,7 @@
|
||||
if test "$gss_impl" = "auto" -o "$gss_impl" = "heimdal"; then
|
||||
gss_failed=0
|
||||
AC_CHECK_LIB(gssapi,gss_unwrap,gss_impl="heimdal",gss_failed=1,
|
||||
- ${GSSAPIBASE_LIBS} -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err ${LIB_SOCKET})
|
||||
+ ${GSSAPIBASE_LIBS} -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err ${LIB_SOCKET} -lhx509)
|
||||
if test "$gss_impl" != "auto" -a "$gss_failed" = "1"; then
|
||||
gss_impl="failed"
|
||||
fi
|
||||
@@ -173,7 +173,7 @@
|
||||
GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_LIBS $gssapi_dir/libgssapi_krb5.a $gssapi_dir/libkrb5.a $gssapi_dir/libk5crypto.a $gssapi_dir/libcom_err.a ${K5SUPSTATIC}"
|
||||
elif test "$gss_impl" = "heimdal"; then
|
||||
CPPFLAGS="$CPPFLAGS -DKRB5_HEIMDAL"
|
||||
- GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err"
|
||||
+ GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} ${LIB_DES} -lcom_err -lhx509"
|
||||
GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_STATIC_LIBS $gssapi_dir/libgssapi.a $gssapi_dir/libkrb5.a $gssapi_dir/libasn1.a $gssapi_dir/libroken.a $gssapi_dir/libcom_err.a ${LIB_CRYPT}"
|
||||
elif test "$gss_impl" = "cybersafe03"; then
|
||||
# Version of CyberSafe with two libraries
|
|
@ -1,13 +1,13 @@
|
|||
Index: configure.in
|
||||
diff -u configure.in.orig configure.in
|
||||
--- configure.in.orig Sat May 29 04:59:21 2004
|
||||
+++ configure.in Sat May 29 05:03:04 2004
|
||||
@@ -933,7 +933,7 @@
|
||||
dnl add perl cccdlflags when building libraries -- this ensures that the
|
||||
--- configure.in.orig 2009-12-21 23:17:00.962723262 +0900
|
||||
+++ configure.in 2009-12-21 23:18:07.032701766 +0900
|
||||
@@ -1145,7 +1145,7 @@
|
||||
dnl libraries will be compiled as PIC if perl requires PIC objects
|
||||
dnl -- this is needed on NetBSD, but seems to cause problems on atleast Solaris --
|
||||
-dnl eval `${PERL} -V:cccdlflags`
|
||||
+ eval `${PERL} -V:cccdlflags`
|
||||
PERL_CCCDLFLAGS="$cccdlflags"
|
||||
AC_SUBST(PERL_CCCDLFLAGS)
|
||||
fi
|
||||
dnl -- this is needed on NetBSD and Linux, but seems to cause problems on atleast Solaris --
|
||||
case "${target_os}" in
|
||||
- linux*|netbsd*)
|
||||
+ linux*|netbsd*|freebsd*)
|
||||
AC_MSG_CHECKING(for perl cccdlflags needed on "${target_os}")
|
||||
eval `${PERL} -V:cccdlflags`
|
||||
PERL_CCCDLFLAGS="$cccdlflags"
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
Index: configure
|
||||
diff -u configure.orig configure
|
||||
--- configure.orig 2009-03-13 21:19:01.000000000 +0900
|
||||
+++ configure 2009-03-15 16:16:50.000000000 +0900
|
||||
--- configure.orig 2009-12-21 23:20:56.817376076 +0900
|
||||
+++ configure 2009-12-21 23:21:49.196653299 +0900
|
||||
@@ -642,6 +642,7 @@
|
||||
IMAP_COM_ERR_LIBS
|
||||
LIB_RT
|
||||
|
@ -9,16 +9,17 @@ diff -u configure.orig configure
|
|||
+LDFLAGS_UCDSNMP
|
||||
SNMP_CONFIG
|
||||
LIB_WRAP
|
||||
CMU_LIB_SUBDIR
|
||||
@@ -19030,6 +19031,7 @@
|
||||
EXTRA_SUBDIRS="${EXTRA_SUBDIRS} perl"
|
||||
SNMP_SUBDIRS
|
||||
@@ -20173,7 +20174,7 @@
|
||||
PERL_SUBDIRS="imap"
|
||||
PERL="${with_perl}"
|
||||
+ eval `${PERL} -V:cccdlflags`
|
||||
PERL_CCCDLFLAGS="$cccdlflags"
|
||||
|
||||
fi
|
||||
@@ -19984,7 +19986,9 @@
|
||||
case "${target_os}" in
|
||||
- linux*|netbsd*)
|
||||
+ linux*|netbsd*|freebsd*)
|
||||
{ $as_echo "$as_me:$LINENO: checking for perl cccdlflags needed on \"${target_os}\"" >&5
|
||||
$as_echo_n "checking for perl cccdlflags needed on \"${target_os}\"... " >&6; }
|
||||
eval `${PERL} -V:cccdlflags`
|
||||
@@ -20749,7 +20750,9 @@
|
||||
|
||||
if test -n "$SNMP_LIBS" && test -n "$SNMP_PREFIX"; then
|
||||
CPPFLAGS="$CPPFLAGS -I${SNMP_PREFIX}/include"
|
||||
|
@ -29,7 +30,7 @@ diff -u configure.orig configure
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_NETSNMP 1
|
||||
@@ -20224,7 +20228,7 @@
|
||||
@@ -21135,7 +21138,7 @@
|
||||
#define HAVE_UCDSNMP 1
|
||||
_ACEOF
|
||||
|
||||
|
|
|
@ -53,7 +53,7 @@ case $2 in
|
|||
echo
|
||||
else
|
||||
echo
|
||||
echo "** Please add an entry for the sieve protocol (2000/tcp)"
|
||||
echo "** Please add an entry for the sieve protocol (4190/tcp)"
|
||||
echo " to /etc/services"
|
||||
echo
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue