Remove expired port:

2021-02-01 www/rt42: Upstream support is ending; please migrate to RT-5.0 (www/rt50)

Suggest www/rt44 in MOVED for compatibility with recently adjusted plugins.
This commit is contained in:
Rene Ladan 2021-02-02 21:21:53 +00:00
parent c8fba2eef6
commit 6038351a30
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=563846
11 changed files with 1 additions and 2182 deletions

1
MOVED
View file

@ -16062,3 +16062,4 @@ www/p5-RT-Extension-RepeatTicket@rt42||2021-02-02|Removed, currently only suppor
www/p5-RT-Extension-RepeatTicket@rt44|www/p5-RT-Extension-RepeatTicket|2021-02-02|Unflavor, currently only supported with www/rt44
www/p5-RTx-Calendar@rt42||2021-02-02|Removed, currently only supported with www/rt44
www/p5-RTx-Calendar@rt44|www/p5-RTx-Calendar|2021-02-02|Unflavor, currently only supported with www/rt44
www/rt42|www/rt44|2021-02-02|Has expired: Upstream support is ending; please migrate to RT-5.0 (www/rt50)

View file

@ -1796,7 +1796,6 @@
SUBDIR += rssroll
SUBDIR += rsstail
SUBDIR += rsstool
SUBDIR += rt42
SUBDIR += rt44
SUBDIR += rt50
SUBDIR += rtv

View file

@ -1,181 +0,0 @@
# $FreeBSD$
PORTNAME= rt
DISTVERSION= 4.2.16
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/
PKGNAMESUFFIX= 42
MAINTAINER= matthew@FreeBSD.org
COMMENT= Industrial-grade ticketing system written in Perl
LICENSE= GPLv2
DEPRECATED= Upstream support is ending; please migrate to RT-5.0 (www/rt50)
EXPIRATION_DATE= 2021-02-01
CONFLICTS_INSTALL= rt44-4.4* brlcad-[0-9]*
NO_ARCH= yes
# See doc/web_deployment.pod for info on the choices of webserver /
# webapp combinations. Note: if using apache, apache-2.2+ is
# recommended. For deployment with nginx, use the SPAWN_FCGI method
# or the builtin webserver with a FCGI handler.
#
# The builtin standalone PSGI based webserver is always available, no
# matter what choice of web deployment platform, or none, that you
# make. Best Practical state that this is really only suitable for
# development usage, although I have heard reports of people using it
# successfully for medium sized deployments. If you only want the
# builtin webserver, simply deselect all of the web options.
#
# See doc/full_text_indexing.pod if you need to set up full text
# indexes on your ticket database. PostgreSQL is
# recommended in this case: the MYSQL / SphinxSearch combination
# mentioned in the docs is currently unsupported in the ports, but see
# http://www.infracaninophile.co.uk/articles/sphinxse.html
OPTIONS_DEFINE= DEVELOPER GD GPG GRAPHVIZ SMIME DOCS
OPTIONS_SINGLE= DB
OPTIONS_SINGLE_DB= MYSQL PGSQL SQLITE
OPTIONS_RADIO= WEB
OPTIONS_RADIO_WEB= AP_MODFASTCGI AP_MODPERL LIGHTTPD SPAWN_FCGI
OPTIONS_DEFAULT= AP_MODFASTCGI GD GPG MYSQL
USERS?= www
GROUPS?= rt www
RUN_DEPENDS+= ${LOCALBASE}/bin/jsmin:devel/jsmin
.include "${.CURDIR}/Makefile.cpan"
RUN_DEPENDS+= ${CLI_DEPS} \
${CORE_DEPS} \
${DASHBOARDS_DEPS} \
${ICAL_DEPS} \
${MAILGATE_DEPS} \
${USERLOGO_DEPS} \
${HTML_DOC_DEPS}
USES= cpe perl5
CPE_VENDOR= bestpractical
RT_LAYOUT= FreeBSD
RT_ETC_DIR?= etc/${PORTNAME}${PKGNAMESUFFIX}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
RT_ETC_PATH= ${PREFIX}/${RT_ETC_DIR}
AP_MODPERL_DESC= Deploy with apache and mod_perl
AP_MODPERL_RUN_DEPENDS= ${MODPERL2_DEPS}
AP_MODFASTCGI_DESC= Deploy with apache and mod_fastcgi
AP_MODFASTCGI_USE= APACHE_RUN=22+
AP_MODFASTCGI_RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:www/mod_fastcgi \
${FASTCGI_DEPS}
LIGHTTPD_DESC= Deploy with lighttpd and mod_fastcgi
LIGHTTPD_RUN_DEPENDS= ${LOCALBASE}/sbin/lighttpd:www/lighttpd \
${FASTCGI_DEPS}
SPAWN_FCGI_DESC= Deploy with spawn_fcgi
SPAWN_FCGI_RUN_DEPENDS= ${LOCALBASE}/bin/spawn-fcgi:www/spawn-fcgi \
${FASTCGI_DEPS}
MYSQL_RUN_DEPENDS= ${MYSQL_DEPS}
MYSQL_VARS= DB_TYPE=mysql DB_DBA_USER=root
PGSQL_RUN_DEPENDS= ${PGSQL_DEPS}
PGSQL_VARS= DB_TYPE=Pg DB_DBA_USER=pgsql
SQLITE_RUN_DEPENDS= ${SQLITE_DEPS}
SQLITE_VARS= DB_TYPE=SQLite DB_DBA_USER=root
DEVELOPER_DESC= Configure for Developers
DEVELOPER_RUN_DEPENDS= ${DEVELOPER_DEPS}
DEVELOPER_CONFIGURE_ENABLE= developer
SMIME_DESC= Enable Secure MIME support
SMIME_RUN_DEPENDS= ${SMIME_DEPS}
SMIME_CONFIGURE_ENABLE= smime
GRAPHVIZ_RUN_DEPENDS= ${GRAPHVIZ_DEPS}
GRAPHVIZ_CONFIGURE_ENABLE= graphviz
GPG_DESC= Enable GnuPG support
GPG_RUN_DEPENDS= ${GPG_DEPS}
GPG_CONFIGURE_ENABLE= gpg
GD_DESC= Enable GD Graphs and Charts
GD_RUN_DEPENDS= ${GD_DEPS}
GD_CONFIGURE_ENABLE= gd
BUILD_DEPENDS+= ${RUN_DEPENDS}
DB_DBA_PASSWORD?=
DB_USER?= rt_user
DB_PASSWORD?= rt_pass
DB_HOST?= localhost
DB_DATABASE?= rt4
WEB_USER?= ${WWWOWN}
WEB_GROUP?= ${WWWGRP}
LIBS_GROUP?= wheel
HAS_CONFIGURE= yes
NO_BUILD= yes
CONFIGURE_ARGS+= --enable-layout=${RT_LAYOUT} \
--with-web-user=${WEB_USER} \
--with-web-group=${WEB_GROUP} \
--with-libs-group=${LIBS_GROUP} \
--with-db-host=${DB_HOST} \
--with-db-port=${DB_PORT} \
--with-db-type=${DB_TYPE} \
--with-db-rt-user=${DB_USER} \
--with-db-rt-pass=${DB_PASSWORD} \
--with-db-database=${DB_DATABASE} \
--with-db-dba=${DB_DBA_USER}
CONFIGURE_ENV+= PERL=${LOCALBASE}/bin/perl
SUB_FILES= pkg-message
SUB_LIST= RT_ETC_PATH=${RT_ETC_PATH}
PLIST_SUB= RT_ETC_DIR=${RT_ETC_DIR}
pre-fetch:
@${ECHO} ""
@${ECHO} "Additional database related settings you can use:"
@${ECHO} " DB_HOST=hostname The database host (localhost)"
@${ECHO} " DB_PORT=port The database port"
@${ECHO} " DB_DATABASE=dbname The database name (rt4)"
@${ECHO} ""
@${ECHO} " DB_DBA_USER=username Name of database administrator (root)"
@${ECHO} " DB_DBA_PASSWORD=password Password of database administrator"
@${ECHO} " DB_USER=username Name of database user for RT (rt_user)"
@${ECHO} " DB_PASSWORD=password Name of database password for RT (rt_pass)"
pre-fetch-SQLITE-on:
@${ECHO} ""
@${ECHO} "SQLITE is not recommended for production use"
post-patch:
@${RM} ${WRKSRC}/lib/RT.pm.in.orig
@${REINPLACE_CMD} -e 's!%%PREFIX%%!${PREFIX}!g' ${WRKSRC}/config.layout
@${REINPLACE_CMD} -e 's!%%SITE_PERL%%!${PREFIX}/${SITE_PERL_REL}!g' ${WRKSRC}/config.layout
@${REINPLACE_CMD} -e 's!/path/to/your/etc!${RT_ETC_PATH}!g' ${WRKSRC}/etc/RT_SiteConfig.pm
@${REINPLACE_CMD} -e 's!/bin:/usr/bin!/bin:/usr/bin:${LOCALBASE}/bin!' ${WRKSRC}/lib/RT/Interface/CLI.pm && \
${RM} ${WRKSRC}/lib/RT/Interface/CLI.pm.bak
pre-install:
@${RM} ${WRKSRC}/lib/RT.pm.in
post-install:
@${RM} -r ${STAGEDIR}/${WWWDIR}${PKGNAMESUFFIX}
${MKDIR} ${STAGEDIR}${DOCSDIR}/upgrade
(cd ${WRKSRC}/etc && \
${COPYTREE_SHARE} upgrade ${STAGEDIR}${DOCSDIR} "! -name *\.in")
.include <bsd.port.mk>

View file

@ -1,297 +0,0 @@
###############################################################################
### --- Core_DEPS ---
### Apache::Session 1.53
### CGI 3.38 perl std (perl<5.22)
### CGI::Cookie 1.20 perl std (perl<5.22)
### CGI::Emulate::PSGI
### CGI::PSGI 0.12
### CSS::Squish 0.06
### Class::Accessor 0.34
### Crypt::Eksblowfish
### DBI 1.37
### DBIx::SearchBuilder 1.66
### Data::GUID
### Date::Extract 0.02
### Date::Manip
### DateTime 0.44
### DateTime::Format::Natural 0.67
### DateTime::Locale 0.40
### Devel::GlobalDestruction
### Devel::StackTrace 1.19
### Digest::MD5 2.27 perl std
### Digest::SHA perl std
### Digest::base perl std
### Email::Address 1.897
### Email::Address::List
### Encode 2.64 perl std (needs newer version)
### Errno perl std
### File::Glob perl std
### File::ShareDir
### File::Spec 0.8 perl std
### File::Temp 0.19 perl std
### HTML::Entities
### HTML::FormatExternal
### HTML::FormatText::WithLinks 0.14
### HTML::FormatText::WithLinks::AndTables
### HTML::Mason 1.43
### HTML::Mason::PSGIHandler 0.52
### HTML::Quoted
### HTML::RewriteAttributes 0.05
### HTML::Scrubber 0.08
### HTTP::Message 6.0
### IPC::Run3
### JSON
### LWP::Simple
### List::MoreUtils
### Locale::Maketext 1.06 perl std
### Locale::Maketext::Fuzzy 0.11
### Locale::Maketext::Lexicon 0.32
### Log::Dispatch 2.30
### MIME::Entity 5.504
### Mail::Header 2.12
### Mail::Mailer 1.57
### Module::Refresh 0.03
### Module::Versions::Report 1.05
### Net::CIDR
### Plack 1.0002
### Plack::Handler::Starlet
### Regexp::Common
### Regexp::Common::net::CIDR
### Regexp::IPv6
### Role::Basic 0.12
### Scalar::Util perl std
### Storable 2.08 perl std
### Symbol::Global::Name 0.04
### Sys::Syslog 0.16 perl std
### Text::Password::Pronounceable
### Text::Quoted 2.07
### Text::Template 1.44
### Text::WikiFormat 0.76
### Text::Wrapper
### Time::HiRes perl std
### Time::ParseDate
### Tree::Simple 1.04
### UNIVERSAL::require
### XML::RSS 1.05
CORE_DEPS= p5-Apache-Session>=1.53:www/p5-Apache-Session \
p5-CGI>4.0:www/p5-CGI \
p5-CGI-Emulate-PSGI>0:www/p5-CGI-Emulate-PSGI \
p5-CGI-PSGI>=0.12:www/p5-CGI-PSGI \
p5-CSS-Squish>=0.06:textproc/p5-CSS-Squish \
p5-Class-Accessor>=0.34:devel/p5-Class-Accessor \
p5-Crypt-Eksblowfish>0:security/p5-Crypt-Eksblowfish \
p5-DBI>=1.37:databases/p5-DBI \
p5-DBIx-SearchBuilder>=1.66:databases/p5-DBIx-SearchBuilder \
p5-Data-GUID>0:devel/p5-Data-GUID \
p5-Date-Extract>=0.02:devel/p5-Date-Extract \
p5-Date-Manip>0:devel/p5-Date-Manip \
p5-DateTime>=0.44:devel/p5-DateTime \
p5-DateTime-Format-Natural>=0.67:devel/p5-DateTime-Format-Natural \
p5-DateTime-Locale>=0.40:devel/p5-DateTime-Locale \
p5-DateTime>=0.44:devel/p5-DateTime \
p5-Devel-GlobalDestruction>0:devel/p5-Devel-GlobalDestruction \
p5-Devel-StackTrace>=1.30:devel/p5-Devel-StackTrace \
p5-Email-Address>=1.897:mail/p5-Email-Address \
p5-Email-Address-List>=0.03:mail/p5-Email-Address-List \
p5-File-ShareDir>0:devel/p5-File-ShareDir \
p5-HTML-FormatExternal>0:textproc/p5-HTML-FormatExternal \
p5-HTML-FormatText-WithLinks-AndTables>0:textproc/p5-HTML-FormatText-WithLinks-AndTables \
p5-HTML-FormatText-WithLinks>=0.14:textproc/p5-HTML-FormatText-WithLinks \
p5-HTML-Mason-PSGIHandler>=0.52:www/p5-HTML-Mason-PSGIHandler \
p5-HTML-Mason>=1.43:www/p5-HTML-Mason \
p5-HTML-Parser>0:www/p5-HTML-Parser \
p5-HTML-Quoted>0:textproc/p5-HTML-Quoted \
p5-HTML-Scrubber>=0.08:www/p5-HTML-Scrubber \
p5-HTTP-Message>=6.0:www/p5-HTTP-Message \
p5-IPC-Run3>0:devel/p5-IPC-Run3 \
p5-JSON>0:converters/p5-JSON \
p5-libwww>0:www/p5-libwww \
p5-List-MoreUtils>0:lang/p5-List-MoreUtils \
p5-Locale-Maketext-Fuzzy>=0.11:devel/p5-Locale-Maketext-Fuzzy \
p5-Locale-Maketext-Lexicon>=0.32:devel/p5-Locale-Maketext-Lexicon \
p5-Log-Dispatch>=2.30:devel/p5-Log-Dispatch \
p5-MIME-Tools>=5.504,2:mail/p5-MIME-Tools \
p5-Mail-Tools>=2.12:mail/p5-Mail-Tools \
p5-Module-Refresh>=0.03:devel/p5-Module-Refresh \
p5-Module-Versions-Report>=1.05:devel/p5-Module-Versions-Report \
p5-Net-CIDR>0:net-mgmt/p5-Net-CIDR \
p5-Plack>=1.0002:www/p5-Plack \
p5-Starlet>0:www/p5-Starlet \
p5-Regexp-Common-net-CIDR>0:textproc/p5-Regexp-Common-net-CIDR \
p5-Regexp-Common>0:textproc/p5-Regexp-Common \
p5-Regexp-IPv6>0:textproc/p5-Regexp-IPv6 \
p5-Role-Basic>=0.12:devel/p5-Role-Basic \
p5-Symbol-Global-Name>=0.05:devel/p5-Symbol-Global-Name \
p5-Text-Password-Pronounceable>0:security/p5-Text-Password-Pronounceable \
p5-Text-Quoted>=2.07:textproc/p5-Text-Quoted \
p5-Text-Template>=1.44:textproc/p5-Text-Template \
p5-Text-WikiFormat>=0.76:textproc/p5-Text-WikiFormat \
p5-Text-Wrapper>0:textproc/p5-Text-Wrapper \
p5-Time-modules>0:devel/p5-Time-modules \
p5-Tree-Simple>=1.04:devel/p5-Tree-Simple \
p5-UNIVERSAL-require>0:devel/p5-UNIVERSAL-require \
p5-XML-RSS>=1.05:textproc/p5-XML-RSS
### --- MAILGATE ---
### Crypt::SSLeay
### Getopt::Long perl std
### LWP::Protocol::https
### LWP::UserAgent 6.0
### Mozilla::CA
### Net::SSL
### Pod::Usage perl std
MAILGATE_DEPS= p5-libwww>6.0:www/p5-libwww \
p5-Crypt-SSLeay>0:security/p5-Crypt-SSLeay \
p5-LWP-Protocol-https>0:www/p5-LWP-Protocol-https \
p5-Mozilla-CA>0:www/p5-Mozilla-CA
### --- CLI ---
### Getopt::Long 2.24 perl std
### HTTP::Request::Common
### LWP
### Term::ReadKey
### Term::ReadLine perl std
### Text::ParseWords perl std
CLI_DEPS= p5-HTTP-Message>0:www/p5-HTTP-Message \
p5-libwww>0:www/p5-libwww \
p5-Term-ReadKey>0:devel/p5-Term-ReadKey
### --- DEVELOPER ---
### Email::Abstract
### File::Find perl std
### File::Which
### Locale::PO
### Log::Dispatch::Perl
### Mojo::DOM
### Plack::Middleware::Test::StashWarnings 0.08
### Set::Tiny
### String::ShellQuote 0 # needed for gnupg-incoming.t
### Test::Builder 0.90 # needed for is_passing perl std
### Test::Deep 0 # needed for shredder tests
### Test::Email
### Test::Expect 0.31
### Test::LongString
### Test::MockTime
### Test::NoWarnings
### Test::Pod
### Test::Warn
### Test::WWW::Mechanize 1.30
### Test::WWW::Mechanize::PSGI
### WWW::Mechanize 1.52
### XML::Simple
DEVELOPER_DEPS= p5-Email-Abstract>0:mail/p5-Email-Abstract \
p5-File-Which>0:sysutils/p5-File-Which \
p5-Locale-PO>0:devel/p5-Locale-PO \
p5-Log-Dispatch-Perl>0:devel/p5-Log-Dispatch-Perl \
p5-Mojolicious>0:www/p5-Mojolicious \
p5-Plack-Middleware-Test-StashWarnings>=0.08:www/p5-Plack-Middleware-Test-StashWarnings \
p5-Set-Tiny>0:devel/p5-Set-Tiny \
p5-String-ShellQuote>0:textproc/p5-String-ShellQuote \
p5-Test-Deep>0:devel/p5-Test-Deep \
p5-Test-Email>0:mail/p5-Test-Email \
p5-Test-Expect>=0.31:devel/p5-Test-Expect \
p5-Test-LongString>0:devel/p5-Test-LongString \
p5-Test-MockTime>0:devel/p5-Test-MockTime \
p5-Test-NoWarnings>0:devel/p5-Test-NoWarnings \
p5-Test-Pod>0:devel/p5-Test-Pod \
p5-Test-WWW-Mechanize-PSGI>0:devel/p5-Test-WWW-Mechanize-PSGI \
p5-Test-WWW-Mechanize>=1.30:devel/p5-Test-WWW-Mechanize \
p5-Test-Warn>0:devel/p5-Test-Warn \
p5-WWW-Mechanize>=1.52:www/p5-WWW-Mechanize \
p5-XML-Simple>0:textproc/p5-XML-Simple
### --- FASTCGI ---
### FCGI 0.74
### FCGI::ProcManager
FASTCGI_DEPS= p5-FCGI-ProcManager>0:www/p5-FCGI-ProcManager \
p5-FCGI>=0.74:www/p5-FCGI
### --- MODPERL2 ---
### Apache::DBI
MODPERL2_DEPS= p5-libapreq2>0:www/p5-libapreq2 \
p5-Apache-DBI>0:www/p5-Apache-DBI
### --- MYSQL ---
### DBD::mysql 2.1018
MYSQL_DEPS= p5-DBD-mysql>=2.1018:databases/p5-DBD-mysql
### --- PGSQL ---
### DBD::Pg 3.3.1
PGSQL_DEPS= p5-DBD-Pg>=3.3.1:databases/p5-DBD-Pg
### --- SQLITE ---
### DBD::SQLite 1.00
SQLITE_DEPS= p5-DBD-SQLite>=1.00:databases/p5-DBD-SQLite
### --- GPG ---
### File::Which
### GnuPG::Interface
### PerlIO::eol
GPG_DEPS= p5-File-Which>0:sysutils/p5-File-Which \
p5-GnuPG-Interface>0:security/p5-GnuPG-Interface \
p5-PerlIO-eol>0:devel/p5-PerlIO-eol
### --- SMIME---
### Crypt::X509
### File::Which
### String::ShellQuote
SMIME_DEPS= p5-Crypt-X509>0:security/p5-Crypt-X509 \
p5-File-Which>0:sysutils/p5-File-Which \
p5-String-ShellQuote>0:textproc/p5-String-ShellQuote
### --- ICAL ---
### Data::ICal
ICAL_DEPS= p5-Data-ICal>0:deskutils/p5-Data-ICal
### --- DASHBOARDS ---
### MIME::Types
### URI 1.59
### URI::QueryParam
DASHBOARDS_DEPS= p5-HTML-RewriteAttributes>=0.05:textproc/p5-HTML-RewriteAttributes \
p5-MIME-Types>0:mail/p5-MIME-Types \
p5-URI>=1.59:net/p5-URI
### --- GRAPHVIZ ---
### GraphViz
### IPC::Run 0.90
GRAPHVIZ_DEPS= p5-GraphViz>0:graphics/p5-GraphViz \
p5-IPC-Run>=0.90:devel/p5-IPC-Run
### -- GD --
### GD
### GD::Graph 1.47
### GD::Text
GD_DEPS= p5-GD>0:graphics/p5-GD \
p5-GD-Graph>0:graphics/p5-GD-Graph \
p5-GD-TextUtil>0:graphics/p5-GD-TextUtil
### --- USERLOGO ---
### Convert::Color
USERLOGO_DEPS= p5-Convert-Color>0:graphics/p5-Convert-Color
### --- HTML-DOC ---
### HTML::Entities
### Pod::Simple 3.24 perl std
HTML_DOC_DEPS= p5-HTML-Parser>0:www/p5-HTML-Parser
### --- AVOID ---
### 'Devel::StackTrace' => [qw(1.28 1.29)],
### 'DBD::Pg' => [qw(3.3.0)],

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1551855343
SHA256 (rt-4.2.16.tar.gz) = 1bbe619072b05efb55725c9df851363892b77ad6788dfd28eadce6a8f84a8209
SIZE (rt-4.2.16.tar.gz) = 7787267

View file

@ -1,87 +0,0 @@
--- Makefile.in.orig 2017-07-12 14:22:49 UTC
+++ Makefile.in
@@ -59,7 +59,7 @@ RT_LAYOUT = @rt_layout_name@
CONFIG_FILE_PATH = @CONFIG_FILE_PATH_R@
CONFIG_FILE = $(CONFIG_FILE_PATH)/RT_Config.pm
-SITE_CONFIG_FILE = $(CONFIG_FILE_PATH)/RT_SiteConfig.pm
+SITE_CONFIG_FILE = $(CONFIG_FILE_PATH)/RT_SiteConfig.pm-dist
RT_VERSION_MAJOR = @RT_VERSION_MAJOR@
@@ -106,7 +106,7 @@ RT_FONT_PATH = @RT_FONT_PATH_R@
RT_LEXICON_PATH = @RT_LEXICON_PATH_R@
RT_STATIC_PATH = @RT_STATIC_PATH_R@
RT_LOCAL_PATH = @RT_LOCAL_PATH_R@
-LOCAL_PLUGIN_PATH = @RT_LOCAL_PATH_R@/plugins
+LOCAL_PLUGIN_PATH = @RT_LOCAL_PATH_R@/share/rt42/plugins
LOCAL_ETC_PATH = @LOCAL_ETC_PATH_R@
LOCAL_LIB_PATH = @LOCAL_LIB_PATH_R@
LOCAL_LEXICON_PATH = @LOCAL_LEXICON_PATH_R@
@@ -269,16 +269,13 @@ testdeps:
depends: fixdeps
fixdeps:
- $(PERL) ./sbin/rt-test-dependencies --verbose --install --with-$(DB_TYPE) $(my_with_web_handlers)
+ $(PERL) ./sbin/rt-test-dependencies --verbose --with-$(DB_TYPE) $(my_with_web_handlers)
#}}}
fixperms:
# Make the libraries readable
chmod $(RT_READABLE_DIR_MODE) $(DESTDIR)$(RT_PATH)
- chown -R $(LIBS_OWNER) $(DESTDIR)$(RT_LIB_PATH)
- chgrp -R $(LIBS_GROUP) $(DESTDIR)$(RT_LIB_PATH)
- chmod -R u+rwX,go-w,go+rX $(DESTDIR)$(RT_LIB_PATH)
chmod $(RT_READABLE_DIR_MODE) $(DESTDIR)$(RT_BIN_PATH)
@@ -357,14 +354,14 @@ clean-mason-cache:
rm -rf $(DESTDIR)$(MASON_DATA_PATH)/etc/*
rm -rf $(DESTDIR)$(MASON_DATA_PATH)/obj/*
-install: testdeps config-install dirs files-install fixperms instruct
+install: config-install dirs files-install
files-install: libs-install etc-install config-install bin-install sbin-install html-install doc-install font-install po-install static-install
config-install:
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -o $(BIN_OWNER) -g $(RTGROUP) -d $(DESTDIR)$(CONFIG_FILE_PATH)
-@COMMENT_INPLACE_LAYOUT@ -$(INSTALL) -m 0440 -o $(BIN_OWNER) -g $(RTGROUP) etc/RT_Config.pm $(DESTDIR)$(CONFIG_FILE)
-@COMMENT_INPLACE_LAYOUT@ [ -f $(DESTDIR)$(SITE_CONFIG_FILE) ] || $(INSTALL) -m 0640 -o $(BIN_OWNER) -g $(RTGROUP) etc/RT_SiteConfig.pm $(DESTDIR)$(SITE_CONFIG_FILE)
+@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d $(DESTDIR)$(CONFIG_FILE_PATH)
+@COMMENT_INPLACE_LAYOUT@ -$(INSTALL) -m 0440 etc/RT_Config.pm $(DESTDIR)$(CONFIG_FILE)
+@COMMENT_INPLACE_LAYOUT@ [ -f $(DESTDIR)$(SITE_CONFIG_FILE) ] || $(INSTALL) -m 0640 etc/RT_SiteConfig.pm $(DESTDIR)$(SITE_CONFIG_FILE)
@COMMENT_INPLACE_LAYOUT@ @echo "Installed configuration. About to install RT in $(RT_PATH)"
test:
@@ -455,19 +452,12 @@ etc-install:
@COMMENT_INPLACE_LAYOUT@ for file in $(ETC_FILES) ; do \
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0644 "etc/$$file" "$(DESTDIR)$(RT_ETC_PATH)/" ; \
@COMMENT_INPLACE_LAYOUT@ done
-@COMMENT_INPLACE_LAYOUT@ [ -d $(DESTDIR)$(RT_ETC_PATH)/upgrade ] || $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_ETC_PATH)/upgrade
-@COMMENT_INPLACE_LAYOUT@ -( cd etc/upgrade && find . -type d -print ) | while read dir ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d "$(DESTDIR)$(RT_ETC_PATH)/upgrade/$$dir" ; \
-@COMMENT_INPLACE_LAYOUT@ done
-@COMMENT_INPLACE_LAYOUT@ -( cd etc/upgrade && find . -type f -not -name '*.in' -print ) | while read file ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0644 "etc/upgrade/$$file" "$(DESTDIR)$(RT_ETC_PATH)/upgrade/$$file" ; \
-@COMMENT_INPLACE_LAYOUT@ done
sbin-install:
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_SBIN_PATH)
@COMMENT_INPLACE_LAYOUT@ for file in $(SYSTEM_BINARIES) ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -o $(BIN_OWNER) -g $(RTGROUP) -m 0755 "sbin/$$file" "$(DESTDIR)$(RT_SBIN_PATH)/" ; \
+@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 "sbin/$$file" "$(DESTDIR)$(RT_SBIN_PATH)/" ; \
@COMMENT_INPLACE_LAYOUT@ done
@@ -475,7 +465,7 @@ sbin-install:
bin-install:
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_BIN_PATH)
@COMMENT_INPLACE_LAYOUT@ for file in $(BINARIES) ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -o $(BIN_OWNER) -g $(RTGROUP) -m 0755 "bin/$$file" "$(DESTDIR)$(RT_BIN_PATH)/" ; \
+@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 "bin/$$file" "$(DESTDIR)$(RT_BIN_PATH)/" ; \
@COMMENT_INPLACE_LAYOUT@ done

View file

@ -1,44 +0,0 @@
--- ./config.layout.orig 2017-07-12 14:22:49 UTC
+++ ./config.layout
@@ -103,31 +103,31 @@
</Layout>
<Layout FreeBSD>
- prefix: /usr/local
+ prefix: %%PREFIX%%
exec_prefix: ${prefix}
bindir: ${exec_prefix}/bin
sbindir: ${exec_prefix}/sbin
sysconfdir: ${prefix}/etc+
mandir: ${prefix}/man
plugindir: ${prefix}/plugins
- libdir: ${prefix}/lib+
+ libdir: %%SITE_PERL%%
datadir: ${prefix}/share+
htmldir: ${datadir}/html
lexdir: ${datadir}/po
- staticdir: ${datadir}/static
+ staticdir: ${datadir}/static
fontdir: ${datadir}/fonts
manualdir: ${prefix}/share/doc+
logfiledir: /var/log
localstatedir: /var/run+
masonstatedir: ${localstatedir}/mason_data
sessionstatedir: ${localstatedir}/session_data
- customdir: ${prefix}/share+
- custometcdir: ${customdir}/local/etc
- customhtmldir: ${customdir}/local/html
- customlexdir: ${customdir}/local/po
- customstaticdir: ${customdir}/static
- customlibdir: ${customdir}/local/lib
- customplugindir: ${customdir}/local/plugins
+ customdir: ${prefix}
+ custometcdir: ${datadir}/etc
+ customhtmldir: ${customdir}/www+
+ customlexdir: ${datadir}/po
+ customstaticdir: ${datadir}/static
+ customlibdir: ${datadir}/lib
+ customplugindir: ${datadir}/plugins
</Layout>
# RH path layout.

View file

@ -1,11 +0,0 @@
--- configure.orig 2017-07-26 18:10:25 UTC
+++ configure
@@ -2102,7 +2102,7 @@ $as_echo "$as_me: WARNING: Layout file $
s/^#.*$//m;
s/^\s+//gim;
s/\s+$/\n/gim;
- s/\+$/\/rt3/gim;
+ s/\+$/\/rt42/gim;
# m4 will not let us just use $srcdir/config.layout, we need $1
s/^\s*((?:bin|sbin|libexec|data|sysconf|sharedstate|localstate|lib|include|oldinclude|info|man|html)dir)\s*:\s*(.*)$/$1=$2/gim;
s/^\s*(.*?)\s*:\s*(.*)$/\(test "x\$$1" = "xNONE" || test "x\$$1" = "x") && $1=$2/gim;

View file

@ -1,52 +0,0 @@
[
{ type: install
message: <<EOM
To initialize RT's database:
$ sudo perl rt-setup-database --action init --dba dba --dba-password X
To clear a previously created RT database:
$ sudo perl rt-setup-database --action drop --dba dba --dba-password X
To complete the installation of this port, please follow these steps:
1. Edit %%RT_ETC_PATH%%/RT_SiteConfig.pm, by referring to
the default config file (%%RT_ETC_PATH%%/RT_Config.pm).
2. Configure the email and web gateways. Please refer to
'SETTING UP THE MAIL GATEWAY' in %%DOCSDIR%%/README
3. Restart Apache or whichever web delivery mechanism you selected..
4. Do remember to *CHANGE* the root's password for the web interface.
The default is "password" (without the quotes.)
5. Configure RT per the instructions at
http://www.bestpractical.com/rt/docs.html
RT does not work with perl taint mode (-T) you must disable it.
Note, some other ports like devel/bugzilla have you add this to your
httpd.conf. This isn't actually a flaw of RT, but of a subset of the
CPAN modules that RT uses.
EOM
}
{ type: install
message: <<EOM
If you're upgrading RT then it is worth reading the UPGRADING document
at this point. Some extension you're using may have been integrated
into core. It's recommended to use new clean directory when you're
upgrading to new release (for example from 4.0.x to 4.2.x).
To upgrade your database schema, preserving ticket history:
1. Backup your RT database.
2. If upgrading to a new major release, create a new database named
rt4 with appropriate rights for the rt_user and reload your
database backup into it.
3. Run:
# /usr/local/sbin/rt-setup-database \
--datadir %%DOCSDIR%%/upgrade \
--action upgrade --prompt-for-dba-password
and answer the prompts.
EOM
}
]

View file

@ -1,7 +0,0 @@
RT is a battle-tested issue tracking system which thousands of
organizations use for bug tracking, help desk ticketing, customer
service, workflow processes, change management, network operations,
youth counselling and even more. Organizations around the world have
been running smoothly thanks to RT for over 10 years.
WWW: http://www.bestpractical.com/rt/

File diff suppressed because it is too large Load diff