Add sdl_image - a simple library to load images of various formats as SDL

surfaces.
This commit is contained in:
Maxim Sobolev 2000-09-20 07:16:53 +00:00
parent 7724974b65
commit 604432fe13
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32889
7 changed files with 75 additions and 0 deletions

View file

@ -158,6 +158,7 @@
SUBDIR += sane
SUBDIR += sced
SUBDIR += scwm-icons
SUBDIR += sdl_image
SUBDIR += sketch
SUBDIR += smpeg
SUBDIR += sodipodi

View file

@ -0,0 +1,38 @@
# New ports collection makefile for: sdl_image
# Date created: 20 September 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= sdl_image
PORTVERSION= 1.0.9
CATEGORIES= graphics
MASTER_SITES= http://www.devolution.com/~slouken/SDL/projects/SDL_image/src/
DISTNAME= SDL_image-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lm"
post-extract:
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|-release \$$\(LT_RELEASE\)||g'
post-configure:
@${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (SDL_image-1.0.9.tar.gz) = 91d8014aacb35605b510443d9c468173

View file

@ -0,0 +1,11 @@
--- Makefile.in 2000/09/20 07:05:33 1.1
+++ Makefile.in 2000/09/20 07:06:00
@@ -89,7 +89,7 @@
lib_LTLIBRARIES = libSDL_image.la
-libSDL_imageincludedir = $(includedir)/SDL
+libSDL_imageincludedir = $(includedir)/SDL11
libSDL_imageinclude_HEADERS = SDL_image.h

View file

@ -0,0 +1 @@
A simple library to load images of various formats as SDL surfaces

View file

@ -0,0 +1,18 @@
This is a simple library to load images of various formats as SDL surfaces.
This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats.
API:
#include "SDL_image.h"
SDL_Surface *IMG_Load(const char *file);
or
SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc);
or
SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc, char *type);
where type is a string specifying the format (i.e. "PNG" or "pcx").
Note that IMG_Load_RW cannot load TGA images.
An example program 'showimage' is included, with source in showimage.c
WWW: http://www.devolution.com/~slouken/SDL/projects/SDL_image/

View file

@ -0,0 +1,5 @@
bin/showimage
include/SDL11/SDL_image.h
lib/libSDL_image.a
lib/libSDL_image.so
lib/libSDL_image.so.9