Update for 0.4.1

PR:		ports/23713
Submitted by:	Nishimura Takashi <takashi@ueda.info.waseda.ac.jp>
This commit is contained in:
Yukihiro Nakai 2000-12-25 13:20:59 +00:00
parent 6bba57f77b
commit 608044953d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36338
5 changed files with 4 additions and 80 deletions

View file

@ -6,13 +6,14 @@
#
# This port does not work with another version of master port.
#PORTVERSION= 0.2.1
CATEGORIES= japanese x11-toolkits gnome
MASTERDIR= ${.CURDIR}/../../x11-toolkits/gal
EXTRA_PATCHES= ${.CURDIR}/files/patch-*
MAINTAINER= nakai@FreeBSD.org
post-patch:
perl -pi -e 's/gdk_font_load(\s)\(.*\)/gdk_fontset_load$$1\("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*"\)/' \
`find ${WRKSRC} -name "*.c" -print`
.include "${MASTERDIR}/Makefile"

View file

@ -1,12 +0,0 @@
diff -ruN gal.orig/e-table/e-table-group-container.c gal/e-table/e-table-group-container.c
--- gal.orig/e-table/e-table-group-container.c Mon Oct 30 15:52:49 2000
+++ gal/e-table/e-table-group-container.c Mon Oct 30 15:53:42 2000
@@ -132,7 +132,7 @@
etgc->ascending = column.ascending;
- etgc->font = gdk_font_load ("lucidasans-10");
+ etgc->font = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
if (!etgc->font){
etgc->font = GTK_WIDGET (GNOME_CANVAS_ITEM (etgc)->canvas)->style->font;

View file

@ -1,14 +0,0 @@
--- gal/e-table/e-table-header-item.c.orig Thu Oct 19 04:23:01 2000
+++ gal/e-table/e-table-header-item.c Mon Oct 30 22:40:09 2000
@@ -189,9 +189,9 @@
{
GdkFont *font;
- font = gdk_fontset_load (fontname);
+ font = gdk_fontset_load ("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
if (font == NULL)
- font = gdk_font_load ("-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-iso8859-1");
+ font = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
ethi_font_set (ethi, font);
}

View file

@ -1,40 +0,0 @@
diff -ruN gal.orig/widgets/e-font.c gal/widgets/e-font.c
--- gal.orig/widgets/e-font.c Mon Oct 30 15:52:47 2000
+++ gal/widgets/e-font.c Mon Oct 30 15:53:37 2000
@@ -39,8 +39,8 @@
EFont * font;
GdkFont *gdkfont;
- gdkfont = gdk_font_load (name);
- if (!gdkfont) gdkfont = gdk_font_load ("fixed");
+ gdkfont = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
+ if (!gdkfont) gdkfont = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
g_return_val_if_fail (gdkfont != NULL, NULL);
font = e_font_from_gdk_font (gdkfont);
gdk_font_unref (gdkfont);
@@ -108,7 +108,7 @@
c[0], c[1], c[2], c[3], c[4], c[5], c[6], c[7],
c[8], c[9], c[10], c[11], c[12], enc);
/* Try to load unicode font */
- newfont = gdk_font_load (p);
+ newfont = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
if (newfont) {
/* OK, use that */
gdk_font_unref (gdkfont);
@@ -137,14 +137,14 @@
c[0], c[1], c[2], lightname, c[4],
c[5], "*", "*", c[8], c[9], c[10],
c[11], "*", enc);
- lightfont = gdk_font_load (p);
+ lightfont = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
}
if (!boldfont) {
g_snprintf (p, len, "%s-%s-%s-%s-%s-%s-%s-%s-%s-%s-%s-%s-%s-%s",
c[0], c[1], c[2], boldname, c[4],
c[5], "*", "*", c[8], c[9], c[10],
c[11], "*", enc);
- boldfont = gdk_font_load (p);
+ boldfont = gdk_fontset_load("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
}
} else
lightfont = gdkfont;

View file

@ -1,11 +0,0 @@
--- gal/e-table/e-table-field-chooser-item.c.orig Mon Oct 30 22:38:31 2000
+++ gal/e-table/e-table-field-chooser-item.c Mon Oct 30 22:38:44 2000
@@ -167,7 +167,7 @@
etfci->font = NULL;
if (font)
- etfci->font = gdk_fontset_load (font);
+ etfci->font = gdk_fontset_load ("-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*");
if (etfci->font == NULL) {
etfci->font = GTK_WIDGET(GNOME_CANVAS_ITEM(etfci)->canvas)->style->font;