Add java-gcj-compat. With scripts and symlinks, now gcj installation acts
like a Java SDK. WWW: ftp://sources.redhat.com/pub/rhug/
This commit is contained in:
parent
c953f588fc
commit
608284ba70
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=169029
7 changed files with 106 additions and 0 deletions
|
@ -71,6 +71,7 @@
|
|||
SUBDIR += jasmin
|
||||
SUBDIR += java-checkstyle
|
||||
SUBDIR += java-cup
|
||||
SUBDIR += java-gcj-compat
|
||||
SUBDIR += java-getopt
|
||||
SUBDIR += java-tutorial
|
||||
SUBDIR += java3d
|
||||
|
|
38
java/java-gcj-compat/Makefile
Normal file
38
java/java-gcj-compat/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# New ports collection makefile for: java-gcj-compat
|
||||
# Date created: 29 July 2006
|
||||
# Whom: <maho@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= java-gcj-compat
|
||||
PORTVERSION= 1.0.56 # intentionally not upgrading
|
||||
CATEGORIES= java devel
|
||||
MASTER_SITES= ftp://sources.redhat.com/pub/rhug/
|
||||
|
||||
MAINTAINER= maho@FreeBSD.org
|
||||
COMMENT= A collection of wrapper scripts, symlinks and jar files for GCJ
|
||||
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/libdata/ldconfig/gcc41-withgcjawt:${PORTSDIR}/lang/gcc41-withgcjawt
|
||||
BUILD_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
|
||||
|
||||
RUN_DEPENDS+= ${LOCALBASE}/libdata/ldconfig/gcc41-withgcjawt:${PORTSDIR}/lang/gcc41-withgcjawt
|
||||
RUN_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
|
||||
|
||||
GCJVER=41
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_PYTHON= yes
|
||||
PLIST_SUB= ARCH=${ARCH}
|
||||
CONFIGURE_ARGS+="-with-origin-name=gcj41" "--with-gcc-suffix=41" \
|
||||
"--with-arch-directory=${ARCH}" "--disable-symlinks" \
|
||||
"--with-classpath-security=${LOCALBASE}/lib/security/classpath.security" \
|
||||
"--with-security-directory=${LOCALBASE}/etc/java/security/security.d"
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
@${LN} -sf ${PREFIX}/lib/jvm/java-1.4.2-gcj41-1.4.2.0 ${PREFIX}/lib/jvm/java-gcj
|
||||
|
||||
.include <bsd.port.mk>
|
3
java/java-gcj-compat/distinfo
Normal file
3
java/java-gcj-compat/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (java-gcj-compat-1.0.56.tar.gz) = 016b4ed55cc61f19e8c3caf0b21a4b7b
|
||||
SHA256 (java-gcj-compat-1.0.56.tar.gz) = 6841a88e8f6f5ae21613a2f98a637adf882b1b5ffc333f5f94f81df0da73fd1c
|
||||
SIZE (java-gcj-compat-1.0.56.tar.gz) = 90314
|
22
java/java-gcj-compat/files/patch-Makefile.in
Normal file
22
java/java-gcj-compat/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- Makefile.in~ Mon Jul 24 18:03:23 2006
|
||||
+++ Makefile.in Sat Jul 29 12:14:06 2006
|
||||
@@ -171,8 +171,8 @@
|
||||
|
||||
jardir = $(SDK_LIB_DIR)
|
||||
jar_DATA = tools.jar
|
||||
-javadoc_jarfile = /usr/share/java/com-sun-javadoc-0.7.7.jar
|
||||
-taglet_jarfile = /usr/share/java/com-sun-tools-doclets-Taglet-0.7.7.jar
|
||||
+javadoc_jarfile = %%LOCALBASE%%/share/java/com-sun-javadoc-0.7.7.jar
|
||||
+taglet_jarfile = %%LOCALBASE%%/share/java/com-sun-tools-doclets-Taglet-0.7.7.jar
|
||||
tools_jar_source_files = \
|
||||
$(top_builddir)/com/sun/tools/javac/Config.java \
|
||||
com/sun/tools/javac/Main.java \
|
||||
@@ -553,7 +553,7 @@
|
||||
ln -sf $(GJDOC) $(DESTDIR)$(SDK_BIN_DIR)/javadoc
|
||||
ln -sf $(GCJ_BIN_DIR)/grmic$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/rmic
|
||||
ln -sf $(GCJ_BIN_DIR)/gjnih$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/javah
|
||||
- ln -sf $(GCJ_BIN_DIR)/ecj $(DESTDIR)$(SDK_BIN_DIR)/javac
|
||||
+ ln -sf $(GCJ_BIN_DIR)/gcj$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/javac
|
||||
ln -sf $(GCJ_BIN_DIR)/grmiregistry$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/rmiregistry
|
||||
ln -sf $(GCJ_BIN_DIR)/grmiregistry$(gcc_suffix) $(DESTDIR)$(JRE_BIN_DIR)/rmiregistry
|
||||
@INSTALL_SYMLINKS_TRUE@ $(mkinstalldirs) $(DESTDIR)$(prefix)/bin
|
11
java/java-gcj-compat/files/patch-configure
Normal file
11
java/java-gcj-compat/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure~ Mon Jul 24 18:03:23 2006
|
||||
+++ configure Sat Jul 29 12:32:48 2006
|
||||
@@ -1996,7 +1996,7 @@
|
||||
# special-case gjdoc and make which are not in the GCC tree
|
||||
GJDOC=`which gjdoc`
|
||||
|
||||
-MAKE=`which make`
|
||||
+MAKE=`which gmake`
|
||||
|
||||
|
||||
# Find gcj prefix using gcj found in PATH.
|
5
java/java-gcj-compat/pkg-descr
Normal file
5
java/java-gcj-compat/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
java-gcj-compat is a collection of wrapper scripts, symlinks and jar
|
||||
files. It is meant to provide an SDK-like interface to the GCJ tool
|
||||
set.
|
||||
|
||||
WWW: ftp://sources.redhat.com/pub/rhug/
|
26
java/java-gcj-compat/pkg-plist
Normal file
26
java/java-gcj-compat/pkg-plist
Normal file
|
@ -0,0 +1,26 @@
|
|||
bin/rebuild-gcj-db
|
||||
bin/aot-compile
|
||||
bin/aot-compile-rpm
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/lib/tools.jar
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/lib/i386/libjawt.so
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/bin/java
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/bin/rmiregistry
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/java
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/jar
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/javadoc
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/rmic
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/javah
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/javac
|
||||
lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/rmiregistry
|
||||
lib/jvm/java-gcj
|
||||
%%PYTHON_SITELIBDIR%%/aotcompile.py
|
||||
%%PYTHON_SITELIBDIR%%/aotcompile.pyc
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/bin
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/lib/%%ARCH%%
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/lib
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/include
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/lib
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin
|
||||
@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0
|
||||
@dirrm lib/jvm
|
Loading…
Reference in a new issue