sysutils/minipro: fix build with GCC-based architectures

This port needs new GCC to build on GCC architectures.

Actually respect CC by putting ?= instead of =.

Also respect CFLAGS and remove post-patch step, instead use a separate patch file.

PR: 238515
Approved by:	mat (mentor)
Differential Revision:	https://reviews.freebsd.org/D20819
This commit is contained in:
Piotr Kubaj 2019-07-09 09:49:19 +00:00
parent 836bdb2d0e
commit 60bdebe042
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=506276
2 changed files with 32 additions and 6 deletions

View file

@ -12,7 +12,7 @@ LICENSE= GPLv3
RUN_DEPENDS= bash:shells/bash
USES= gmake pkgconfig shebangfix
USES= compiler:c11 gmake pkgconfig shebangfix
USE_GITLAB= yes
GL_ACCOUNT= DavidGriffith
@ -23,11 +23,6 @@ PLIST_FILES= bin/minipro \
bin/miniprohex \
man/man1/minipro.1.gz
post-patch:
@${REINPLACE_CMD} -e ' s|gcc|clang|g' \
-e 's|share/||g' \
${WRKSRC}/Makefile
post-install:
@${GZIP_CMD} ${STAGEDIR}${PREFIX}/man/man1/minipro.1
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}

View file

@ -0,0 +1,31 @@
--- Makefile.orig 2019-02-27 06:19:06 UTC
+++ Makefile
@@ -1,16 +1,16 @@
# Install Configuration
# Your C compiler
-CC=gcc
+CC?=gcc
#CC=clang
# Compiler options
-CFLAGS = -g -O0 -Wall
+CFLAGS ?= -g -O0 -Wall
# Normally minipro is installed to /usr/local. If you want to put it
# somewhere else, define that location here.
PREFIX ?= /usr/local
-MANDIR ?= $(PREFIX)/share/man
+MANDIR ?= $(PREFIX)/man
# Some older releases of MacOS need some extra library flags.
#EXTRA_LIBS += "-framework Foundation -framework IOKit"
@@ -58,7 +58,7 @@ OBJCOPY=objcopy
DIST_DIR = $(MINIPRO)-$(VERSION)
BIN_INSTDIR=$(DESTDIR)$(PREFIX)/bin
-MAN_INSTDIR=$(DESTDIR)$(PREFIX)/share/man/man1
+MAN_INSTDIR=$(DESTDIR)$(PREFIX)/man/man1
UDEV_DIR=$(shell $(PKG_CONFIG) --define-variable=prefix=$(PREFIX) --silence-errors --variable=udevdir udev)
UDEV_RULES_INSTDIR=$(DESTDIR)$(UDEV_DIR)/rules.d