-Fix the build with libtool 2.2.
-Remove pcre dependency, it has never use system which it uses in its tarball. -Don't build the pcre's example, it's not need. -Bump the PORTREVISION.
This commit is contained in:
parent
3218121bc8
commit
60e1c76f66
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=237751
2 changed files with 59 additions and 3 deletions
|
@ -8,7 +8,7 @@
|
|||
|
||||
PORTNAME= regexx
|
||||
PORTVERSION= 0.98.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -16,8 +16,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A complete regular expressions C++ solution
|
||||
|
||||
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -29,5 +27,7 @@ post-patch:
|
|||
${WRKSRC}/src/Makefile.in ${WRKSRC}/pcre/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's| examples||g' \
|
||||
${WRKSRC}/Makefile.am
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
56
devel/regexx/files/patch-libtool22
Normal file
56
devel/regexx/files/patch-libtool22
Normal file
|
@ -0,0 +1,56 @@
|
|||
--- pcre/Makefile.in.orig 2001-03-13 10:31:36.000000000 -0600
|
||||
+++ pcre/Makefile.in 2009-07-13 22:54:21.000000000 -0500
|
||||
@@ -90,13 +90,13 @@
|
||||
@echo ' '
|
||||
@echo '--- Building pcregrep utility'
|
||||
@echo ' '
|
||||
- $(LIBTOOL) $(CC) $(CFLAGS) -o pcregrep pcregrep.o libpcre.$(LIBSUFFIX)
|
||||
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o pcregrep pcregrep.o libpcre.$(LIBSUFFIX)
|
||||
|
||||
pcretest: libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest.o
|
||||
@echo ' '
|
||||
@echo '--- Building pcretest testing program'
|
||||
@echo ' '
|
||||
- $(LIBTOOL) $(PURIFY) $(CC) $(CFLAGS) -o pcretest pcretest.o \
|
||||
+ $(LIBTOOL) --mode=link $(PURIFY) $(CC) $(CFLAGS) -o pcretest pcretest.o \
|
||||
libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX)
|
||||
|
||||
libpcre.a: $(OBJ)
|
||||
@@ -112,7 +112,7 @@
|
||||
@echo '--- Building shared library: libpcre'
|
||||
@echo ' '
|
||||
-rm -f libpcre.la
|
||||
- ./libtool $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
|
||||
+ ./libtool --mode=link $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
|
||||
|
||||
libpcreposix.a: pcreposix.o
|
||||
@echo ' '
|
||||
@@ -127,22 +127,22 @@
|
||||
@echo '--- Building shared library: libpcreposix'
|
||||
@echo ' '
|
||||
-rm -f libpcreposix.la
|
||||
- ./libtool $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
|
||||
+ ./libtool --mode=link $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
|
||||
|
||||
pcre.o: chartables.c pcre.c pcre.h internal.h config.h Makefile
|
||||
- $(LIBTOOL) $(CC) -c $(CFLAGS) $(UTF8) pcre.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $(UTF8) pcre.c
|
||||
|
||||
pcreposix.o: pcreposix.c pcreposix.h internal.h pcre.h config.h Makefile
|
||||
- $(LIBTOOL) $(CC) -c $(CFLAGS) pcreposix.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) pcreposix.c
|
||||
|
||||
maketables.o: maketables.c pcre.h internal.h config.h Makefile
|
||||
- $(LIBTOOL) $(CC) -c $(CFLAGS) maketables.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) maketables.c
|
||||
|
||||
get.o: get.c pcre.h internal.h config.h Makefile
|
||||
- $(LIBTOOL) $(CC) -c $(CFLAGS) get.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) get.c
|
||||
|
||||
study.o: study.c pcre.h internal.h config.h Makefile
|
||||
- $(LIBTOOL) $(CC) -c $(CFLAGS) $(UTF8) study.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $(UTF8) study.c
|
||||
|
||||
pcretest.o: pcretest.c pcre.h config.h Makefile
|
||||
$(CC) -c $(CFLAGS) $(UTF8) pcretest.c
|
Loading…
Reference in a new issue