- Send to attic and point to graphics/blender
- Note: No longer needed since binary version is no longer in the tree. Requested by: David Yeske <dyeske@gmail.com> (maintainer) Approved by: sat (mentor)
This commit is contained in:
parent
6aaeae9c90
commit
60f1dcd51b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=199870
7 changed files with 1 additions and 150 deletions
1
MOVED
1
MOVED
|
@ -3241,3 +3241,4 @@ net/ng_netflow||2007-09-18|Has expired: already in base in all supported version
|
|||
java/jdk12-doc||2007-09-18|Has expired: Obsolete version of jdk
|
||||
japanese/netypesv||2007-09-18|Has expired: Depends on obsolete version of jdk
|
||||
net-im/micq|net-im/climm|2007-09-18|Project renamed
|
||||
graphics/blender-devel|graphics/blender|2007-09-21|Not needed since binary version is gone
|
||||
|
|
|
@ -37,7 +37,6 @@
|
|||
SUBDIR += batik
|
||||
SUBDIR += bbrb
|
||||
SUBDIR += blender
|
||||
SUBDIR += blender-devel
|
||||
SUBDIR += bmeps
|
||||
SUBDIR += bmp-rootvis
|
||||
SUBDIR += bmp2html
|
||||
|
|
|
@ -1,91 +0,0 @@
|
|||
# New ports collection makefile for: blender
|
||||
# Date created: 27 Feb 2003
|
||||
# Whom: David Yeske <dyeske@gmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= blender
|
||||
PORTVERSION= 2.44
|
||||
CATEGORIES= graphics games
|
||||
MASTER_SITES= http://download.blender.org/source/ \
|
||||
http://mirror.cs.umn.edu/blender.org/source/ \
|
||||
http://public.planetmirror.com/pub/blender/source/
|
||||
PKGNAMESUFFIX= -devel
|
||||
|
||||
MAINTAINER= dyeske@gmail.com
|
||||
COMMENT= 3D modeling/rendering/animation/gaming package
|
||||
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
freetype.9:${PORTSDIR}/print/freetype2 \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
SDL.11:${PORTSDIR}/devel/sdl12 \
|
||||
Half.4:${PORTSDIR}/graphics/OpenEXR \
|
||||
openal.0:${PORTSDIR}/audio/openal \
|
||||
alut.1:${PORTSDIR}/audio/freealut \
|
||||
avutil.1:${PORTSDIR}/multimedia/ffmpeg
|
||||
|
||||
CONFLICTS= blender-[0-9]*
|
||||
PLIST_FILES= bin/blender
|
||||
USE_X_PREFIX= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_PYTHON= 2.4+
|
||||
USE_SDL= sdl
|
||||
USE_GL= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
.if defined(WITH_OPTIMIZED_CFLAGS)
|
||||
CFLAGS+= -O3 -ffast-math
|
||||
.endif
|
||||
|
||||
MAKE_ENV+= NAN_CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
|
||||
-I${LOCALBASE}/include \
|
||||
-I${LOCALBASE}/include/OpenEXR \
|
||||
-I${PYTHON_INCLUDEDIR}"
|
||||
MAKE_ENV+= NAN_FREETYPE="${LOCALBASE}"
|
||||
MAKE_ENV+= NAN_OPENEXR="${LOCALBASE}"
|
||||
MAKE_ENV+= WITH_BF_BLENDERPLAYER="false"
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITH_OPTIMIZED_CFLAGS)
|
||||
@${ECHO_MSG} "You can enable additional compilation optimizations"
|
||||
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|sdl11-config|${SDL_CONFIG}|; \
|
||||
s|2.3|${PYTHON_VER}|' \
|
||||
${WRKSRC}/source/nan_definitions.mk
|
||||
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|WITH_ICONV=true|WITH_ICONV=false|; \
|
||||
s|NAN_PYTHON=.*|NAN_PYTHON=${LOCALBASE}|; \
|
||||
s|2.4|${PYTHON_VER}|; \
|
||||
s|NAN_JPEG=.*|NAN_JPEG=${LOCALBASE}|; \
|
||||
s|NAN_OPENEXR=.*|NAN_OPENEXR=${LOCALBASE}|; \
|
||||
s|NAN_PNG=.*|NAN_PNG=${LOCALBASE}|' \
|
||||
${WRKSRC}/user-def.mk
|
||||
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|gcc|${CC}|; \
|
||||
s|g++|${CXX}|; \
|
||||
s|-pipe||; \
|
||||
s|-O2|${CFLAGS}|; \
|
||||
s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|; \
|
||||
s|/usr/X11R6|${X11BASE}|' \
|
||||
${WRKSRC}/source/nan_compile.mk
|
||||
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-lc_r||; \
|
||||
s|-pthread|-lintl -lIlmThread ${PTHREAD_LIBS}|' \
|
||||
${WRKSRC}/source/nan_link.mk
|
||||
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-FIX_NAN_WARN||' \
|
||||
${WRKSRC}/source/nan_warn.mk
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd/bin/blender ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (blender-2.44.tar.gz) = 7ac841f6feb27e9d7fb6d77cf137be12
|
||||
SHA256 (blender-2.44.tar.gz) = 8fa5a46ea65d2a8b87fd1368d5984dfa0a41bdc3cfe24c776e069a4fe40102d1
|
||||
SIZE (blender-2.44.tar.gz) = 14362667
|
|
@ -1,20 +0,0 @@
|
|||
--- source/blender/blenlib/intern/storage.c.orig Sun Mar 19 14:28:01 2006
|
||||
+++ source/blender/blenlib/intern/storage.c Mon Aug 21 23:50:20 2006
|
||||
@@ -50,7 +50,7 @@
|
||||
#include <time.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
-#if !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
|
||||
+#if !defined(__FreeBSD__) && !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
|
||||
#include <sys/statfs.h>
|
||||
#endif
|
||||
|
||||
@@ -196,7 +196,7 @@
|
||||
#ifdef __BeOS
|
||||
return -1;
|
||||
#endif
|
||||
-#if !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
|
||||
+#if !defined(__FreeBSD__) && !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
|
||||
|
||||
if (statfs(name, &disk, sizeof(struct statfs), 0)){
|
||||
/* printf("diskfree: Couldn't get information about %s.\n",dir); */
|
|
@ -1,31 +0,0 @@
|
|||
--- source/nan_definitions.mk.orig Wed Nov 22 11:05:35 2006
|
||||
+++ source/nan_definitions.mk Wed Mar 21 21:24:37 2007
|
||||
@@ -55,9 +55,9 @@
|
||||
export NAN_LIBDIR ?= $(NANBLENDERHOME)/../lib
|
||||
export NAN_OBJDIR ?= $(NANBLENDERHOME)/obj
|
||||
# Library Config_Guess DIRectory
|
||||
- export LCGDIR = $(NAN_LIBDIR)/$(CONFIG_GUESS)
|
||||
+ export LCGDIR = $(NAN_LIBDIR)/freebsd
|
||||
# Object Config_Guess DIRectory
|
||||
- export OCGDIR = $(NAN_OBJDIR)/$(CONFIG_GUESS)
|
||||
+ export OCGDIR = $(NAN_OBJDIR)/freebsd
|
||||
|
||||
export NAN_MOTO ?= $(LCGDIR)/moto
|
||||
ifeq ($(FREE_WINDOWS), true)
|
||||
@@ -132,7 +132,7 @@
|
||||
export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a $(NAN_OPENEXR)/lib/libHalf.a $(NAN_OPENEXR)/lib/libIex.a
|
||||
else
|
||||
export NAN_OPENEXR ?= /usr/local
|
||||
- export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a $(NAN_OPENEXR)/lib/libHalf.a $(NAN_OPENEXR)/lib/libIex.a
|
||||
+ export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a $(NAN_OPENEXR)/lib/libIlmThread.a $(NAN_OPENEXR)/lib/libHalf.a $(NAN_OPENEXR)/lib/libIex.a
|
||||
endif
|
||||
endif
|
||||
export NAN_OPENEXR_INC ?= -I$(NAN_OPENEXR)/include -I$(NAN_OPENEXR)/include/OpenEXR
|
||||
@@ -291,6 +291,7 @@
|
||||
|
||||
# enable freetype2 support for text objects
|
||||
# export WITH_FREETYPE2 ?= true
|
||||
+ export NAN_NO_KETSJI=true
|
||||
|
||||
else
|
||||
ifeq ($(OS),irix)
|
|
@ -1,4 +0,0 @@
|
|||
Blender is a free and fully functional 3D
|
||||
modeling/rendering/animation/gaming package.
|
||||
|
||||
WWW: http://www.blender.org/
|
Loading…
Reference in a new issue