- Update to 1.3.0
- Use distfile provided by Debian - Add dependency on GCC from ports when building on 8.x (amd64) due to code generation issue with built-in GCC PR: ports/185212 Submitted by: Jan Beich <jbeich at tormail.org>
This commit is contained in:
parent
a05d4502ac
commit
60f674b64a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339215
6 changed files with 26 additions and 30 deletions
|
@ -2,14 +2,13 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libvpx
|
||||
PORTVERSION= 1.2.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
DISTNAME= ${PORTNAME}-v${PORTVERSION}
|
||||
MASTER_SITES= DEBIAN
|
||||
DISTNAME= ${PORTNAME}_${DISTVERSION}.orig
|
||||
|
||||
MAINTAINER= ashish@FreeBSD.org
|
||||
COMMENT= VP8 Codec SDK
|
||||
COMMENT= VP8/VP9 Codec SDK
|
||||
|
||||
LICENSE= BSD
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
@ -19,7 +18,6 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
|
|||
|
||||
USES= gmake perl5
|
||||
USE_BZIP2= yes
|
||||
PROJECTHOST= webm
|
||||
HAS_CONFIGURE= yes
|
||||
USE_PERL5= build
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -30,8 +28,14 @@ POSTPROC_DESC= Enable postprocessing
|
|||
RUNTIME_DESC= Enable runtime CPU detection
|
||||
SHARED_DESC= Enable shared-library support
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
|
||||
ALL_TARGET=
|
||||
CONFIGURE_ARGS+= --enable-pic --disable-install-srcs --enable-vp8 --disable-install-docs --prefix=${PREFIX}
|
||||
CONFIGURE_ARGS+=--prefix=${PREFIX} \
|
||||
--disable-install-docs \
|
||||
--disable-install-srcs \
|
||||
--enable-pic \
|
||||
--enable-vp8 \
|
||||
--enable-vp9
|
||||
MAKE_ARGS+= verbose=yes
|
||||
MAKE_ENV= LC_ALL=C
|
||||
|
||||
|
@ -45,6 +49,12 @@ SHARED_CONFIGURE_ON= --enable-shared
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OSVERSION} < 900000
|
||||
.if ${ARCH} == "amd64"
|
||||
USE_GCC= yes
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 1000000
|
||||
CONFIGURE_ARGS+= --disable-unit-tests
|
||||
.endif
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (libvpx-v1.2.0.tar.bz2) = 5ef0c650b2daa62085eb8105a7a4273f3e987db53c5ec97fd51d1b6511e5aa06
|
||||
SIZE (libvpx-v1.2.0.tar.bz2) = 1714121
|
||||
SHA256 (libvpx_1.3.0.orig.tar.bz2) = bd5af97b74d53a111b48852dfcd1791b2c758f1fe972833b363fe34a83a7750a
|
||||
SIZE (libvpx_1.3.0.orig.tar.bz2) = 2077846
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- build/make/configure.sh.orig
|
||||
+++ build/make/configure.sh
|
||||
@@ -1135,7 +1135,7 @@
|
||||
print_webm_license() {
|
||||
local destination=$1
|
||||
local prefix=$2
|
||||
- local suffix=$3
|
||||
+ local suffix="$3"
|
||||
shift 3
|
||||
cat <<EOF > ${destination}
|
||||
${prefix} Copyright (c) 2011 The WebM project authors. All Rights Reserved.${suffix}
|
|
@ -3,10 +3,10 @@ $FreeBSD$
|
|||
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -134,6 +134,7 @@
|
||||
all_platforms="${all_platforms} universal-darwin10-gcc"
|
||||
@@ -149,6 +149,7 @@
|
||||
all_platforms="${all_platforms} universal-darwin11-gcc"
|
||||
all_platforms="${all_platforms} universal-darwin12-gcc"
|
||||
all_platforms="${all_platforms} universal-darwin13-gcc"
|
||||
+all_platforms="${all_platforms} ia64-linux-gcc"
|
||||
all_platforms="${all_platforms} generic-gnu"
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
libvpx is the VP8 Codec SDK.
|
||||
libvpx is the VP8/VP9 Codec SDK.
|
||||
|
||||
WWW: http://www.webmproject.org/
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
bin/vpxdec
|
||||
bin/vpxenc
|
||||
bin/vp8_scalable_patterns
|
||||
bin/vp9_spatial_scalable_encoder
|
||||
include/vpx/svc_context.h
|
||||
include/vpx/vp8.h
|
||||
include/vpx/vp8cx.h
|
||||
include/vpx/vp8dx.h
|
||||
include/vpx/vpx_codec.h
|
||||
include/vpx/vpx_codec_impl_bottom.h
|
||||
include/vpx/vpx_codec_impl_top.h
|
||||
include/vpx/vpx_decoder.h
|
||||
include/vpx/vpx_encoder.h
|
||||
include/vpx/vpx_image.h
|
||||
|
@ -15,6 +15,6 @@ lib/libvpx.a
|
|||
libdata/pkgconfig/vpx.pc
|
||||
%%SHARED%%lib/libvpx.so
|
||||
%%SHARED%%lib/libvpx.so.1
|
||||
%%SHARED%%lib/libvpx.so.1.2
|
||||
%%SHARED%%lib/libvpx.so.1.2.0
|
||||
%%SHARED%%lib/libvpx.so.1.3
|
||||
%%SHARED%%lib/libvpx.so.1.3.0
|
||||
@dirrm include/vpx
|
||||
|
|
Loading…
Reference in a new issue