audio/cheesecutter: Fix build on 14-CURRENT

PR:		260106
This commit is contained in:
Hiroo Ono 2021-11-29 12:59:05 +01:00 committed by Emanuel Haupt
parent 8547737a73
commit 610ffb4fc8
2 changed files with 26 additions and 4 deletions

View file

@ -4,6 +4,7 @@ PORTNAME= cheesecutter
DISTVERSIONPREFIX= v
DISTVERSION= 2.9-beta-3-25
DISTVERSIONSUFFIX= -gdbe9a9d
PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= ehaupt@FreeBSD.org
@ -12,8 +13,6 @@ COMMENT= Tracker for composing music for the C64 SID chip
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.md
BROKEN_FreeBSD_14= ld: error: undefined hidden symbol: __start___minfo
BUILD_DEPENDS= acme:devel/acme \
ldc2:lang/ldc
@ -37,4 +36,10 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/${f}.fr.1 ${STAGEDIR}${MANPREFIX}/share/man/fr/man1
.endfor
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if (${OSVERSION} >= 1400042)
MAKE_ARGS= DLDFLAGS=-L=-Wl,-z,nostart-stop-gc
.endif
.include <bsd.port.post.mk>

View file

@ -8,7 +8,24 @@
LIBS=-L-ldl -L-lstdc++
COMFLAGS=-O2
VERSION=$(shell cat Version)
@@ -38,10 +40,10 @@ c64: $(C64OBJS)
@@ -19,7 +21,7 @@ include Makefile.objects.mk
all: ct2util ccutter
ccutter:$(C64OBJS) $(OBJS) $(CXX_OBJS)
- $(DC) $(COMFLAGS) -of=$@ $(OBJS) $(CXX_OBJS) $(LIBS)
+ $(DC) $(COMFLAGS) $(DLDFLAGS) -of=$@ $(OBJS) $(CXX_OBJS) $(LIBS)
.cpp.o : $(CXX_SRCS)
@@ -31,17 +33,17 @@ ccutter:$(C64OBJS) $(OBJS) $(CXX_OBJS)
ct: $(C64OBJS) $(CTOBJS)
ct2util: $(C64OBJS) $(UTILOBJS)
- $(DC) $(COMFLAGS) -of=$@ $(UTILOBJS)
+ $(DC) $(COMFLAGS) $(DLDFLAGS) -of=$@ $(UTILOBJS)
c64: $(C64OBJS)
install: all
strip ccutter$(EXE)
strip ct2util$(EXE)