- Update to 1.4.1

- Do not use OPTIONS for the mutually exclusive UI choices, use
  conflicting slave ports (celestia-gnome and celestia-gtk)
- Axe KDE support since I cannot test it (patches welcome)
- Enable Lua support by default
- Always install a desktop entry
- Relayout the Makefile
- Take maintainership
This commit is contained in:
Jean-Yves Lefort 2006-05-04 12:38:37 +00:00
parent e14cc8801d
commit 613f27d55d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161334
9 changed files with 448 additions and 219 deletions

View file

@ -5,152 +5,97 @@
# $FreeBSD$
#
PORTNAME= celestia
PORTVERSION= 1.3.2
PORTREVISION= 2
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
PORTNAME= celestia
PORTVERSION= 1.4.1
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= celestia
PKGNAMESUFFIX= -${CELESTIA_UI}
MAINTAINER= ports@FreeBSD.org
COMMENT= Scriptable space flight simulator for X
MAINTAINER= jylefort@FreeBSD.org
COMMENT= Scriptable space flight simulator for X
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= libtool:15
PLIST= ${WRKDIR}/plist
PORTDOCS= AUTHORS CelestiaKeyAssignments.txt ChangeLog \
coding-standards.html devguide.txt \
KbdMouseJoyControls.txt README TODO TRANSLATORS
USE_GMAKE= yes
USE_GL= yes
USE_GNOME=
USE_X_PREFIX= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_GL= yes
USE_GETTEXT= yes
WANT_GNOME= yes
USE_X_PREFIX= yes
CONFIGURE_ARGS= --program-prefix=""
CONFIGURE_ARGS= --program-prefix=""
CONFIGURE_ENV= \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}" \
CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
OPTIONS= LUA "Lua support" off \
GLUT "Glut interface" off \
GTK "Gtk+ interface" off \
GNOME "GNOME interface" off \
KDE "KDE interface" off
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|} # lol
.if ${CELESTIA_UI} == "glut"
CONFIGURE_ARGS+= --with-glut
LIB_DEPENDS+= glut:${PORTSDIR}/graphics/libglut
.elif ${CELESTIA_UI} == "gtk"
CONFIGURE_ARGS+= --with-gtk
USE_GNOME+= gtk20
.elif ${CELESTIA_UI} == "gnome"
CONFIGURE_ARGS+= --with-gnome
USE_GNOME+= libgnomeui
GCONF_SCHEMAS= celestia.schemas
PKGMESSAGE= ${PKGDIR}/pkg-message.gnome
.else
IGNORE= invalid CELESTIA_UI value "${CELESTIA_UI}" -- valid values are ${UI_LIST}
.endif
.if ${CELESTIA_UI} == "gtk" || ${CELESTIA_UI} == "gnome"
USE_GNOME+= gnomehack
LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
STARTUP_NOTIFY= true
PLIST_FILES+= share/celestia/celestia-logo.png share/celestia/celestiaui.xml
.else
STARTUP_NOTIFY= false
.endif
PORTDOCS= AUTHORS CelestiaKeyAssignments.txt ChangeLog \
KbdMouseJoyControls.txt README TODO TRANSLATORS \
coding-standards.html devguide.txt
DESKTOP_ENTRIES="Celestia" \
"Explore space" \
"celestia.png" \
"celestia" \
"Application;Astronomy;Science;Education;" \
${STARTUP_NOTIFY}
OPTIONS= LUA "Lua support" on
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
IGNORE= does not compile on FreeBSD 4.x
.endif
.if defined(WITH_LUA)
LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
CONFIGURE_ARGS+= --with-lua
.endif
.if defined(WITH_GNOME)
PKGMESSAGE= ${WRKDIR}/message
WITH_GTK= yes # GNOME requires GTK+
USE_GNOME+= libgnomeui
CONFIGURE_ARGS+= --with-gnome
GCONF_SCHEMAS= celestia.schemas
.endif
.if defined(WITH_GTK)
USE_GNOME+= gnomehack gnomeprefix gtk20
LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
CONFIGURE_ARGS+= --with-gtk
PLIST_SUB+= DATADIR="share/gnome/celestia"
.else
PLIST_SUB+= DATADIR="share/celestia"
.endif
.if defined(WITH_KDE)
USE_KDELIBS_VER= 3
CONFIGURE_ARGS+= --with-kde
# KDE_LIBS_VER is defined after including bsd.port.pre.mk, so we need
# to include bsd.kde.mk manually.
.include "${PORTSDIR}/Mk/bsd.kde.mk"
.endif
.if !defined(WITH_KDE) && !defined(WITH_GTK) && !defined(WITH_GNOME)
WITH_GLUT= yes # an UI is required, fallback to Glut
.endif
.if defined(WITH_GLUT)
CONFIGURE_ARGS+= --with-glut
.endif
.if defined(WITH_GTK) || defined(WITH_GLUT)
# libglut is only required for Glut and GTK+ interfaces
LIB_DEPENDS+= glut:${PORTSDIR}/graphics/libglut
.endif
pre-patch:
@${REINPLACE_CMD} -e \
's|-O2||g; \
s|-Wall||g; \
s|-ffast-math||g; \
s|-fexpensive-optimizations||g; \
s|"x" = "y"|"x" = "x"|' \
${WRKSRC}/configure
.for o in -O2 -Wall -ffast-math -fexpensive-optimizations -fomit-frame-pointer
@${REINPLACE_CMD} -e 's|${o}||g' ${WRKSRC}/configure
.endfor
@${REINPLACE_CMD} -e 's|COPYING||g' ${WRKSRC}/Makefile.in
.if !defined(WITH_GNOME)
@${REINPLACE_CMD} -e \
's|\(install-pkgdataDATA\) install-schemasDATA|\1|; \
s|\$$(DESTDIR)\$$(schemasdir)||' \
${WRKSRC}/src/celestia/gtk/data/Makefile.in
.endif
pre-install:
@${RM} -f ${PLIST}
.if defined(WITH_GNOME)
@${ECHO_CMD} "The GConf daemon must be restarted with the commands:" \
>> ${PKGMESSAGE}
@${ECHO_CMD} "gconftool-2 --shutdown && gconftool-2 --spawn" \
>> ${PKGMESSAGE}
@${ECHO_CMD} share/gnome/applications/celestia.desktop >> ${PLIST}
@${ECHO_CMD} share/gnome/pixmaps/celestia.png >> ${PLIST}
.endif
.for ii in bin/celestia %%DATADIR%%/celestia.png %%DATADIR%%/controls.txt
@${ECHO_CMD} ${ii} >> ${PLIST}
.endfor
@${FIND} ${WRKSRC}/data/ -name '*.???' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/extras/ -name '*.ssc' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/fonts/ -name '*.txf' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
.for ii in celestia.cfg demo.cel guide.cel start.cel
@${ECHO_CMD} %%DATADIR%%/${ii} >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
@${FIND} ${WRKSRC}/manual/ -name '*.???*' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
.endif
@${FIND} ${WRKSRC}/models/ -name '*.???*' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/shaders/ -name '*.fp' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/shaders/ -name '*.vp' | \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/textures/ -name '*.jpg' -o -name '*.png'| \
${SED} -e "s:^${WRKSRC}/:%%DATADIR%%/:g" >> ${PLIST}
.for ii in /data /extras /fonts /manual /models /shaders \
/textures/hires /textures/lores /textures/medres /textures /
@${ECHO_CMD} @dirrm %%DATADIR%%${ii} >> ${PLIST}
.endfor
post-install:
${INSTALL_DATA} ${WRKSRC}/src/celestia/gtk/data/celestia.png \
${PREFIX}/share/pixmaps
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for ii in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
.endfor
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.if defined(WITH_GNOME)
.if ${CELESTIA_UI} == "gnome"
@${CAT} ${PKGMESSAGE}
.endif

View file

@ -1,3 +1,3 @@
MD5 (celestia-1.3.2.tar.gz) = 0aaf86592a8989a0576e34c1f4cb3c2a
SHA256 (celestia-1.3.2.tar.gz) = 70d244150cc4d13fd659f0c0b6f3d6359f183679a61af11fe65fa33f51169c7b
SIZE (celestia-1.3.2.tar.gz) = 18091458
MD5 (celestia-1.4.1.tar.gz) = be1d36fc97a13b9a276249dbc0efac41
SHA256 (celestia-1.4.1.tar.gz) = f9dc34dbc0d53e98534000545802b5ab4a471c3cb3fa08a9c958cbbbeb28d8b5
SIZE (celestia-1.4.1.tar.gz) = 23966886

View file

@ -0,0 +1,30 @@
--- config.h.in.orig Thu May 4 11:37:39 2006
+++ config.h.in Thu May 4 11:37:52 2006
@@ -248,27 +248,6 @@
-#if !defined(HAVE_STRLCAT_PROTO)
-#ifdef __cplusplus
-extern "C" {
-#endif
-unsigned long strlcat(char*, const char*, unsigned long);
-#ifdef __cplusplus
-}
-#endif
-#endif
-
-
-
-#if !defined(HAVE_STRLCPY_PROTO)
-#ifdef __cplusplus
-extern "C" {
-#endif
-unsigned long strlcpy(char*, const char*, unsigned long);
-#ifdef __cplusplus
-}
-#endif
-#endif

View file

@ -0,0 +1,10 @@
--- src/celestia/Makefile.in.orig Thu May 4 13:10:55 2006
+++ src/celestia/Makefile.in Thu May 4 13:11:07 2006
@@ -347,6 +347,7 @@
celestia_LDADD = \
+ $(INTLLIBS) \
$(celestiaKDELIBS) \
$(celestiaGTKLIBS) \
../celengine/libcelengine.a \

View file

@ -1,72 +0,0 @@
$FreeBSD$
author: Jean-Yves Lefort
--- src/celestia/gtkmain.cpp.orig Tue Feb 15 19:00:43 2005
+++ src/celestia/gtkmain.cpp Tue Feb 15 19:16:55 2005
@@ -54,6 +54,10 @@
using namespace std;
+// Linux compatibility
+static int daylight = 0;
+static long linux_timezone = 0;
+
char AppName[] = "Celestia";
static CelestiaCore* appCore = NULL;
@@ -274,7 +278,7 @@
{
if (appCore->getTimeZoneBias() == 0)
{
- appCore->setTimeZoneBias(-timezone + 3600 * daylight);
+ appCore->setTimeZoneBias(-linux_timezone + 3600 * daylight);
appCore->setTimeZoneName(tzname[daylight]);
prefs->showLocalTime = TRUE;
}
@@ -3391,7 +3395,7 @@
appCore->start((double) curtime / 86400.0 + (double) astro::Date(1970, 1, 1));
localtime(&curtime); /* Only doing this to set timezone as a side
effect*/
- appCore->setTimeZoneBias(-timezone + 3600 * daylight);
+ appCore->setTimeZoneBias(-linux_timezone + 3600 * daylight);
appCore->setTimeZoneName(tzname[daylight]);
timeOptions[1]=tzname[daylight];
@@ -3967,7 +3971,7 @@
appCore->getRenderer()->setStarStyle(p->starStyle);
appCore->setHudDetail(p->hudDetail);
if (p->showLocalTime) {
- appCore->setTimeZoneBias(-timezone + 3600 * daylight);
+ appCore->setTimeZoneBias(-linux_timezone + 3600 * daylight);
appCore->setTimeZoneName(tzname[daylight]);
}
else {
@@ -4067,7 +4071,7 @@
void confShowLocalTime(GConfClient* c, guint, GConfEntry* e, gpointer) {
prefs->showLocalTime = gconf_client_get_bool(c, gconf_entry_get_key(e), NULL);
if (prefs->showLocalTime) {
- appCore->setTimeZoneBias(-timezone + 3600 * daylight);
+ appCore->setTimeZoneBias(-linux_timezone + 3600 * daylight);
appCore->setTimeZoneName(tzname[daylight]);
}
else {
@@ -4126,6 +4130,18 @@
// MAIN
int main(int argc, char* argv[])
{
+ time_t now;
+ struct tm *tm;
+
+ // provide Linux's daylight and timezone
+ now = time(NULL);
+ if (now >= 0)
+ {
+ tm = localtime(&now);
+ daylight = tm->tm_isdst;
+ linux_timezone = tm->tm_gmtoff;
+ }
+
// Say we're not ready to render yet.
bReady = false;

View file

@ -1,24 +0,0 @@
$FreeBSD$
author: Jean-Yves Lefort
--- src/celutil/resmanager.h.orig Tue Feb 15 18:52:35 2005
+++ src/celutil/resmanager.h Tue Feb 15 18:57:38 2005
@@ -72,7 +72,7 @@
{
ResourceHandle h = handles.size();
resources.insert(resources.end(), info);
- handles.insert(ResourceHandleMap::value_type(info, h));
+ handles.insert(typename ResourceHandleMap::value_type(info, h));
return h;
}
}
@@ -105,7 +105,7 @@
else
{
resources[h].state = ResourceLoaded;
- loadedResources.insert(NameMap::value_type(resources[h].resolvedName, resources[h].resource));
+ loadedResources.insert(typename NameMap::value_type(resources[h].resolvedName, resources[h].resource));
}
}
}

View file

@ -0,0 +1,10 @@
--- src/celutil/util.h.orig Thu May 4 11:51:00 2006
+++ src/celutil/util.h Thu May 4 11:51:12 2006
@@ -28,6 +28,7 @@
#ifdef _WIN32
#define _(s) s
#else
+#include <libintl.h>
#define _(s) gettext(s)
#endif

View file

@ -0,0 +1,6 @@
===============================================================================
IMPORTANT: the GConf daemon must be restarted after installing this
port, by typing:
gconftool-2 --shutdown && gconftool-2 --spawn
===============================================================================

324
astro/celestia/pkg-plist Normal file
View file

@ -0,0 +1,324 @@
bin/celestia
share/celestia/celestia.cfg
share/celestia/controls.txt
share/celestia/data/asterisms.dat
share/celestia/data/asteroids.ssc
share/celestia/data/boundaries.dat
share/celestia/data/cassini.xyz
share/celestia/data/comets.ssc
share/celestia/data/deepsky.dsc
share/celestia/data/earth_locs.ssc
share/celestia/data/eros_locs.ssc
share/celestia/data/extrasolar.ssc
share/celestia/data/extrasolar.stc
share/celestia/data/galileo.xyz
share/celestia/data/gaspra_locs.ssc
share/celestia/data/hdxindex.dat
share/celestia/data/huygens.xyz
share/celestia/data/ida_locs.ssc
share/celestia/data/jupitermoons_locs.ssc
share/celestia/data/mars_locs.ssc
share/celestia/data/marsmoons_locs.ssc
share/celestia/data/merc_locs.ssc
share/celestia/data/moon_locs.ssc
share/celestia/data/nearstars.stc
share/celestia/data/neptunemoons_locs.ssc
share/celestia/data/outersys.ssc
share/celestia/data/revised.stc
share/celestia/data/ring_locs.ssc
share/celestia/data/saoxindex.dat
share/celestia/data/saturnmoons_locs.ssc
share/celestia/data/solarsys.ssc
share/celestia/data/spacecraft.ssc
share/celestia/data/spectbins.stc
share/celestia/data/starnames.dat
share/celestia/data/stars.dat
share/celestia/data/uranusmoons_locs.ssc
share/celestia/data/venus_locs.ssc
share/celestia/data/visualbins.stc
share/celestia/data/world-capitals.ssc
share/celestia/demo.cel
share/celestia/extras/apollo.ssc
share/celestia/extras/comets.ssc
share/celestia/extras/minormoons.ssc
share/celestia/extras/numberedmoons.ssc
share/celestia/extras/shroxclassic.ssc
share/celestia/extras/shroxmars.ssc
share/celestia/extras/skylab.ssc
share/celestia/fonts/clean12.txf
share/celestia/fonts/clean16.txf
share/celestia/fonts/cleanbold12.txf
share/celestia/fonts/cleanbold16.txf
share/celestia/fonts/default.txf
share/celestia/fonts/helv10.txf
share/celestia/fonts/helv12.txf
share/celestia/fonts/helv18.txf
share/celestia/fonts/helv24.txf
share/celestia/fonts/helvbold12.txf
share/celestia/fonts/helvbold18.txf
share/celestia/fonts/helvbold24.txf
share/celestia/fonts/sans10.txf
share/celestia/fonts/sans12.txf
share/celestia/fonts/sans14.txf
share/celestia/fonts/sans20.txf
share/celestia/fonts/sansbold10.txf
share/celestia/fonts/sansbold12.txf
share/celestia/fonts/sansbold14.txf
share/celestia/fonts/sansbold20.txf
share/celestia/guide.cel
share/celestia/models/S0.pts
share/celestia/models/SBa.pts
share/celestia/models/SBb.pts
share/celestia/models/SBc.pts
share/celestia/models/Sa.pts
share/celestia/models/Sb.pts
share/celestia/models/Sc.pts
share/celestia/models/amalthea.cmod
share/celestia/models/asteroid.cms
share/celestia/models/bacchus.cmod
share/celestia/models/borrelly.cms
share/celestia/models/castalia.cmod
share/celestia/models/deimos.cmod
share/celestia/models/epimetheus.cmod
share/celestia/models/eros.cmod
share/celestia/models/eros.cms
share/celestia/models/gaspra.cmod
share/celestia/models/geographos.cmod
share/celestia/models/golevka.cmod
share/celestia/models/halley.cmod
share/celestia/models/hyperion.cmod
share/celestia/models/hyperion.cms
share/celestia/models/ida.cmod
share/celestia/models/janus.cmod
share/celestia/models/kleopatra.cmod
share/celestia/models/ky26.cmod
share/celestia/models/larissa.cmod
share/celestia/models/pandora.cmod
share/celestia/models/phobos.cmod
share/celestia/models/phoebe.cmod
share/celestia/models/prometheus.cmod
share/celestia/models/proteus.cmod
share/celestia/models/proteus.cms
share/celestia/models/roughsphere.cms
share/celestia/models/toutatis.cmod
share/celestia/models/vesta.cmod
share/celestia/shaders/bumpdiffuse.vp
share/celestia/shaders/bumpdiffuse_arb.vp
share/celestia/shaders/bumpdiffuse_nv.fp
share/celestia/shaders/bumphaze.vp
share/celestia/shaders/bumphaze_arb.vp
share/celestia/shaders/diffuse.vp
share/celestia/shaders/diffuse2_arb.vp
share/celestia/shaders/diffuse_arb.vp
share/celestia/shaders/diffuse_nv.fp
share/celestia/shaders/diffuse_texoff.vp
share/celestia/shaders/diffuse_texoff2_arb.vp
share/celestia/shaders/diffuse_texoff_arb.vp
share/celestia/shaders/eclipse1_nv.fp
share/celestia/shaders/eclipse2_nv.fp
share/celestia/shaders/ell_galaxy_arb.vp
share/celestia/shaders/glossmap_arb.vp
share/celestia/shaders/haze.vp
share/celestia/shaders/haze2_arb.vp
share/celestia/shaders/haze_arb.vp
share/celestia/shaders/multishadow_arb.vp
share/celestia/shaders/night.vp
share/celestia/shaders/night2_arb.vp
share/celestia/shaders/night_arb.vp
share/celestia/shaders/rings.vp
share/celestia/shaders/rings_arb.vp
share/celestia/shaders/ringshadow.vp
share/celestia/shaders/ringshadow_arb.vp
share/celestia/shaders/shadow_on_rings_nv.fp
share/celestia/shaders/shadowtex.vp
share/celestia/shaders/shadowtex_arb.vp
share/celestia/shaders/simple.vp
share/celestia/shaders/simple_arb.vp
share/celestia/shaders/specular.vp
share/celestia/shaders/specular2_arb.vp
share/celestia/shaders/specular_arb.vp
share/celestia/shaders/star_arb.vp
share/celestia/shaders/texphong_alpha_arb.vp
share/celestia/shaders/texphong_alpha_nv.fp
share/celestia/shaders/texphong_arb.vp
share/celestia/shaders/texphong_nv.fp
share/celestia/splash/splash.png
share/celestia/start.cel
share/celestia/textures/flare.jpg
share/celestia/textures/logo.png
share/celestia/textures/lores/amalthea.jpg
share/celestia/textures/lores/ariel-lok-mask.png
share/celestia/textures/lores/ariel.jpg
share/celestia/textures/lores/astar.jpg
share/celestia/textures/lores/asteroid.jpg
share/celestia/textures/lores/browndwarf.jpg
share/celestia/textures/lores/bstar.jpg
share/celestia/textures/lores/callisto-lok-mask.png
share/celestia/textures/lores/callisto.jpg
share/celestia/textures/lores/charon-lok-spec.jpg
share/celestia/textures/lores/charon-lok.jpg
share/celestia/textures/lores/deimos.jpg
share/celestia/textures/lores/dione.jpg
share/celestia/textures/lores/earth-clouds.png
share/celestia/textures/lores/earth.png
share/celestia/textures/lores/earthnight.jpg
share/celestia/textures/lores/enceladus.jpg
share/celestia/textures/lores/epimetheus-lok.jpg
share/celestia/textures/lores/epimetheus.jpg
share/celestia/textures/lores/eros.jpg
share/celestia/textures/lores/europa-lok-mask.png
share/celestia/textures/lores/europa.jpg
share/celestia/textures/lores/exo-class1.jpg
share/celestia/textures/lores/exo-class2.jpg
share/celestia/textures/lores/exo-class3.jpg
share/celestia/textures/lores/exo-class4.jpg
share/celestia/textures/lores/exo-class4night.jpg
share/celestia/textures/lores/exo-class5.jpg
share/celestia/textures/lores/exo-class5night.jpg
share/celestia/textures/lores/extrasolar-lok.jpg
share/celestia/textures/lores/ganymede-lok-mask.png
share/celestia/textures/lores/ganymede.jpg
share/celestia/textures/lores/gaspramosaic.jpg
share/celestia/textures/lores/gstar.jpg
share/celestia/textures/lores/hyperion-lok.jpg
share/celestia/textures/lores/hyperion.jpg
share/celestia/textures/lores/iapetus.jpg
share/celestia/textures/lores/idamosaic.jpg
share/celestia/textures/lores/io-lok-mask.png
share/celestia/textures/lores/io.jpg
share/celestia/textures/lores/janus.jpg
share/celestia/textures/lores/jupiter.jpg
share/celestia/textures/lores/mars.jpg
share/celestia/textures/lores/marsbump.jpg
share/celestia/textures/lores/mercury-lok-mask.png
share/celestia/textures/lores/mercury.jpg
share/celestia/textures/lores/mimas-lok-mask.png
share/celestia/textures/lores/mimas.jpg
share/celestia/textures/lores/miranda-lok-mask.png
share/celestia/textures/lores/miranda.jpg
share/celestia/textures/lores/moon.jpg
share/celestia/textures/lores/moonbump.jpg
share/celestia/textures/lores/mstar.jpg
share/celestia/textures/lores/neptune-rings.png
share/celestia/textures/lores/neptune.jpg
share/celestia/textures/lores/oberon-lok-mask.png
share/celestia/textures/lores/oberon.jpg
share/celestia/textures/lores/phobos.jpg
share/celestia/textures/lores/phoebe.jpg
share/celestia/textures/lores/pluto-lok-spec.jpg
share/celestia/textures/lores/pluto-lok.jpg
share/celestia/textures/lores/prometheus.jpg
share/celestia/textures/lores/proteus.jpg
share/celestia/textures/lores/rhea.jpg
share/celestia/textures/lores/saturn-rings.png
share/celestia/textures/lores/saturn.jpg
share/celestia/textures/lores/tethys.jpg
share/celestia/textures/lores/titan-clouds.jpg
share/celestia/textures/lores/titan.jpg
share/celestia/textures/lores/titania-lok-mask.png
share/celestia/textures/lores/titania.jpg
share/celestia/textures/lores/triton-lok-mask.png
share/celestia/textures/lores/triton.jpg
share/celestia/textures/lores/umbriel-lok-mask.png
share/celestia/textures/lores/umbriel.jpg
share/celestia/textures/lores/uranus-rings.png
share/celestia/textures/lores/uranus.jpg
share/celestia/textures/lores/venus.jpg
share/celestia/textures/lores/venuslike.jpg
share/celestia/textures/lores/venuslikenight.jpg
share/celestia/textures/lores/venussurface.jpg
share/celestia/textures/medres/amalthea.jpg
share/celestia/textures/medres/ariel.jpg
share/celestia/textures/medres/astar.jpg
share/celestia/textures/medres/asteroid.jpg
share/celestia/textures/medres/browndwarf.jpg
share/celestia/textures/medres/bstar.jpg
share/celestia/textures/medres/callisto.jpg
share/celestia/textures/medres/charon-lok-spec.jpg
share/celestia/textures/medres/charon-lok.jpg
share/celestia/textures/medres/deimos.jpg
share/celestia/textures/medres/dione.jpg
share/celestia/textures/medres/earth-clouds.png
share/celestia/textures/medres/earth.png
share/celestia/textures/medres/earthnight.jpg
share/celestia/textures/medres/enceladus.jpg
share/celestia/textures/medres/epimetheus-lok.jpg
share/celestia/textures/medres/epimetheus.jpg
share/celestia/textures/medres/eros.jpg
share/celestia/textures/medres/europa.jpg
share/celestia/textures/medres/exo-class1.jpg
share/celestia/textures/medres/exo-class2.jpg
share/celestia/textures/medres/exo-class3.jpg
share/celestia/textures/medres/exo-class4.jpg
share/celestia/textures/medres/exo-class4night.jpg
share/celestia/textures/medres/exo-class5.jpg
share/celestia/textures/medres/exo-class5night.jpg
share/celestia/textures/medres/ganymede.jpg
share/celestia/textures/medres/gaspramosaic.jpg
share/celestia/textures/medres/gstar.jpg
share/celestia/textures/medres/hyperion-lok.jpg
share/celestia/textures/medres/hyperion.jpg
share/celestia/textures/medres/iapetus.jpg
share/celestia/textures/medres/idamosaic.jpg
share/celestia/textures/medres/io.jpg
share/celestia/textures/medres/iss-cap1.jpg
share/celestia/textures/medres/iss-mc1.jpg
share/celestia/textures/medres/iss-mc31.jpg
share/celestia/textures/medres/iss-sol1.jpg
share/celestia/textures/medres/janus.jpg
share/celestia/textures/medres/jupiter.jpg
share/celestia/textures/medres/mars.jpg
share/celestia/textures/medres/marsbump.jpg
share/celestia/textures/medres/mercury.jpg
share/celestia/textures/medres/mimas.jpg
share/celestia/textures/medres/miranda.jpg
share/celestia/textures/medres/moon.jpg
share/celestia/textures/medres/moonbump.jpg
share/celestia/textures/medres/mstar.jpg
share/celestia/textures/medres/neptune.jpg
share/celestia/textures/medres/oberon.jpg
share/celestia/textures/medres/phobos.jpg
share/celestia/textures/medres/phoebe.jpg
share/celestia/textures/medres/pluto-lok-spec.jpg
share/celestia/textures/medres/pluto-lok.jpg
share/celestia/textures/medres/prometheus.jpg
share/celestia/textures/medres/proteus.jpg
share/celestia/textures/medres/rhea.jpg
share/celestia/textures/medres/saturn.jpg
share/celestia/textures/medres/tethys.jpg
share/celestia/textures/medres/titan-clouds.jpg
share/celestia/textures/medres/titan.jpg
share/celestia/textures/medres/titania.jpg
share/celestia/textures/medres/triton.jpg
share/celestia/textures/medres/umbriel.jpg
share/celestia/textures/medres/venus.jpg
share/celestia/textures/medres/venuslike.jpg
share/celestia/textures/medres/venuslikenight.jpg
share/celestia/textures/medres/venussurface.jpg
share/locale/de/LC_MESSAGES/celestia.mo
share/locale/el/LC_MESSAGES/celestia.mo
share/locale/en/LC_MESSAGES/celestia.mo
share/locale/es/LC_MESSAGES/celestia.mo
share/locale/fr/LC_MESSAGES/celestia.mo
share/locale/gl/LC_MESSAGES/celestia.mo
share/locale/hu/LC_MESSAGES/celestia.mo
share/locale/it/LC_MESSAGES/celestia.mo
share/locale/nl/LC_MESSAGES/celestia.mo
share/locale/pt/LC_MESSAGES/celestia.mo
share/locale/pt_br/LC_MESSAGES/celestia.mo
share/locale/ru/LC_MESSAGES/celestia.mo
share/pixmaps/celestia.png
@exec mkdir -p %D/share/celestia/textures/hires
@dirrm share/celestia/textures/medres
@dirrm share/celestia/textures/lores
@dirrm share/celestia/textures/hires
@dirrm share/celestia/textures
@dirrm share/celestia/splash
@dirrm share/celestia/shaders
@dirrm share/celestia/models
@dirrm share/celestia/fonts
@dirrm share/celestia/extras
@dirrm share/celestia/data
@dirrm share/celestia
@dirrmtry share/locale/pt_br/LC_MESSAGES
@dirrmtry share/locale/pt_br