Update to 3.3.10

PR:		74176
Submitted by:	Sergio Mangialardi <sergio@softshark.org>
This commit is contained in:
Tilman Keskinoz 2004-12-04 19:34:14 +00:00
parent fca78f573f
commit 6158be8800
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123126
8 changed files with 19 additions and 56 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= ddd
PORTVERSION= 3.3.9
PORTVERSION= 3.3.10
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_XPM= yes
USE_MOTIF= yes
USE_LIBTOOL_VER=13
USE_LIBTOOL_VER=15
CFLAGS+= -Wno-deprecated
CPPFLAGS+= -I${LOCALBASE}/include

View file

@ -1,2 +1,2 @@
MD5 (ddd-3.3.9.tar.gz) = acfca53c62507795f4ceb355cb34e2a2
SIZE (ddd-3.3.9.tar.gz) = 8238347
MD5 (ddd-3.3.10.tar.gz) = a10a3b55455cce8073cf2f8db01ba1a1
SIZE (ddd-3.3.10.tar.gz) = 7620458

View file

@ -1,6 +1,6 @@
--- configure.orig Thu Aug 19 19:58:54 2004
+++ configure Thu Aug 19 20:08:09 2004
@@ -3009,7 +3009,7 @@
--- configure.orig Sat Nov 6 18:47:15 2004
+++ configure Sat Nov 6 18:51:40 2004
@@ -2985,7 +2985,7 @@
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
@ -9,7 +9,7 @@
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
@@ -35756,7 +35756,7 @@
@@ -36132,7 +36132,7 @@
_ACEOF
if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |

View file

@ -1,5 +1,5 @@
--- ddd/LiterateA.C.orig Thu Aug 19 20:16:55 2004
+++ ddd/LiterateA.C Thu Aug 19 20:23:49 2004
--- ddd/LiterateA.C.orig Sat Nov 6 19:00:37 2004
+++ ddd/LiterateA.C Sat Nov 6 19:04:44 2004
@@ -216,8 +216,12 @@
int flags = fcntl(fileno(fp), F_GETFL, 0);
if (flags == -1)
@ -8,9 +8,9 @@
- _raiseIOWarning("cannot set file to non-blocking mode");
+ if (fcntl(fileno(fp), F_SETFL, flags | O_NONBLOCK) == -1) {
+#if defined(__FreeBSD__)
+ if(errno != EAGAIN)
+ if(errno != EAGAIN)
+#endif
+ _raiseIOWarning("cannot set file to non-blocking mode");
+ _raiseIOWarning("cannot set file to non-blocking mode");
+ }
#endif
@ -23,9 +23,9 @@
- _raiseIOWarning("cannot restore file mode");
+ if (fcntl(fileno(fp), F_SETFL, flags) == -1) {
+#if defined(__FreeBSD__)
+ if(errno != EAGAIN)
+ if(errno != EAGAIN)
+#endif
+ _raiseIOWarning("cannot restore file mode");
+ _raiseIOWarning("cannot restore file mode");
+ }
#endif

View file

@ -1,6 +1,6 @@
--- ddd/Makefile.in.orig Thu Aug 19 20:39:55 2004
+++ ddd/Makefile.in Thu Aug 19 20:40:10 2004
@@ -469,7 +469,7 @@
--- ddd/Makefile.in.orig Sat Nov 6 18:53:54 2004
+++ ddd/Makefile.in Sat Nov 6 18:54:32 2004
@@ -369,7 +369,7 @@
LPR = @LPR@
LTLIBOBJS = @LTLIBOBJS@
M4 = @M4@

View file

@ -1,5 +1,5 @@
--- ddd/TTYAgent.C.orig Thu Aug 19 20:41:45 2004
+++ ddd/TTYAgent.C Thu Aug 19 20:45:56 2004
--- ddd/TTYAgent.C.orig Sat Nov 6 19:05:52 2004
+++ ddd/TTYAgent.C Sat Nov 6 19:08:23 2004
@@ -715,8 +715,19 @@
}
else

View file

@ -1,18 +0,0 @@
--- libiberty/strerror.c.orig Thu Aug 19 20:54:24 2004
+++ libiberty/strerror.c Thu Aug 19 20:55:15 2004
@@ -460,6 +460,7 @@
same name, it differs from other implementations in that it is dynamically
initialized rather than statically initialized. */
+#ifndef __FreeBSD__
#ifndef HAVE_SYS_ERRLIST
#define sys_nerr sys_nerr__
@@ -472,6 +473,7 @@
extern int sys_nerr;
extern char *sys_errlist[];
+#endif
#endif
/*

View file

@ -1,19 +0,0 @@
--- libiberty/strsignal.c.orig Thu Aug 19 20:58:24 2004
+++ libiberty/strsignal.c Thu Aug 19 20:59:24 2004
@@ -241,6 +241,7 @@
same name, it differs from other implementations in that it is dynamically
initialized rather than statically initialized. */
+#ifndef __FreeBSD__
#ifndef HAVE_SYS_SIGLIST
static int sys_nsig;
@@ -258,7 +259,7 @@
extern const char * const sys_siglist[];
#endif
-
+#endif
/*