Patch for Doc/Makefile.in to:

- Add --no-split to the makeinfo command line.
- Remove info files before makeinfo.
This commit is contained in:
Masafumi Max NAKANE 1997-06-16 11:49:17 +00:00
parent c7e688d572
commit 619aa31ea8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6965
2 changed files with 42 additions and 0 deletions

View file

@ -0,0 +1,21 @@
--- Doc/Makefile.in.orig Wed Dec 18 05:14:11 1996
+++ Doc/Makefile.in Mon Jun 16 20:40:29 1997
@@ -93,7 +93,8 @@
everything: all zsh_us.ps zsh_a4.ps zsh_toc.html
zsh.info: zsh.texi
- @$(MAKEINFO) -I$(srcdir) $(srcdir)/zsh.texi || { \
+ @rm -f zsh.info*
+ @$(MAKEINFO) --no-split -I$(srcdir) $(srcdir)/zsh.texi || { \
echo Info documentation cannot be compiled without $(MAKEINFO). ; \
echo You can find precompiled info files in zsh-doc.tar.gz. ; }
@@ -127,7 +128,7 @@
# install info pages, creating install directory if necessary
install.info: zsh.info
$(top_srcdir)/mkinstalldirs $(infodir)
- for file in zsh.info zsh.info-[1-9]; do \
+ for file in zsh.info*; do \
[ -f "$$file" ] && $(INSTALL_DATA) $$file $(infodir) ; \
done

21
shells/zsh/files/patch-ab Normal file
View file

@ -0,0 +1,21 @@
--- Doc/Makefile.in.orig Wed Dec 18 05:14:11 1996
+++ Doc/Makefile.in Mon Jun 16 20:40:29 1997
@@ -93,7 +93,8 @@
everything: all zsh_us.ps zsh_a4.ps zsh_toc.html
zsh.info: zsh.texi
- @$(MAKEINFO) -I$(srcdir) $(srcdir)/zsh.texi || { \
+ @rm -f zsh.info*
+ @$(MAKEINFO) --no-split -I$(srcdir) $(srcdir)/zsh.texi || { \
echo Info documentation cannot be compiled without $(MAKEINFO). ; \
echo You can find precompiled info files in zsh-doc.tar.gz. ; }
@@ -127,7 +128,7 @@
# install info pages, creating install directory if necessary
install.info: zsh.info
$(top_srcdir)/mkinstalldirs $(infodir)
- for file in zsh.info zsh.info-[1-9]; do \
+ for file in zsh.info*; do \
[ -f "$$file" ] && $(INSTALL_DATA) $$file $(infodir) ; \
done