Nitrogen is a background browser and setter for X windows. It is written
in C++ using the gtkmm toolkit. WWW: http://l3ib.org/nitrogen PR: ports/114282 Submitted by: Jonathan Liu <Net147 at hotmail.com>
This commit is contained in:
parent
eca23a2738
commit
61cbb12adc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196769
8 changed files with 128 additions and 0 deletions
|
@ -417,6 +417,7 @@
|
|||
SUBDIR += nctop
|
||||
SUBDIR += ndir
|
||||
SUBDIR += netdump-server
|
||||
SUBDIR += nitrogen
|
||||
SUBDIR += no-login
|
||||
SUBDIR += npadmin
|
||||
SUBDIR += nrg2iso
|
||||
|
|
45
sysutils/nitrogen/Makefile
Normal file
45
sysutils/nitrogen/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# Ports collection makefile for: nitrogen
|
||||
# Date created: 4 July 3007
|
||||
# Whom: Jonathan Liu <Net147@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= nitrogen
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://l3ib.org/nitrogen/files/ \
|
||||
http://www.sourcefiles.org/Toys/Candy/
|
||||
|
||||
MAINTAINER= Net147@hotmail.com
|
||||
COMMENT= Background browser and setter for X windows
|
||||
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
|
||||
LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
|
||||
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme \
|
||||
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
|
||||
|
||||
USE_GNOME= gtk20
|
||||
INSTALLS_ICONS= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-inotify
|
||||
CXXFLAGS+= -I${X11BASE}/include -L${X11BASE}/lib
|
||||
|
||||
OPTIONS= XINERAMA "Xinerama support" on
|
||||
|
||||
MAN1= nitrogen.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_XINERAMA)
|
||||
CONFIGURE_ARGS+=--disable-xinerama
|
||||
.else
|
||||
CONFIGURE_ARGS+=--enable-xinerama
|
||||
LIB_DEPENDS+= Xinerama:${PORTSDIR}/x11/libXinerama
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,' \
|
||||
${WRKSRC}/data/icon-theme-installer
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
sysutils/nitrogen/distinfo
Normal file
3
sysutils/nitrogen/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (nitrogen-1.0.tar.gz) = 9f5cae247a6aae12900a72cff4cd24f2
|
||||
SHA256 (nitrogen-1.0.tar.gz) = 7e708ed33bdde8d4d4a122207337e061a9ab4f3f62cfd08a617576dd55300213
|
||||
SIZE (nitrogen-1.0.tar.gz) = 231632
|
17
sysutils/nitrogen/files/patch-data-icon-theme-installer
Normal file
17
sysutils/nitrogen/files/patch-data-icon-theme-installer
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- data/icon-theme-installer.orig Sun Dec 31 16:59:08 2006
|
||||
+++ data/icon-theme-installer Tue Jul 3 21:45:35 2007
|
||||
@@ -101,12 +101,12 @@
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-if test ! -x $(echo "$MKINSTALLDIRS_EXEC" | cut -f1 -d' '); then
|
||||
+if test ! -x $(which $(echo "$MKINSTALLDIRS_EXEC" | cut -f1 -d' ')); then
|
||||
echo "Cannot find '$MKINSTALLDIRS_EXEC'; You probably want to pass -m \$(mkinstalldirs)"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-if test ! -x $(echo "$INSTALL_DATA_EXEC" | cut -f1 -d' '); then
|
||||
+if test ! -x $(which $(echo "$INSTALL_DATA_EXEC" | cut -f1 -d' ')); then
|
||||
echo "Cannot find '$INSTALL_DATA_EXEC'; You probably want to pass -x \$(INSTALL_DATA)"
|
||||
exit 1
|
||||
fi
|
20
sysutils/nitrogen/files/patch-src-NWindow.cc
Normal file
20
sysutils/nitrogen/files/patch-src-NWindow.cc
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- src/NWindow.cc.orig Sat May 12 05:12:25 2007
|
||||
+++ src/NWindow.cc Wed Jul 4 17:07:08 2007
|
||||
@@ -155,9 +155,16 @@
|
||||
void NWindow::setup_select_boxes() {
|
||||
|
||||
Glib::RefPtr<Gtk::IconTheme> icontheme = Gtk::IconTheme::get_default();
|
||||
+ Glib::RefPtr<Gtk::IconTheme> gnomeicontheme = Gtk::IconTheme::create();
|
||||
Glib::RefPtr<Gdk::Pixbuf> icon, genericicon;
|
||||
|
||||
- genericicon = icontheme->load_icon("image-x-generic", 16, Gtk::ICON_LOOKUP_NO_SVG);
|
||||
+ gnomeicontheme->set_custom_theme("gnome");
|
||||
+
|
||||
+ try {
|
||||
+ genericicon = icontheme->load_icon("image-x-generic", 16, Gtk::ICON_LOOKUP_NO_SVG);
|
||||
+ } catch (...) {
|
||||
+ genericicon = gnomeicontheme->load_icon("image-x-generic", 16, Gtk::ICON_LOOKUP_NO_SVG);
|
||||
+ }
|
||||
|
||||
// modes
|
||||
try {
|
27
sysutils/nitrogen/files/patch-src-Thumbview.cc
Normal file
27
sysutils/nitrogen/files/patch-src-Thumbview.cc
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- src/Thumbview.cc.orig Tue Jan 30 04:01:36 2007
|
||||
+++ src/Thumbview.cc Wed Jul 4 17:10:44 2007
|
||||
@@ -56,6 +56,11 @@
|
||||
* Constructor, sets up gtk stuff, inits data and queues
|
||||
*/
|
||||
Thumbview::Thumbview() : dir("") {
|
||||
+ Glib::RefPtr<Gtk::IconTheme> icontheme = Gtk::IconTheme::get_default();
|
||||
+ Glib::RefPtr<Gtk::IconTheme> gnomeicontheme = Gtk::IconTheme::create();
|
||||
+
|
||||
+ gnomeicontheme->set_custom_theme("gnome");
|
||||
+
|
||||
set_policy (Gtk::POLICY_NEVER, Gtk::POLICY_AUTOMATIC);
|
||||
set_shadow_type (Gtk::SHADOW_IN);
|
||||
|
||||
@@ -96,7 +101,11 @@
|
||||
// store->set_sort_column (short_filename, Gtk::SORT_ASCENDING);
|
||||
|
||||
// load loading image
|
||||
- this->loading_image = Gtk::IconTheme::get_default()->load_icon("image-loading", 64, Gtk::ICON_LOOKUP_FORCE_SVG);
|
||||
+ try {
|
||||
+ this->loading_image = icontheme->load_icon("image-loading", 64, Gtk::ICON_LOOKUP_FORCE_SVG);
|
||||
+ } catch (...) {
|
||||
+ this->loading_image = gnomeicontheme->load_icon("image-loading", 64, Gtk::ICON_LOOKUP_FORCE_SVG);
|
||||
+ }
|
||||
|
||||
// make our async queues
|
||||
this->aqueue_createthumbs = g_async_queue_new();
|
4
sysutils/nitrogen/pkg-descr
Normal file
4
sysutils/nitrogen/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Nitrogen is a background browser and setter for X windows. It is written
|
||||
in C++ using the gtkmm toolkit.
|
||||
|
||||
WWW: http://l3ib.org/nitrogen
|
11
sysutils/nitrogen/pkg-plist
Normal file
11
sysutils/nitrogen/pkg-plist
Normal file
|
@ -0,0 +1,11 @@
|
|||
bin/nitrogen
|
||||
share/icons/hicolor/128x128/apps/nitrogen.png
|
||||
share/icons/hicolor/16x16/apps/nitrogen.png
|
||||
share/icons/hicolor/22x22/apps/nitrogen.png
|
||||
share/icons/hicolor/32x32/apps/nitrogen.png
|
||||
share/icons/hicolor/48x48/apps/nitrogen.png
|
||||
share/icons/hicolor/16x16/devices/video-display.png
|
||||
share/icons/hicolor/16x16/actions/wallpaper-bestfit.png
|
||||
share/icons/hicolor/16x16/actions/wallpaper-centered.png
|
||||
share/icons/hicolor/16x16/actions/wallpaper-scaled.png
|
||||
share/icons/hicolor/16x16/actions/wallpaper-tiled.png
|
Loading…
Reference in a new issue