net/libnfs: Update to 5.0.1

Approved by:	maintainer timeout
This commit is contained in:
Kirill Ponomarev 2022-04-17 08:53:18 +02:00
parent 2268ec40fb
commit 61d70f727d
5 changed files with 22 additions and 21 deletions

View file

@ -1,29 +1,28 @@
# Created by: Manuel Creach <manuel.creach@icloud.com>
PORTNAME= libnfs
PORTVERSION= 4.0.0
PORTREVISION= 1
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 5.0.1
CATEGORIES= net
MAINTAINER= snoe925@gmail.com
COMMENT= Client library for accessing NFS shares over a network
LICENSE= LGPL21 GPLv3
LICENSE= GPLv3 LGPL21
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
PLIST_SUB= SHLIB=${SHLIB}
SHLIB= 13
GNU_CONFIGURE= yes
USES= autoreconf gmake libtool pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= sahlberg
USE_LDCONFIG= yes
SHLIB= 14
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-werror
PLIST_SUB= SHLIB=${SHLIB}
post-patch:
${REINPLACE_CMD} 's|$$(libdir)/\(pkgconfig\)|$$(prefix)/libdata/\1|' \
${WRKSRC}/Makefile.am

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1550007484
SHA256 (sahlberg-libnfs-libnfs-4.0.0_GH0.tar.gz) = 6ee77e9fe220e2d3e3b1f53cfea04fb319828cc7dbb97dd9df09e46e901d797d
SIZE (sahlberg-libnfs-libnfs-4.0.0_GH0.tar.gz) = 251662
TIMESTAMP = 1650110743
SHA256 (sahlberg-libnfs-libnfs-5.0.1_GH0.tar.gz) = 7ef445410b42f36b9bad426608b53ccb9ccca4101e545c383f564c11db672ca8
SIZE (sahlberg-libnfs-libnfs-5.0.1_GH0.tar.gz) = 279550

View file

@ -1,10 +0,0 @@
--- include/nfsc/libnfs-zdr.h.orig 2020-07-26 21:16:08 UTC
+++ include/nfsc/libnfs-zdr.h
@@ -92,7 +92,6 @@ struct ZDR {
typedef struct ZDR ZDR;
-typedef uint32_t u_int;
typedef uint32_t enum_t;
typedef uint32_t bool_t;

View file

@ -0,0 +1,11 @@
--- include/nfsc/libnfs.h
+++ include/nfsc/libnfs.h
@@ -29,7 +29,7 @@
#include <stdint.h>
#if defined(__ANDROID__) || defined(AROS) || defined(__PPU__) \
- || ( defined(__APPLE__) && defined(__MACH__) )
+ || ( defined(__APPLE__) && defined(__MACH__) ) || defined(__FreeBSD__)
#include <sys/time.h>
#else
#include <time.h>

View file

@ -1,6 +1,7 @@
bin/nfs-cat
bin/nfs-cp
bin/nfs-ls
bin/nfs-stat
lib/libnfs.a
lib/libnfs.so
lib/libnfs.so.%%SHLIB%%