Update conky to 1.11.2
New version uses an embedded version of toloa++ and drops support for lua 5.1
This commit is contained in:
parent
d9f155bd7e
commit
61fcfeb1fe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489991
10 changed files with 50 additions and 104 deletions
|
@ -2,21 +2,20 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= conky
|
||||
PORTVERSION= 1.11.1
|
||||
PORTVERSION= 1.11.2
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= madpilot@FreeBSD.org
|
||||
COMMENT?= Advanced, highly configurable system monitor for X11
|
||||
|
||||
LIB_DEPENDS= libtolua++-5.1.so:lang/tolua++ \
|
||||
libinotify.so:devel/libinotify
|
||||
LIB_DEPENDS= libinotify.so:devel/libinotify
|
||||
BUILD_DEPENDS= db2x_xsltproc:textproc/docbook2X \
|
||||
docbook-xsl>=0:textproc/docbook-xsl \
|
||||
xsltproc:textproc/libxslt
|
||||
|
||||
USES= cpe cmake:noninja compiler:c++11-lib gettext-runtime iconv \
|
||||
localbase lua:51 pkgconfig tar:bzip2
|
||||
localbase lua:53 pkgconfig tar:bzip2
|
||||
|
||||
CMAKE_ARGS+= -DBUILD_PORT_MONITORS:BOOL=false \
|
||||
-DBUILD_IBM:BOOL=false \
|
||||
|
@ -132,8 +131,7 @@ post-patch:
|
|||
-e 's/ -lbsd/ -lintl -linotify/' \
|
||||
${WRKSRC}/cmake/ConkyPlatformChecks.cmake
|
||||
@${REINPLACE_CMD} -e 's,LOCALBASE,${LOCALBASE},' \
|
||||
${WRKSRC}/doc/docgen.sh \
|
||||
${WRKSRC}/doc/docs.xml
|
||||
${WRKSRC}/doc/docgen.sh
|
||||
|
||||
post-build:
|
||||
(cd ${WRKSRC}/doc && ${SH} docgen.sh)
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1545078509
|
||||
SHA256 (brndnmtthws-conky-v1.11.1_GH0.tar.gz) = 71fab859946cc2e67be46f2db53859c66369c5c87acf18fc8dfbd41b114f6d6e
|
||||
SIZE (brndnmtthws-conky-v1.11.1_GH0.tar.gz) = 1091759
|
||||
TIMESTAMP = 1547073048
|
||||
SHA256 (brndnmtthws-conky-v1.11.2_GH0.tar.gz) = 1acf9dae9ce1a762309ab6b600a0464c2e054420d416b515ff39658430a0e819
|
||||
SIZE (brndnmtthws-conky-v1.11.2_GH0.tar.gz) = 2373307
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- CMakeLists.txt.orig 2018-12-02 18:26:02 UTC
|
||||
--- CMakeLists.txt.orig 2019-01-08 01:26:24 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -54,26 +54,27 @@ add_subdirectory(doc)
|
||||
add_subdirectory(src)
|
||||
@@ -72,9 +72,12 @@ if(BUILD_TESTS)
|
||||
endif()
|
||||
|
||||
IF(NOT DEFINED DOC_PATH)
|
||||
if(NOT DEFINED DOC_PATH)
|
||||
- set(DOC_PATH "share/doc/${CPACK_PACKAGE_NAME}-${VERSION}")
|
||||
+ set(DOC_PATH "share/doc/${CPACK_PACKAGE_NAME}")
|
||||
ENDIF(NOT DEFINED DOC_PATH)
|
||||
endif(NOT DEFINED DOC_PATH)
|
||||
-set(DOC_FILES extras/convert.lua data/conky_no_x11.conf data/conky.conf)
|
||||
+IF(NOT DEFINED SAMPLE_PATH)
|
||||
+ set(SAMPLE_PATH "share/examples/${CPACK_PACKAGE_NAME}")
|
||||
|
@ -14,28 +14,25 @@
|
|||
+set(SAMPLE_FILES extras/convert.lua data/conky_no_x11.conf data/conky.conf)
|
||||
|
||||
set(HTML_PATH "${DOC_PATH}/html")
|
||||
set(HTML_FILES doc/config_settings.html doc/docs.html doc/lua.html doc/variables.html)
|
||||
set(HTML_FILES
|
||||
@@ -83,16 +86,14 @@ set(HTML_FILES
|
||||
doc/lua.html
|
||||
doc/variables.html)
|
||||
|
||||
-set(MAN_PATH "share/man/man1")
|
||||
+set(MAN_PATH "man/man1")
|
||||
set(MAN_FILES doc/conky.1)
|
||||
|
||||
-install(FILES ${DOC_FILES}
|
||||
- DESTINATION ${DOC_PATH})
|
||||
+install(FILES ${SAMPLE_FILES}
|
||||
+ DESTINATION ${SAMPLE_PATH})
|
||||
-install(FILES ${DOC_FILES} DESTINATION ${DOC_PATH})
|
||||
+install(FILES ${SAMPLE_FILES} DESTINATION ${SAMPLE_PATH})
|
||||
|
||||
-if(MAINTAINER_MODE)
|
||||
- install(FILES ${HTML_FILES}
|
||||
- DESTINATION ${HTML_PATH})
|
||||
+install(FILES ${HTML_FILES}
|
||||
+ DESTINATION ${HTML_PATH})
|
||||
- install(FILES ${HTML_FILES} DESTINATION ${HTML_PATH})
|
||||
+install(FILES ${HTML_FILES} DESTINATION ${HTML_PATH})
|
||||
|
||||
- install(FILES ${MAN_FILES}
|
||||
- DESTINATION ${MAN_PATH})
|
||||
- install(FILES ${MAN_FILES} DESTINATION ${MAN_PATH})
|
||||
-endif(MAINTAINER_MODE)
|
||||
+install(FILES ${MAN_FILES}
|
||||
+ DESTINATION ${MAN_PATH})
|
||||
+install(FILES ${MAN_FILES} DESTINATION ${MAN_PATH})
|
||||
|
||||
if(CHECK_CODE_QUALITY)
|
||||
# Set up clang-tidy
|
||||
|
|
11
sysutils/conky/files/patch-cmake_Conky.cmake
Normal file
11
sysutils/conky/files/patch-cmake_Conky.cmake
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- cmake/Conky.cmake.orig 2019-01-08 01:26:24 UTC
|
||||
+++ cmake/Conky.cmake
|
||||
@@ -18,7 +18,7 @@
|
||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
|
||||
-# set(RELEASE true)
|
||||
+set(RELEASE true)
|
||||
|
||||
# Set system vars
|
||||
if(CMAKE_SYSTEM_NAME MATCHES "Linux")
|
|
@ -1,10 +0,0 @@
|
|||
--- doc/docs.xml.orig 2016-07-20 16:53:48 UTC
|
||||
+++ doc/docs.xml
|
||||
@@ -1,6 +1,6 @@
|
||||
<?xml version="1.0" encoding="utf-8"?>
|
||||
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.4//EN"
|
||||
-"http://www.oasis-open.org/docbook/xml/4.4/docbookx.dtd"
|
||||
+"LOCALBASE/share/xml/docbook/4.4/docbookx.dtd"
|
||||
[
|
||||
<!ENTITY command_options SYSTEM "command_options.xml">
|
||||
<!ENTITY config_settings SYSTEM "config_settings.xml">
|
|
@ -1,29 +0,0 @@
|
|||
--- src/bsdapm.cc.orig 2018-12-16 17:16:51 UTC
|
||||
+++ src/bsdapm.cc
|
||||
@@ -61,7 +61,7 @@ static int apm_getinfo(int fd, apm_info_t aip) {
|
||||
return 0;
|
||||
}
|
||||
|
||||
-void print_apm_adapter(struct text_object *obj, char *p, int p_max_size) {
|
||||
+void print_apm_adapter(struct text_object *obj, char *p, unsigned int p_max_size) {
|
||||
int fd;
|
||||
const char *out;
|
||||
#ifdef __OpenBSD__
|
||||
@@ -109,7 +109,7 @@ void print_apm_adapter(struct text_object *obj, char *
|
||||
snprintf(p, p_max_size, "%s", out);
|
||||
}
|
||||
|
||||
-void print_apm_battery_life(struct text_object *obj, char *p, int p_max_size) {
|
||||
+void print_apm_battery_life(struct text_object *obj, char *p, unsigned int p_max_size) {
|
||||
int fd;
|
||||
u_int batt_life;
|
||||
const char *out;
|
||||
@@ -150,7 +150,7 @@ void print_apm_battery_life(struct text_object *obj, c
|
||||
snprintf(p, p_max_size, "%s", out);
|
||||
}
|
||||
|
||||
-void print_apm_battery_time(struct text_object *obj, char *p, int p_max_size) {
|
||||
+void print_apm_battery_time(struct text_object *obj, char *p, unsigned int p_max_size) {
|
||||
int fd;
|
||||
int batt_time;
|
||||
#ifdef __OpenBSD__
|
|
@ -1,14 +0,0 @@
|
|||
--- src/bsdapm.h.orig 2018-12-02 18:26:02 UTC
|
||||
+++ src/bsdapm.h
|
||||
@@ -29,8 +29,8 @@
|
||||
#ifndef _BSDAPM_H
|
||||
#define _BSDAPM_H
|
||||
|
||||
-void print_apm_adapter(struct text_object *, char *, int);
|
||||
-void print_apm_battery_life(struct text_object *, char *, int);
|
||||
-void print_apm_battery_time(struct text_object *, char *, int);
|
||||
+void print_apm_adapter(struct text_object *, char *, unsigned int);
|
||||
+void print_apm_battery_life(struct text_object *, char *, unsigned int);
|
||||
+void print_apm_battery_time(struct text_object *, char *, unsigned int);
|
||||
|
||||
#endif /* _BSDAPM_H */
|
|
@ -1,11 +0,0 @@
|
|||
--- src/freebsd.cc.orig 2018-12-16 17:16:51 UTC
|
||||
+++ src/freebsd.cc
|
||||
@@ -254,6 +254,8 @@ int update_total_processes(void) {
|
||||
kvm_getprocs(kd, KERN_PROC_ALL, 0, &n_processes);
|
||||
|
||||
info.procs = n_processes;
|
||||
+
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
int update_running_processes(void) {
|
|
@ -1,15 +1,6 @@
|
|||
--- src/luamm.cc.orig 2018-12-02 18:26:02 UTC
|
||||
--- src/luamm.cc.orig 2019-01-08 01:26:24 UTC
|
||||
+++ src/luamm.cc
|
||||
@@ -56,7 +56,7 @@ int exception_to_string(lua_State *l) {
|
||||
} catch (std::exception &e) {
|
||||
lua_pushstring(l, e.what());
|
||||
} catch (...) {
|
||||
-#if defined(__APPLE__) && defined(__MACH__)
|
||||
+#if (defined(__APPLE__) && defined(__MACH__)) || defined(__FreeBSD__)
|
||||
// lua_pushstring(l, ptr->__cxa_exception_type()->name());
|
||||
printf(
|
||||
"%s: FIXME: no member named '__cxa_exception_type' in "
|
||||
@@ -345,7 +345,7 @@ int state::gc(int what, int data) {
|
||||
@@ -336,7 +336,7 @@ int state::gc(int what, int data) {
|
||||
pushinteger(what);
|
||||
pushinteger(data);
|
||||
call(2, 1, 0);
|
||||
|
@ -18,7 +9,7 @@
|
|||
int r = tointeger(-1);
|
||||
pop();
|
||||
return r;
|
||||
@@ -420,7 +420,7 @@ bool state::next(int index) {
|
||||
@@ -411,7 +411,7 @@ bool state::next(int index) {
|
||||
|
||||
call(2, MULTRET, 0);
|
||||
|
||||
|
@ -27,7 +18,7 @@
|
|||
int r = tointeger(-1);
|
||||
pop();
|
||||
return r != 0;
|
||||
@@ -460,7 +460,7 @@ bool state::safe_compare(lua_CFunction trampoline, int
|
||||
@@ -451,7 +451,7 @@ bool state::safe_compare(lua_CFunction trampoline, int
|
||||
pushvalue(index1);
|
||||
pushvalue(index2);
|
||||
call(2, 1, 0);
|
||||
|
|
13
sysutils/conky/files/patch-src_main.cc
Normal file
13
sysutils/conky/files/patch-src_main.cc
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/main.cc.orig 2019-01-08 01:26:24 UTC
|
||||
+++ src/main.cc
|
||||
@@ -359,10 +359,6 @@ int main(int argc, char **argv) {
|
||||
return EXIT_FAILURE;
|
||||
}
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
|
||||
- kvm_close(kd);
|
||||
-#endif
|
||||
-
|
||||
#ifdef LEAKFREE_NCURSES
|
||||
_nc_free_and_exit(0); // hide false memleaks
|
||||
#endif
|
Loading…
Reference in a new issue