New port, games/goldencheetah: Training software for cyclists.
http://www.goldencheetah.org/ PR: 203080 Submitted by: trebbu@googlemail.com (maintainer) Approved by: swills (maintainer) Differential Revision: https://reviews.freebsd.org/D8383
This commit is contained in:
parent
7d283c7225
commit
6207538494
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=425082
8 changed files with 177 additions and 0 deletions
|
@ -366,6 +366,7 @@
|
|||
SUBDIR += gnustep-ladder
|
||||
SUBDIR += gnustep-sudoku
|
||||
SUBDIR += golddig
|
||||
SUBDIR += goldencheetah
|
||||
SUBDIR += golly
|
||||
SUBDIR += gomoku
|
||||
SUBDIR += gondola
|
||||
|
|
52
games/goldencheetah/Makefile
Normal file
52
games/goldencheetah/Makefile
Normal file
|
@ -0,0 +1,52 @@
|
|||
# Created by: Bert Burgemeister <trebbu@googlemail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= GoldenCheetah
|
||||
PORTVERSION= 3.2
|
||||
DISTVERSIONPREFIX= V
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= trebbu@googlemail.com
|
||||
COMMENT= Training software for cyclists
|
||||
|
||||
LICENSE= BSD3CLAUSE GPLv2 LGPL21
|
||||
LICENSE_COMB= multi
|
||||
|
||||
LIB_DEPENDS= libical.so:devel/libical \
|
||||
libqwtplot3d-qt4.so:math/qwtplot3d-qt4 \
|
||||
libkqoauth.so:security/kqoauth \
|
||||
libvlc.so:multimedia/vlc-qt4
|
||||
|
||||
BROKEN_FreeBSD_9= Does not build on FreeBSD 9
|
||||
|
||||
USE_GITHUB= yes
|
||||
|
||||
DESKTOP_ENTRIES= "${PORTNAME}" \
|
||||
"${COMMENT}" \
|
||||
"${DATADIR}/gc.png" \
|
||||
"${PORTNAME}" \
|
||||
"Education;Sports;" \
|
||||
false
|
||||
|
||||
USES= bison gmake qmake
|
||||
USE_GL= gl glu
|
||||
USE_QT4= corelib gui linguist moc_build network opengl \
|
||||
qmake rcc script sql svg uic webkit xml
|
||||
INFO= GC3-FAQ GC3-Release GC31-Release
|
||||
|
||||
post-extract:
|
||||
${CP} ${WRKSRC}/src/gcconfig.pri.in ${WRKSRC}/src/gcconfig.pri
|
||||
${CP} ${WRKSRC}/qwt/qwtconfig.pri.in ${WRKSRC}/qwt/qwtconfig.pri
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/src/images/gc.png \
|
||||
${STAGEDIR}${DATADIR}/
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/${INFO_PATH}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/user/*.info \
|
||||
${STAGEDIR}${PREFIX}/${INFO_PATH}/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/user/*.pdf ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/goldencheetah/distinfo
Normal file
3
games/goldencheetah/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1477796528
|
||||
SHA256 (GoldenCheetah-GoldenCheetah-V3.2_GH0.tar.gz) = 6335a90a8d864932ef946b526872885518f6c104598e15cbd7ad7d69b4377ea7
|
||||
SIZE (GoldenCheetah-GoldenCheetah-V3.2_GH0.tar.gz) = 49052706
|
11
games/goldencheetah/files/patch-src_Settings.cpp
Normal file
11
games/goldencheetah/files/patch-src_Settings.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Settings.cpp.orig 2015-08-12 08:43:33 UTC
|
||||
+++ src/Settings.cpp
|
||||
@@ -11,6 +11,8 @@ int OperatingSystem = WINDOWS;
|
||||
int OperatingSystem = LINUX;
|
||||
#elif defined Q_OS_OPENBSD
|
||||
int OperatingSystem = OPENBSD;
|
||||
+#elif defined Q_OS_FREEBSD
|
||||
+int OperatingSystem = FREEBSD;
|
||||
#endif
|
||||
|
||||
static GSettings *GetApplicationSettings()
|
10
games/goldencheetah/files/patch-src_Settings.h
Normal file
10
games/goldencheetah/files/patch-src_Settings.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/Settings.h.orig 2015-08-12 08:43:33 UTC
|
||||
+++ src/Settings.h
|
||||
@@ -277,6 +277,7 @@ extern int OperatingSystem;
|
||||
#define LINUX 2
|
||||
#define OSX 3
|
||||
#define OPENBSD 4
|
||||
+#define FREEBSD 5
|
||||
|
||||
#if QT_VERSION > 0x050000
|
||||
#define OS_STYLE "Fusion"
|
79
games/goldencheetah/files/patch-src_gcconfig.pri
Normal file
79
games/goldencheetah/files/patch-src_gcconfig.pri
Normal file
|
@ -0,0 +1,79 @@
|
|||
--- src/gcconfig.pri.orig 2015-09-13 16:55:44 UTC
|
||||
+++ src/gcconfig.pri
|
||||
@@ -25,7 +25,7 @@
|
||||
# Let us know where flex and bison are installed.
|
||||
# You may need to specify the full path if things don't work.
|
||||
#QMAKE_LEX = flex
|
||||
-#QMAKE_YACC = bison
|
||||
+QMAKE_YACC = bison
|
||||
#win32 {
|
||||
# QMAKE_YACC = bison --file-prefix=y -t
|
||||
# QMAKE_MOVE = cmd /c move
|
||||
@@ -69,8 +69,8 @@
|
||||
# You may override the INCLUDE and LIB files if you like.
|
||||
# You *must* define KQOAUTH_INSTALL to use this feature.
|
||||
|
||||
-#KQOAUTH_INSTALL =
|
||||
-#KQOAUTH_INCLUDE =
|
||||
+KQOAUTH_INSTALL = /usr/local
|
||||
+KQOAUTH_INCLUDE = /usr/local/include/QtKOAuth
|
||||
#KQOAUTH_LIBS =
|
||||
|
||||
# If you want 3D plotting, you need to install qwtplot3d
|
||||
@@ -86,9 +86,9 @@
|
||||
# QWT3D_LIBS = $${QWT3D_INSTALL}/lib/libqwtplot3d.a
|
||||
# You may override the INCLUDE and LIB files if you like.
|
||||
# You *must* define QWT3D_INSTALL to use this feature.
|
||||
-#QWT3D_INSTALL =
|
||||
-#QWT3D_INCLUDE =
|
||||
-#QWT3D_LIBS =
|
||||
+QWT3D_INSTALL = /usr/local
|
||||
+QWT3D_INCLUDE = /usr/local/include/qwtplot3d-qt4
|
||||
+QWT3D_LIBS = /usr/local/lib/libqwtplot3d-qt4.so
|
||||
|
||||
# For TrainingPeaks.com upload/download you need to install the Qt Soap add-on
|
||||
# http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap
|
||||
@@ -128,9 +128,9 @@
|
||||
# ICAL_LIBS = $${ICAL_INSTALL}/lib/libical.a
|
||||
# You may override the INCLUDE and LIB files if you like.
|
||||
# You *must* define ICAL_INSTALL to use this feature.
|
||||
-#ICAL_INSTALL =
|
||||
+ICAL_INSTALL = /usr/local
|
||||
#ICAL_INCLUDE =
|
||||
-#ICAL_LIBS =
|
||||
+ICAL_LIBS = /usr/local/lib/libical.so
|
||||
|
||||
# If you want support for using USB1 sticks in Train View on Windows
|
||||
# then install the SiLabs USBXpress Software Development Kit (SDK)
|
||||
@@ -151,7 +151,7 @@
|
||||
# http://sourceforge.net/projects/libusb-win32/files/libusb-win32-releases/0.1.12.2/
|
||||
# You may override the INCLUDE and LIB files if you like.
|
||||
# You *must* define LIBUSB_INSTALL to use this feature.
|
||||
-#LIBUSB_INSTALL = /usr/local
|
||||
+LIBUSB_INSTALL = /usr
|
||||
#LIBUSB_INCLUDE =
|
||||
#LIBUSB_LIBS =
|
||||
|
||||
@@ -173,8 +173,8 @@
|
||||
# VLC_LIBS = -lvlc -lvlccore
|
||||
# You may override the INCLUDE and LIB files if you like.
|
||||
# You *must* define VLC_INSTALL to use this feature.
|
||||
-#VLC_INSTALL =
|
||||
-#VLC_INCLUDE =
|
||||
+VLC_INSTALL = /usr/local
|
||||
+VLC_INCLUDE = /usr/local/include/libvlc
|
||||
#VLC_LIBS =
|
||||
|
||||
# *** Mac users NOTE ***
|
||||
@@ -235,7 +235,9 @@ macx {
|
||||
#DEFINES += GC_HAVE_DWM
|
||||
|
||||
# What video playback do you want?
|
||||
-DEFINES += GC_VIDEO_NONE # dont add any video playback support
|
||||
+#DEFINES += GC_VIDEO_NONE # dont add any video playback support
|
||||
#DEFINES += GC_VIDEO_QUICKTIME # mac only and the default
|
||||
#DEFINES += GC_VIDEO_QT5 # use QT5 qvideowidget if QT > 5.2.1
|
||||
-#DEFINES += GC_VIDEO_VLC # use VideoLan library needs VLC_INSTALL defined above
|
||||
+DEFINES += GC_VIDEO_VLC # use VideoLan library needs VLC_INSTALL defined above
|
||||
+
|
||||
+DEFINES += GC_VERSION=\\\"3.2.0\\\"
|
14
games/goldencheetah/pkg-descr
Normal file
14
games/goldencheetah/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
Golden Cheetah is a cycling performance software. It imports ride data
|
||||
downloaded from various devices or exported from other programs,
|
||||
including TrainingPeaks WKO+ and the manufacturers' software for the
|
||||
Ergomo, Garmin, Polar, PowerTap, and SRM devices. It provides a rich
|
||||
set of analysis tools, including a critical power graph, BikeScore
|
||||
calculation, histogram analysis, a best interval finder, and a pedal
|
||||
force versus pedal velocity chart, to name just a few.
|
||||
|
||||
KML file support will be missing until libkml 1.3 becomes available.
|
||||
|
||||
Connecting with Strava has been made impossible by Strava's own API
|
||||
Agreement.
|
||||
|
||||
WWW: http://goldencheetah.org/
|
7
games/goldencheetah/pkg-plist
Normal file
7
games/goldencheetah/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
%%DATADIR%%/gc.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GC3-FAQ.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GC3-Manual.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GC3-Release.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GC31-Release.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Golden Cheetah Science v1.pdf
|
||||
bin/GoldenCheetah
|
Loading…
Reference in a new issue