The file renaming utilities consists of five programs designed to make renaming

of files faster and less cumbersome:
- qmv ("quick move") allows a bunch of file names to be edited in a text editor;
- imv ("interactive move") allows a single file name to be edited in the
  terminal using the GNU Readline library
- qcp and icp are similar to qmv and imv but copy files instead of moving them;
- deurlname removes URL encoded characters (such as %20 representing space) from
  file names.

WWW: http://www.nongnu.org/renameutils/

PR:		194045
Submitted by:	Matteo Cypriani <mcy@lm7.fr>
This commit is contained in:
Pawel Pekala 2014-12-12 22:16:44 +00:00
parent 121c9e3823
commit 62287039dd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374607
7 changed files with 119 additions and 0 deletions

View file

@ -777,6 +777,7 @@
SUBDIR += rej
SUBDIR += relaxconf
SUBDIR += rename
SUBDIR += renameutils
SUBDIR += reoback
SUBDIR += respond
SUBDIR += retail

View file

@ -0,0 +1,30 @@
# Created by: Matteo Cypriani <mcy@lm7.fr>
# $FreeBSD$
PORTNAME= renameutils
PORTVERSION= 0.12.0
CATEGORIES= sysutils converters
MASTER_SITES= SAVANNAH
MAINTAINER= mcy@lm7.fr
COMMENT= Rename files faster and more easily
LICENSE= GPLv3
RUN_DEPENDS= gls:${PORTSDIR}/sysutils/coreutils
GNU_CONFIGURE= yes
USES= readline charsetfix
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
# This should not be needed any more for the next upstream version
post-patch:
@${REINPLACE_CMD} -e 's/($$bindir)/$$(bindir)/' \
${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (renameutils-0.12.0.tar.gz) = cbd2f002027ccf5a923135c3f529c6d17fabbca7d85506a394ca37694a9eb4a3
SIZE (renameutils-0.12.0.tar.gz) = 954114

View file

@ -0,0 +1,13 @@
--- src/icmd.c.orig 2008-09-21 09:10:29 UTC
+++ src/icmd.c
@@ -45,8 +45,8 @@
#include "common/string-utils.h"
#include "common/common.h"
-#define MV_COMMAND "mv"
-#define CP_COMMAND "cp"
+#define MV_COMMAND "gmv"
+#define CP_COMMAND "gcp"
/* This list should be up to date with mv and cp!
* It was last updated on 2007-11-30 for
* Debian coreutils 5.97-5.4 in unstable.

View file

@ -0,0 +1,11 @@
--- src/qcmd.c.orig 2011-08-21 17:15:51 UTC
+++ src/qcmd.c
@@ -239,7 +239,7 @@
editor_program = xstrdup(editor_program);
if (ls_program == NULL)
- ls_program = xstrdup("ls");
+ ls_program = xstrdup("gls");
/* Parse format options */
if (format_options != NULL && !format->parse_options(format_options))

View file

@ -0,0 +1,10 @@
The file renaming utilities consists of five programs designed to make renaming
of files faster and less cumbersome:
- qmv ("quick move") allows a bunch of file names to be edited in a text editor;
- imv ("interactive move") allows a single file name to be edited in the
terminal using the GNU Readline library
- qcp and icp are similar to qmv and imv but copy files instead of moving them;
- deurlname removes URL encoded characters (such as %20 representing space) from
file names.
WWW: http://www.nongnu.org/renameutils/

View file

@ -0,0 +1,52 @@
bin/deurlname
bin/icmd
bin/icp
bin/imv
bin/qcmd
bin/qcp
bin/qmv
man/man1/deurlname.1.gz
man/man1/icmd.1.gz
man/man1/icp.1.gz
man/man1/imv.1.gz
man/man1/qcmd.1.gz
man/man1/qcp.1.gz
man/man1/qmv.1.gz
%%NLS%%share/locale/af/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/be/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/bg/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/ca/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/cs/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/da/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/de/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/el/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/es/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/et/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/eu/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/fi/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/fr/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/fr/LC_MESSAGES/renameutils.mo
%%NLS%%share/locale/ga/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/gl/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/hu/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/it/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/ja/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/ko/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/ms/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/nb/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/nl/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/pl/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/pt/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/ro/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/ru/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/rw/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/sk/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/sl/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/sv/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/sv/LC_MESSAGES/renameutils.mo
%%NLS%%share/locale/tr/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/uk/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/vi/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/renameutils-gnulib.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/renameutils-gnulib.mo