devel/gecode: Update 5.1.0 -> 6.2.0
Reset maintainer due to extended timeouts on bug #240101, #240100, #240089, as per policy. Approved by: dem.procopiou@gmail.com (maintainer's timeout; 62 days)
This commit is contained in:
parent
2b37629217
commit
62307392cf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=515748
4 changed files with 111 additions and 132 deletions
|
@ -2,12 +2,14 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gecode
|
||||
PORTVERSION= 5.1.0
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://www.gecode.org/download/
|
||||
DISTVERSIONPREFIX= release-
|
||||
DISTVERSION= 6.2.0
|
||||
CATEGORIES= devel math
|
||||
|
||||
MAINTAINER= dem.procopiou@gmail.com
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
|
||||
PATCHFILES= f08079c5df271869bc7c0799b3eccc52ca2f4d83.patch:-p1 # https://github.com/Gecode/gecode/pull/51
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Generic Constraint Development Environment
|
||||
|
||||
LICENSE= BSL MIT
|
||||
|
@ -16,49 +18,19 @@ LICENSE_COMB= multi
|
|||
NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
|
||||
NOT_FOR_ARCHS_REASON= needs code written to specify rounding control mechanism in Boost.Numeric.Interval
|
||||
|
||||
LIB_DEPENDS= libmpfr.so:math/mpfr \
|
||||
libgmp.so:math/gmp
|
||||
|
||||
USES= bison compiler:c++11-lang gmake perl5
|
||||
USE_PERL5= build
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-static \
|
||||
--enable-shared \
|
||||
--disable-doc-dot \
|
||||
--disable-doc-tagfile \
|
||||
--disable-doc-chm \
|
||||
--enable-driver \
|
||||
--enable-graph \
|
||||
--enable-flatzinc \
|
||||
--enable-sheduling \
|
||||
--disable-examples \
|
||||
--enable-minimodel \
|
||||
--enable-search \
|
||||
--with-gmp-include=${LOCALBASE}/include \
|
||||
--with-gmp-lib=${LOCALBASE}/lib \
|
||||
--with-mpfr-include=${LOCALBASE}/include \
|
||||
--with-mpfr-lib=${LOCALBASE}/lib \
|
||||
--disable-gist --disable-qt
|
||||
USES= bison cmake compiler:c++11-lang
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Gecode
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
PLIST_SUB= SHLIB_VERSION=44
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
CMAKE_ON= BUILD_SHARED_LIBS
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
CFLAGS+= -D__USE_ISOC99
|
||||
.endif
|
||||
OPTIONS_DEFINE= GIST
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/^PACKAGE_VERSION_NUMBER/s|^|#| ; \
|
||||
/_vendor/s| == | = | ; \
|
||||
/host_os/s| == | = | ; \
|
||||
/gcc_optimize_flag/s|-O3|| ; \
|
||||
/="-ggdb/s|^|#|' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fzn-gecode
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgecode*.so.[0-9]*.[0-9]*
|
||||
GIST_DESC= Enable gist, graphical and interactive search tool
|
||||
GIST_CMAKE_BOOL= ENABLE_GIST
|
||||
GIST_USES= qt:5
|
||||
GIST_USE= qt=core,gui,printsupport,widgets,qmake_build,buildtools_build
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
TIMESTAMP = 1501308015
|
||||
SHA256 (gecode-5.1.0.tar.gz) = f9885f97e0f80b54eaf1a8f9d0c419d831229a689619f6429c6148f5c50740d0
|
||||
SIZE (gecode-5.1.0.tar.gz) = 3213603
|
||||
TIMESTAMP = 1566709177
|
||||
SHA256 (Gecode-gecode-release-6.2.0_GH0.tar.gz) = 27d91721a690db1e96fa9bb97cec0d73a937e9dc8062c3327f8a4ccb08e951fd
|
||||
SIZE (Gecode-gecode-release-6.2.0_GH0.tar.gz) = 3672525
|
||||
SHA256 (f08079c5df271869bc7c0799b3eccc52ca2f4d83.patch) = 945e522a7204324ba9740a76fc3a3806f670932e6dd57629ff041afedd5eb70d
|
||||
SIZE (f08079c5df271869bc7c0799b3eccc52ca2f4d83.patch) = 2005
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- Makefile.in.orig 2016-10-23 12:09:24 UTC
|
||||
+++ Makefile.in
|
||||
@@ -851,8 +851,8 @@ endif
|
||||
#
|
||||
|
||||
|
||||
-INTEXAMPLEHDR0 = \
|
||||
- scowl
|
||||
+# INTEXAMPLEHDR0 = \
|
||||
+# scowl
|
||||
INTEXAMPLESRC0 = \
|
||||
alpha bacp bibd donald efpa eq20 golomb-ruler \
|
||||
graph-color grocery ind-set magic-sequence magic-square \
|
|
@ -5,6 +5,8 @@ include/gecode/driver/options.hpp
|
|||
include/gecode/driver/script.hpp
|
||||
include/gecode/flatzinc.hh
|
||||
include/gecode/flatzinc/ast.hh
|
||||
include/gecode/flatzinc/branch.hh
|
||||
include/gecode/flatzinc/branch.hpp
|
||||
include/gecode/flatzinc/conexpr.hh
|
||||
include/gecode/flatzinc/option.hh
|
||||
include/gecode/flatzinc/parser.hh
|
||||
|
@ -26,6 +28,7 @@ include/gecode/float/array.hpp
|
|||
include/gecode/float/bool.hh
|
||||
include/gecode/float/bool/ite.hpp
|
||||
include/gecode/float/branch.hh
|
||||
include/gecode/float/branch.hpp
|
||||
include/gecode/float/branch/action.hpp
|
||||
include/gecode/float/branch/afc.hpp
|
||||
include/gecode/float/branch/assign.hpp
|
||||
|
@ -123,9 +126,11 @@ include/gecode/int/bool/ite.hpp
|
|||
include/gecode/int/bool/lq.hpp
|
||||
include/gecode/int/bool/or.hpp
|
||||
include/gecode/int/branch.hh
|
||||
include/gecode/int/branch.hpp
|
||||
include/gecode/int/branch/action.hpp
|
||||
include/gecode/int/branch/afc.hpp
|
||||
include/gecode/int/branch/assign.hpp
|
||||
include/gecode/int/branch/cbs.hpp
|
||||
include/gecode/int/branch/chb.hpp
|
||||
include/gecode/int/branch/merit.hpp
|
||||
include/gecode/int/branch/ngl.hpp
|
||||
|
@ -172,6 +177,7 @@ include/gecode/int/cumulatives.hh
|
|||
include/gecode/int/cumulatives/val.hpp
|
||||
include/gecode/int/distinct.hh
|
||||
include/gecode/int/distinct/bnd.hpp
|
||||
include/gecode/int/distinct/cbs.hpp
|
||||
include/gecode/int/distinct/dom-ctrl.hpp
|
||||
include/gecode/int/distinct/dom.hpp
|
||||
include/gecode/int/distinct/eqite.hpp
|
||||
|
@ -191,11 +197,12 @@ include/gecode/int/exception.hpp
|
|||
include/gecode/int/exec.hh
|
||||
include/gecode/int/exec/when.hpp
|
||||
include/gecode/int/extensional.hh
|
||||
include/gecode/int/extensional/base.hpp
|
||||
include/gecode/int/extensional/basic.hpp
|
||||
include/gecode/int/extensional.hpp
|
||||
include/gecode/int/extensional/bit-set.hpp
|
||||
include/gecode/int/extensional/compact.hpp
|
||||
include/gecode/int/extensional/dfa.hpp
|
||||
include/gecode/int/extensional/incremental.hpp
|
||||
include/gecode/int/extensional/layered-graph.hpp
|
||||
include/gecode/int/extensional/tiny-bit-set.hpp
|
||||
include/gecode/int/extensional/tuple-set.hpp
|
||||
include/gecode/int/gcc.hh
|
||||
include/gecode/int/gcc/bnd-sup.hpp
|
||||
|
@ -246,6 +253,8 @@ include/gecode/int/nvalues/int-gq.hpp
|
|||
include/gecode/int/nvalues/int-lq.hpp
|
||||
include/gecode/int/nvalues/range-event.hpp
|
||||
include/gecode/int/nvalues/sym-bit-matrix.hpp
|
||||
include/gecode/int/order.hh
|
||||
include/gecode/int/order/propagate.hpp
|
||||
include/gecode/int/precede.hh
|
||||
include/gecode/int/precede/single.hpp
|
||||
include/gecode/int/propagator.hpp
|
||||
|
@ -366,56 +375,63 @@ include/gecode/iter/values-singleton.hpp
|
|||
include/gecode/iter/values-union.hpp
|
||||
include/gecode/iter/values-unique.hpp
|
||||
include/gecode/kernel.hh
|
||||
include/gecode/kernel/action.hpp
|
||||
include/gecode/kernel/advisor.hpp
|
||||
include/gecode/kernel/afc.hpp
|
||||
include/gecode/kernel/allocators.hpp
|
||||
include/gecode/kernel/archive.hpp
|
||||
include/gecode/kernel/array.hpp
|
||||
include/gecode/kernel/branch-tiebreak.hpp
|
||||
include/gecode/kernel/branch-traits.hpp
|
||||
include/gecode/kernel/branch-val.hpp
|
||||
include/gecode/kernel/branch-var.hpp
|
||||
include/gecode/kernel/brancher-filter.hpp
|
||||
include/gecode/kernel/brancher-merit.hpp
|
||||
include/gecode/kernel/brancher-print.hpp
|
||||
include/gecode/kernel/brancher-val-commit.hpp
|
||||
include/gecode/kernel/brancher-val-sel-commit.hpp
|
||||
include/gecode/kernel/brancher-val-sel.hpp
|
||||
include/gecode/kernel/brancher-view-sel.hpp
|
||||
include/gecode/kernel/brancher-view-val.hpp
|
||||
include/gecode/kernel/brancher-view.hpp
|
||||
include/gecode/kernel/chb.hpp
|
||||
include/gecode/kernel/branch/action.hpp
|
||||
include/gecode/kernel/branch/afc.hpp
|
||||
include/gecode/kernel/branch/chb.hpp
|
||||
include/gecode/kernel/branch/filter.hpp
|
||||
include/gecode/kernel/branch/merit.hpp
|
||||
include/gecode/kernel/branch/print.hpp
|
||||
include/gecode/kernel/branch/tiebreak.hpp
|
||||
include/gecode/kernel/branch/traits.hpp
|
||||
include/gecode/kernel/branch/val-commit.hpp
|
||||
include/gecode/kernel/branch/val-sel-commit.hpp
|
||||
include/gecode/kernel/branch/val-sel.hpp
|
||||
include/gecode/kernel/branch/val.hpp
|
||||
include/gecode/kernel/branch/var.hpp
|
||||
include/gecode/kernel/branch/view-sel.hpp
|
||||
include/gecode/kernel/branch/view-val.hpp
|
||||
include/gecode/kernel/branch/view.hpp
|
||||
include/gecode/kernel/core.hpp
|
||||
include/gecode/kernel/data/array.hpp
|
||||
include/gecode/kernel/data/rnd.hpp
|
||||
include/gecode/kernel/data/shared-array.hpp
|
||||
include/gecode/kernel/data/shared-data.hpp
|
||||
include/gecode/kernel/exception.hpp
|
||||
include/gecode/kernel/gpi.hpp
|
||||
include/gecode/kernel/macros.hpp
|
||||
include/gecode/kernel/memory-config.hpp
|
||||
include/gecode/kernel/memory-manager.hpp
|
||||
include/gecode/kernel/memory/allocators.hpp
|
||||
include/gecode/kernel/memory/config.hpp
|
||||
include/gecode/kernel/memory/manager.hpp
|
||||
include/gecode/kernel/memory/region.hpp
|
||||
include/gecode/kernel/modevent.hpp
|
||||
include/gecode/kernel/propagator.hpp
|
||||
include/gecode/kernel/propagator/advisor.hpp
|
||||
include/gecode/kernel/propagator/pattern.hpp
|
||||
include/gecode/kernel/propagator/subscribed.hpp
|
||||
include/gecode/kernel/propagator/wait.hpp
|
||||
include/gecode/kernel/range-list.hpp
|
||||
include/gecode/kernel/region.hpp
|
||||
include/gecode/kernel/rnd.hpp
|
||||
include/gecode/kernel/shared-array.hpp
|
||||
include/gecode/kernel/shared-data.hpp
|
||||
include/gecode/kernel/subscribed-propagators.hpp
|
||||
include/gecode/kernel/trace-filter.hpp
|
||||
include/gecode/kernel/trace-print.hpp
|
||||
include/gecode/kernel/trace-recorder.hpp
|
||||
include/gecode/kernel/trace-traits.hpp
|
||||
include/gecode/kernel/trace.hpp
|
||||
include/gecode/kernel/tracer.hpp
|
||||
include/gecode/kernel/shared-object.hpp
|
||||
include/gecode/kernel/shared-space-data.hpp
|
||||
include/gecode/kernel/trace/filter.hpp
|
||||
include/gecode/kernel/trace/general.hpp
|
||||
include/gecode/kernel/trace/print.hpp
|
||||
include/gecode/kernel/trace/recorder.hpp
|
||||
include/gecode/kernel/trace/tracer.hpp
|
||||
include/gecode/kernel/trace/traits.hpp
|
||||
include/gecode/kernel/var-imp.hpp
|
||||
include/gecode/kernel/var-type.hpp
|
||||
include/gecode/kernel/var.hpp
|
||||
include/gecode/kernel/view.hpp
|
||||
include/gecode/kernel/wait.hh
|
||||
include/gecode/minimodel.hh
|
||||
include/gecode/minimodel/aliases.hpp
|
||||
include/gecode/minimodel/bool-expr.hpp
|
||||
include/gecode/minimodel/channel.hpp
|
||||
include/gecode/minimodel/exception.hpp
|
||||
include/gecode/minimodel/float-expr.hpp
|
||||
include/gecode/minimodel/float-rel.hpp
|
||||
include/gecode/minimodel/int-expr.hpp
|
||||
include/gecode/minimodel/int-rel.hpp
|
||||
include/gecode/minimodel/ipl.hpp
|
||||
include/gecode/minimodel/ldsb.hpp
|
||||
include/gecode/minimodel/matrix.hpp
|
||||
include/gecode/minimodel/optimize.hpp
|
||||
|
@ -426,41 +442,55 @@ include/gecode/search.hh
|
|||
include/gecode/search/bab.hpp
|
||||
include/gecode/search/base.hpp
|
||||
include/gecode/search/build.hpp
|
||||
include/gecode/search/cpprofiler/connector.hpp
|
||||
include/gecode/search/cpprofiler/message.hpp
|
||||
include/gecode/search/cutoff.hpp
|
||||
include/gecode/search/dfs.hpp
|
||||
include/gecode/search/engine.hpp
|
||||
include/gecode/search/exception.hpp
|
||||
include/gecode/search/lds.hpp
|
||||
include/gecode/search/meta/dead.hh
|
||||
include/gecode/search/meta/nogoods.hh
|
||||
include/gecode/search/meta/parallel/pbs.hh
|
||||
include/gecode/search/meta/parallel/pbs.hpp
|
||||
include/gecode/search/meta/rbs.hh
|
||||
include/gecode/search/meta/rbs.hpp
|
||||
include/gecode/search/meta/sequential/pbs.hh
|
||||
include/gecode/search/meta/sequential/pbs.hpp
|
||||
include/gecode/search/nogoods.hh
|
||||
include/gecode/search/nogoods.hpp
|
||||
include/gecode/search/options.hpp
|
||||
include/gecode/search/parallel/bab.hh
|
||||
include/gecode/search/parallel/dfs.hh
|
||||
include/gecode/search/parallel/engine.hh
|
||||
include/gecode/search/parallel/path.hh
|
||||
include/gecode/search/par/bab.hh
|
||||
include/gecode/search/par/bab.hpp
|
||||
include/gecode/search/par/dfs.hh
|
||||
include/gecode/search/par/dfs.hpp
|
||||
include/gecode/search/par/engine.hh
|
||||
include/gecode/search/par/engine.hpp
|
||||
include/gecode/search/par/path.hh
|
||||
include/gecode/search/par/path.hpp
|
||||
include/gecode/search/par/pbs.hh
|
||||
include/gecode/search/par/pbs.hpp
|
||||
include/gecode/search/pbs.hpp
|
||||
include/gecode/search/rbs.hpp
|
||||
include/gecode/search/relax.hh
|
||||
include/gecode/search/sebs.hpp
|
||||
include/gecode/search/sequential/bab.hh
|
||||
include/gecode/search/sequential/dfs.hh
|
||||
include/gecode/search/sequential/lds.hh
|
||||
include/gecode/search/sequential/path.hh
|
||||
include/gecode/search/seq/bab.hh
|
||||
include/gecode/search/seq/bab.hpp
|
||||
include/gecode/search/seq/dead.hh
|
||||
include/gecode/search/seq/dfs.hh
|
||||
include/gecode/search/seq/dfs.hpp
|
||||
include/gecode/search/seq/lds.hh
|
||||
include/gecode/search/seq/lds.hpp
|
||||
include/gecode/search/seq/path.hh
|
||||
include/gecode/search/seq/path.hpp
|
||||
include/gecode/search/seq/pbs.hh
|
||||
include/gecode/search/seq/pbs.hpp
|
||||
include/gecode/search/seq/rbs.hh
|
||||
include/gecode/search/seq/rbs.hpp
|
||||
include/gecode/search/statistics.hpp
|
||||
include/gecode/search/stop.hpp
|
||||
include/gecode/search/support.hh
|
||||
include/gecode/search/trace-recorder.hpp
|
||||
include/gecode/search/tracer.hpp
|
||||
include/gecode/search/traits.hpp
|
||||
include/gecode/search/worker.hh
|
||||
include/gecode/set.hh
|
||||
include/gecode/set/array-traits.hpp
|
||||
include/gecode/set/array.hpp
|
||||
include/gecode/set/branch.hh
|
||||
include/gecode/set/branch.hpp
|
||||
include/gecode/set/branch/action.hpp
|
||||
include/gecode/set/branch/afc.hpp
|
||||
include/gecode/set/branch/assign.hpp
|
||||
|
@ -551,12 +581,14 @@ include/gecode/support/dynamic-array.hpp
|
|||
include/gecode/support/dynamic-queue.hpp
|
||||
include/gecode/support/dynamic-stack.hpp
|
||||
include/gecode/support/exception.hpp
|
||||
include/gecode/support/hash.hpp
|
||||
include/gecode/support/heap.hpp
|
||||
include/gecode/support/hw-rnd.hpp
|
||||
include/gecode/support/int-type.hpp
|
||||
include/gecode/support/macros.hpp
|
||||
include/gecode/support/marked-pointer.hpp
|
||||
include/gecode/support/random.hpp
|
||||
include/gecode/support/ref-count.hpp
|
||||
include/gecode/support/run-jobs.hpp
|
||||
include/gecode/support/sort.hpp
|
||||
include/gecode/support/static-stack.hpp
|
||||
|
@ -663,37 +695,22 @@ include/gecode/third-party/boost/numeric/interval/transc.hpp
|
|||
include/gecode/third-party/boost/numeric/interval/utility.hpp
|
||||
include/gecode/third-party/boost/type.hpp
|
||||
lib/libgecodedriver.so
|
||||
lib/libgecodedriver.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodedriver.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodeflatzinc.so
|
||||
lib/libgecodeflatzinc.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodeflatzinc.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodefloat.so
|
||||
lib/libgecodefloat.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodefloat.so.%%SHLIB_VERSION%%.0
|
||||
%%GIST%%lib/libgecodegist.so
|
||||
lib/libgecodeint.so
|
||||
lib/libgecodeint.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodeint.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodekernel.so
|
||||
lib/libgecodekernel.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodekernel.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodeminimodel.so
|
||||
lib/libgecodeminimodel.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodeminimodel.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodesearch.so
|
||||
lib/libgecodesearch.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodesearch.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodeset.so
|
||||
lib/libgecodeset.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodeset.so.%%SHLIB_VERSION%%.0
|
||||
lib/libgecodesupport.so
|
||||
lib/libgecodesupport.so.%%SHLIB_VERSION%%
|
||||
lib/libgecodesupport.so.%%SHLIB_VERSION%%.0
|
||||
%%DATADIR%%/mznlib/all_different_int.mzn
|
||||
%%DATADIR%%/mznlib/all_equal_int.mzn
|
||||
%%DATADIR%%/mznlib/alldifferent_except_0.mzn
|
||||
%%DATADIR%%/mznlib/among.mzn
|
||||
%%DATADIR%%/mznlib/arg_max_bool.mzn
|
||||
%%DATADIR%%/mznlib/arg_max_int.mzn
|
||||
%%DATADIR%%/mznlib/arg_min_bool.mzn
|
||||
%%DATADIR%%/mznlib/arg_min_int.mzn
|
||||
%%DATADIR%%/mznlib/at_least_int.mzn
|
||||
%%DATADIR%%/mznlib/at_least_set.mzn
|
||||
|
@ -709,6 +726,7 @@ lib/libgecodesupport.so.%%SHLIB_VERSION%%.0
|
|||
%%DATADIR%%/mznlib/decreasing_int.mzn
|
||||
%%DATADIR%%/mznlib/diffn.mzn
|
||||
%%DATADIR%%/mznlib/disjoint.mzn
|
||||
%%DATADIR%%/mznlib/disjunctive_strict.mzn
|
||||
%%DATADIR%%/mznlib/distribute.mzn
|
||||
%%DATADIR%%/mznlib/exactly_int.mzn
|
||||
%%DATADIR%%/mznlib/exactly_set.mzn
|
||||
|
|
Loading…
Reference in a new issue