Update to 2007-03-22 snapshot:
- ARM reabbot support (orginal patch by Aurelien Jarno). - SMP half-idle fix. - Watchpoint support (previous commit got eaten by Savannah server crash). - ARM register index+writeback fix (Lauro Ramos Venancio). - PPC: Make it safe to use 64 bits GPR and/or 64 bits host registers. For "symetry", add 64 bits versions of all modified functions. As a side effect, add a lot of code provision for PowerPC 64 support. Move overflow and carry checks in common routines for simple cases. Add isel and popcntb instructions from PowerPC 2.03 specification. Remove remaining micro-operations helpers prototypes from op.c. Fix XER_BC field to be 7 bits long. Add power management support for PowerPC 603 & 604. Fix compilation warnings. Add PowerPC 64 target for tests. As no PowerPC 64 CPU is implemented, this target can just be used to check that there is no difference between PowerPC 32 & PowerPC 64 used in 32 bits mode. - Allow disabling IDE block mode, by Carlo Marcelo Arenas Belon. - Don't fail for "revert to poweron defaults" IDE command, by Carlo Marcelo Arenas Belon. - Better ioport debugging output. - OHCI USB PXA support (Andrzej Zaborowski). - MIPS -cpu selection support, by Herve Poussineau. - PPC: As icbi is not a priviledge instruction and is treated as a load by the MMU it needs to be implemented for every MMU translation mode. - MIPS: Fix BD flag handling, cause register contents, implement some more bits for R2 interrupt handling. - A VGA card for the Malta board. - SCSI fixes, by Wang Cheng Yeh. - Add -name option, by Anthony Liguori. - Improve -pidfile option, by Anthony Liguori. - Close file descriptors when execing network tap setup script, by Daniel P. Berrange. - Fix qemu crash due to sparc division-by-zero, by Aurelien Jarno. - Fix call to generated code on SPARC, by Juergen Keil. - mips: Barf on branches/jumps in branch delay slots. Spotted by Stefan Weil. - VMMouse Emulation, by Anthony Liguori. - SlavIO interrupt controller fix, by Aurelien Jarno. - SlavIO Counter-Timers fix, by Aurelien Jarno. - PowerPC 2.03 SPE extension - first pass. - Fix Sparc branches, original patch by Aurelien Jarno Approved by: miwi (mentor, implicit)
This commit is contained in:
parent
f4f1b57715
commit
626195abb2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188295
5 changed files with 8 additions and 28 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= qemu
|
||||
PORTVERSION= 0.9.0s.20070309
|
||||
PORTVERSION= 0.9.0s.20070322
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://qemu.org/:release \
|
||||
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
|
||||
|
@ -14,7 +14,7 @@ MASTER_SITES= http://qemu.org/:release \
|
|||
http://www.volny.cz/xnavara/qemu/:snapshot \
|
||||
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
|
||||
http://people.freebsd.org/~maho/qemu/:misc
|
||||
DISTNAME= ${PORTNAME}-snapshot-2007-03-09_05
|
||||
DISTNAME= ${PORTNAME}-snapshot-2007-03-22_05
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
|
||||
DIST_SUBDIR= qemu
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
MD5 (qemu/qemu-snapshot-2007-03-09_05.tar.bz2) = e3899581b8628a6eeb1ba33e18aab632
|
||||
SHA256 (qemu/qemu-snapshot-2007-03-09_05.tar.bz2) = bb8cf3e70492fce405074436a3001f06e6193d58c313862b4c5d165c2beace74
|
||||
SIZE (qemu/qemu-snapshot-2007-03-09_05.tar.bz2) = 1667747
|
||||
MD5 (qemu/qemu-snapshot-2007-03-22_05.tar.bz2) = b1d9d1b68094a9679b77d8b08796a7e4
|
||||
SHA256 (qemu/qemu-snapshot-2007-03-22_05.tar.bz2) = be19f224e83fd90064f26b8d09fe018c4de7d27663f11544d494ac52d03808fa
|
||||
SIZE (qemu/qemu-snapshot-2007-03-22_05.tar.bz2) = 1685829
|
||||
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
|
||||
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
|
||||
SIZE (qemu/patch3_cirrus) = 8817
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
Index: qemu/Makefile
|
||||
@@ -19,14 +19,19 @@
|
||||
@@ -19,7 +19,11 @@
|
||||
BASE_LDFLAGS += -static
|
||||
endif
|
||||
ifdef BUILD_DOCS
|
||||
|
@ -11,16 +11,7 @@ Index: qemu/Makefile
|
|||
else
|
||||
DOCS=
|
||||
endif
|
||||
|
||||
ifndef CONFIG_DARWIN
|
||||
ifndef CONFIG_WIN32
|
||||
-LIBS+=-lrt
|
||||
+# XXX need ifndef CONFIG_BSD
|
||||
+# LIBS+=-lrt
|
||||
endif
|
||||
endif
|
||||
|
||||
@@ -64,8 +69,10 @@
|
||||
@@ -60,8 +64,10 @@
|
||||
common de-ch es fo fr-ca hu ja mk nl-be pt sl tr
|
||||
|
||||
install-doc: $(DOCS)
|
||||
|
|
|
@ -1,15 +1,3 @@
|
|||
Index: qemu/Makefile.target
|
||||
@@ -404,7 +404,9 @@
|
||||
ifndef CONFIG_DARWIN
|
||||
ifndef CONFIG_WIN32
|
||||
ifndef CONFIG_SOLARIS
|
||||
-VL_LIBS=-lutil -lrt
|
||||
+#VL_LIBS=-lutil -lrt
|
||||
+# XXX this cant be just merged back...
|
||||
+VL_LIBS=-lutil
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
Index: qemu/vl.c
|
||||
@@ -541,7 +541,7 @@
|
||||
static void init_get_clock(void)
|
||||
|
|
|
@ -4,6 +4,7 @@ bin/qemu-system-arm
|
|||
bin/qemu-system-mips
|
||||
bin/qemu-system-mipsel
|
||||
bin/qemu-system-ppc
|
||||
bin/qemu-system-ppc64
|
||||
bin/qemu-system-sparc
|
||||
bin/qemu-system-x86_64
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qemu-doc.html
|
||||
|
|
Loading…
Reference in a new issue