deskutils/remind: fix build on FreeBSD 12.
ChangeLog: https://lists.freebsd.org/archives/freebsd-pkg-fallout/2022-October/282238.html PR: 267196 Reported by: fuz@fuz.su (maintainer)
This commit is contained in:
parent
bb0e622ee4
commit
6266198345
3 changed files with 18 additions and 5 deletions
|
@ -67,16 +67,16 @@ LOCATION?= Ottawa
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's#DEFAULT_LATITUDE 39#DEFAULT_LATITUDE ${DEFAULT_LATITUDE}#' \
|
||||
-e 's#DEFAULT_LONGITUDE 39#DEFAULT_LONGITUDE ${DEFAULT_LONGITUDE}#' \
|
||||
-e 's#Ottawa#${LOCATION}#' ${WRKSRC}/src/custom.h
|
||||
|
||||
post-patch-A4-on:
|
||||
pre-configure-A4-on:
|
||||
@${REINPLACE_CMD} -e 's#"Letter", 612, 792#"A4", 595, 842#' ${WRKSRC}/src/custom.h
|
||||
|
||||
post-patch-TCLTK-on:
|
||||
pre-configure-TCLTK-on:
|
||||
@${REINPLACE_CMD} -e 's,wish,${WISH},' ${WRKSRC}/scripts/tkremind
|
||||
|
||||
do-build:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- src/Makefile.in.orig 2022-02-10 22:15:01 UTC
|
||||
--- src/Makefile.in.orig 2022-10-14 15:06:27 UTC
|
||||
+++ src/Makefile.in
|
||||
@@ -52,8 +52,11 @@ remind: $(REMINDOBJS)
|
||||
|
||||
install-nostripped: all
|
||||
install: all
|
||||
-mkdir -p $(DESTDIR)$(bindir) || true
|
||||
- for prog in $(PROGS) $(SCRIPTS) ; do \
|
||||
+ for prog in $(PROGS) ; do \
|
||||
|
|
13
deskutils/remind/files/patch-src_funcs.c
Normal file
13
deskutils/remind/files/patch-src_funcs.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/funcs.c.orig 2022-10-19 10:26:29 UTC
|
||||
+++ src/funcs.c
|
||||
@@ -29,9 +29,7 @@
|
||||
|
||||
#include <unistd.h>
|
||||
|
||||
-#ifdef HAVE_SYS_FILE_H
|
||||
-#include <sys/file.h>
|
||||
-#endif
|
||||
+#include <fcntl.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
|
Loading…
Reference in a new issue