Add gens, a Sega Genesis/CD/32X emulator
PR: ports/82576 Submitted by: Travis Poppe <tlp@LiquidX.org>
This commit is contained in:
parent
7e4b4a17fb
commit
629892cbb9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138544
7 changed files with 136 additions and 0 deletions
|
@ -29,6 +29,7 @@
|
|||
SUBDIR += gcube
|
||||
SUBDIR += generator
|
||||
SUBDIR += generator-cbiere
|
||||
SUBDIR += gens
|
||||
SUBDIR += gngb
|
||||
SUBDIR += gnuboy
|
||||
SUBDIR += grustibus
|
||||
|
|
47
emulators/gens/Makefile
Normal file
47
emulators/gens/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
# New ports collection makefile for: gens
|
||||
# Date created: 22 Jun 2005
|
||||
# Whom: Travis Poppe <tlp@liquidx.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gens
|
||||
PORTVERSION= 2.12a
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= Gens212a1SrcL
|
||||
|
||||
MAINTAINER= tlp@liquidx.org
|
||||
COMMENT= Sega Genesis/CD/32X emulator
|
||||
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}_linux/${PORTNAME}
|
||||
USE_ZIP= yes
|
||||
USE_SDL= sdl
|
||||
USE_GNOME= gtk20
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
|
||||
${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
|
||||
${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/Makefile
|
||||
${REINPLACE_CMD} -e 's|%%LDFLAGS%%|${LDFLAGS}|' ${WRKSRC}/Makefile
|
||||
@${CAT} ${FILESDIR}/gens.in | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' > ${WRKDIR}/gens
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/gens
|
||||
${MKDIR} ${PREFIX}/share/gens/resource
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/gens ${PREFIX}/bin/gens
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/gens ${PREFIX}/share/gens/gens
|
||||
${INSTALL_DATA} ${WRKSRC}/resource/* ${PREFIX}/share/gens/resource
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_linux/README ${DOCSDIR}/README
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
emulators/gens/distinfo
Normal file
2
emulators/gens/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (Gens212a1SrcL.zip) = 84b7511333f796633cfd0465c17679f2
|
||||
SIZE (Gens212a1SrcL.zip) = 572647
|
26
emulators/gens/files/gens.in
Normal file
26
emulators/gens/files/gens.in
Normal file
|
@ -0,0 +1,26 @@
|
|||
#!/bin/sh
|
||||
# gens - gens 2.12a wrapper script
|
||||
#
|
||||
# 2005 Travis Poppe
|
||||
|
||||
USERDIR=$HOME/.gens
|
||||
|
||||
if [ -d $USERDIR ]; then
|
||||
echo "gens working directory appears to be $USERDIR/"
|
||||
echo ""
|
||||
|
||||
cd $USERDIR
|
||||
./gens $*
|
||||
exit
|
||||
fi
|
||||
|
||||
mkdir $USERDIR
|
||||
mkdir $USERDIR/resource
|
||||
ln -s %%PREFIX%%/share/gens/gens $USERDIR/gens
|
||||
ln -s %%PREFIX%%/share/gens/resource/* $USERDIR/resource
|
||||
|
||||
echo "Installed gens to $USERDIR/"
|
||||
echo ""
|
||||
|
||||
cd $USERDIR
|
||||
./gens $*
|
26
emulators/gens/files/patch-Makefile
Normal file
26
emulators/gens/files/patch-Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- Makefile.orig Wed Jun 22 16:18:29 2005
|
||||
+++ Makefile Wed Jun 22 16:19:44 2005
|
||||
@@ -59,7 +59,7 @@
|
||||
glade/interface.o\
|
||||
glade/support.o
|
||||
|
||||
-GTKCFLAGS=-DWITH_GTK -DGTK_DISABLE_DEPRECATED `pkg-config gtk+-2.0 --cflags`
|
||||
+GTKCFLAGS=-DWITH_GTK `pkg-config gtk+-2.0 --cflags`
|
||||
|
||||
|
||||
#uncomment this if you want to enable GTK support (default)
|
||||
@@ -73,12 +73,12 @@
|
||||
GTKLDFLAGS=`pkg-config gtk+-2.0 --libs`
|
||||
|
||||
#uncomment this if you want to enable GTK support (default)
|
||||
-LDFLAGS=-lm `sdl-config --libs` -lz -lstdc++ -s $(GTKLDFLAGS)
|
||||
+LDFLAGS=-lm `sdl-config --libs` -lz -lstdc++ -s $(GTKLDFLAGS) %%LDFLAGS%%
|
||||
#uncomment this if you want to disable GTK support
|
||||
#LDFLAGS=-lm `sdl-config --libs` -lz -lstdc++ -s
|
||||
|
||||
|
||||
-NASMFLAGS=-D__GCC2 -f elf -O3
|
||||
+NASMFLAGS=-D__GCC2 -f elf
|
||||
CC=gcc
|
||||
CXX=g++
|
||||
TARGET=gens
|
14
emulators/gens/pkg-descr
Normal file
14
emulators/gens/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
A Sega Genesis/CD/32X emulator that uses the SDL library and has a GTK
|
||||
user interface.
|
||||
|
||||
Note: This is not the latest version of gens available for *nix. The
|
||||
latest version makes use of the Linux-specific header file 'linux/cdrom.h'
|
||||
which causes the build to fail.
|
||||
|
||||
Patches to get the latest version working on FreeBSD are more than
|
||||
welcome!
|
||||
|
||||
WWW: http://gens.consolemul.com/
|
||||
|
||||
- Travis Poppe
|
||||
tlp@liquidx.org
|
20
emulators/gens/pkg-plist
Normal file
20
emulators/gens/pkg-plist
Normal file
|
@ -0,0 +1,20 @@
|
|||
bin/gens
|
||||
%%DATADIR%%/gens
|
||||
%%DATADIR%%/resource/Gens2.ico
|
||||
%%DATADIR%%/resource/bitmap1.bmp
|
||||
%%DATADIR%%/resource/bmp00000.bmp
|
||||
%%DATADIR%%/resource/bmp00001.bmp
|
||||
%%DATADIR%%/resource/bmp00002.bmp
|
||||
%%DATADIR%%/resource/bmp00003.bmp
|
||||
%%DATADIR%%/resource/bmp00004.bmp
|
||||
%%DATADIR%%/resource/bmp00005.bmp
|
||||
%%DATADIR%%/resource/bmp00006.bmp
|
||||
%%DATADIR%%/resource/gens.ico
|
||||
%%DATADIR%%/resource/gens_big.bmp
|
||||
%%DATADIR%%/resource/gens_small.bmp
|
||||
%%DATADIR%%/resource/sonic.ico
|
||||
%%DATADIR%%/resource/sonic2.ico
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%/resource
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue