- Drop GNU m4 dependency, unless running on really old FreeBSD version
PR: ports/110743 Submitted by: Matthew D. Fuller <fullermd@over-yonder.net> (maintainer)
This commit is contained in:
parent
22077fe04a
commit
629fa6a914
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188186
3 changed files with 28 additions and 21 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= ctwm
|
||||
PORTVERSION= 3.8a
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://ctwm.free.lp.se/dist/ \
|
||||
http://www.centralmiss.com/~matt/distfiles/
|
||||
|
@ -14,16 +15,24 @@ MASTER_SITES= http://ctwm.free.lp.se/dist/ \
|
|||
MAINTAINER= fullermd@over-yonder.net
|
||||
COMMENT= An extension to twm, with support for multiple virtual screens, etc
|
||||
|
||||
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
|
||||
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
|
||||
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
USE_IMAKE= yes
|
||||
USE_XPM= yes
|
||||
MAN1= ctwm.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Very old versions need GNU m4
|
||||
.if ( ${OSVERSION} < 450005 || \
|
||||
( ${OSVERSION} >= 500000 && ${OSVERSION} < 500034 ) )
|
||||
EXTRA_PATCHES+= ${FILESDIR}/gm4-patch
|
||||
BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4
|
||||
RUN_DEPENDS+= gm4:${PORTSDIR}/devel/m4
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
${CP} ${WRKSRC}/Imakefile.local-template ${WRKSRC}/Imakefile.local
|
||||
${CAT} ${FILESDIR}/Imakefile.local-additional >> ${WRKSRC}/Imakefile.local
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,5 +1,21 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- Imakefile.orig Thu May 5 08:22:40 2005
|
||||
+++ Imakefile Mon May 9 19:30:45 2005
|
||||
@@ -67,10 +67,12 @@
|
||||
#endif
|
||||
|
||||
#if defined USE_M4 || defined USEM4
|
||||
+ M4PROGNAME = gm4
|
||||
+ M4PROG = $(LOCALBASE)/bin/$(M4PROGNAME)
|
||||
M4LIBDIR =
|
||||
M4INCDIR =
|
||||
|
||||
- M4DEFINES = -DUSEM4
|
||||
+ M4DEFINES = -DUSEM4 -DM4PROG=\"$(M4PROG)\" -DM4PROGNAME=\"$(M4PROGNAME)\"
|
||||
M4LIB = $(M4LIBDIR)
|
||||
#else
|
||||
M4LIBDIR =
|
||||
--- parse.c.orig Fri Feb 16 03:24:27 2007
|
||||
+++ parse.c Sun Mar 4 18:36:18 2007
|
||||
@@ -2128,7 +2128,7 @@
|
|
@ -1,18 +0,0 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- Imakefile.orig Thu May 5 08:22:40 2005
|
||||
+++ Imakefile Mon May 9 19:30:45 2005
|
||||
@@ -67,10 +67,12 @@
|
||||
#endif
|
||||
|
||||
#if defined USE_M4 || defined USEM4
|
||||
+ M4PROGNAME = gm4
|
||||
+ M4PROG = $(LOCALBASE)/bin/$(M4PROGNAME)
|
||||
M4LIBDIR =
|
||||
M4INCDIR =
|
||||
|
||||
- M4DEFINES = -DUSEM4
|
||||
+ M4DEFINES = -DUSEM4 -DM4PROG=\"$(M4PROG)\" -DM4PROGNAME=\"$(M4PROGNAME)\"
|
||||
M4LIB = $(M4LIBDIR)
|
||||
#else
|
||||
M4LIBDIR =
|
Loading…
Reference in a new issue