Remove the bogus dependency on -ltiff (--without-tiff was always in there).

Make the testcms link the new -lcms statically to avoid possible conflicts
with the already installed library (probably of a different version).

PR:	ports/68610
This commit is contained in:
Mikhail Teterin 2004-10-25 20:14:27 +00:00
parent a359bd0658
commit 62a3a103b8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120177
2 changed files with 9 additions and 4 deletions

View file

@ -16,13 +16,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light Color Management System -- a color management library
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
USE_GNOME= gnomehack gnometarget lthack
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-jpeg --without-tiff
INSTALLS_SHLIB= yes

View file

@ -0,0 +1,9 @@
--- testbed/Makefile.in Mon Apr 19 12:02:23 2004
+++ testbed/Makefile.in Mon Oct 25 16:07:37 2004
@@ -198,5 +198,5 @@
testcms_LDADD = $(top_builddir)/src/liblcms.la
-testcms_LDFLAGS = @LDFLAGS@
+testcms_LDFLAGS = @LDFLAGS@ -static
testcms_SOURCES = testcms.c