- Fix parallel builds (-jX) and remove MAKE_JOBS_UNSAFE
- Utilize PLIST_FILES and PORTDOCS instead of pkg-plist - Reword port description a bit; fix Makefile header
This commit is contained in:
parent
1e279835ef
commit
62abe08f9d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=355289
4 changed files with 20 additions and 17 deletions
|
@ -1,4 +1,4 @@
|
|||
# Created by: Andrey Zakhvatov
|
||||
# Created by: Andrey Zakhvatov <andy@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nbench
|
||||
|
@ -11,15 +11,17 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= BYTE Magazine's native benchmarks
|
||||
|
||||
ALL_TARGET= # empty
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
PLIST_FILES= bin/nbench share/nbench/NNET.DAT
|
||||
PORTDOCS= README README.submit RESULTS bdoc.txt
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/nbench ${STAGEDIR}${PREFIX}/bin
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${STAGEDIR}${DATADIR}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in README README.submit RESULTS bdoc.txt
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.orig Mon Oct 18 00:07:05 2004
|
||||
+++ Makefile Mon Oct 18 00:07:51 2004
|
||||
@@ -19,10 +19,10 @@
|
||||
@@ -19,10 +19,10 @@ default: nbench
|
||||
# You should leave -static in the CFLAGS so that your sysinfo can be
|
||||
# compiled into the executable.
|
||||
|
||||
|
@ -13,3 +13,12 @@
|
|||
|
||||
# if your gcc lets you do it, then try this one
|
||||
#CFLAGS = -s -static -Wall -O3 -fomit-frame-pointer -funroll-loops
|
||||
@@ -126,7 +126,7 @@ pointer.h: pointer Makefile
|
||||
if [ "4" = `./pointer` ] ; then touch pointer.h ;\
|
||||
else echo "#define LONG64" >pointer.h ; fi
|
||||
|
||||
-misc.o: misc.h misc.c Makefile
|
||||
+misc.o: misc.h misc.c nmglobal.h pointer.h Makefile
|
||||
$(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
|
||||
-c misc.c
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
BYTE Magazine's native benchmarks (also called BYTEmark), which are
|
||||
designed to expose the capabilities of a system's CPU, FPU, and memory
|
||||
system.
|
||||
This is a Linux/Unix port of release 2 of BYTE Magazine's BYTEmark benchmark
|
||||
program (previously known as BYTE's Native Mode Benchmarks). It is designed
|
||||
to expose the capabilities of a system's CPU, FPU, and memory system.
|
||||
|
||||
WWW: http://www.tux.org/~mayer/linux/bmark.html
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
bin/nbench
|
||||
share/nbench/NNET.DAT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.submit
|
||||
%%PORTDOCS%%%%DOCSDIR%%/RESULTS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/bdoc.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm share/nbench
|
Loading…
Reference in a new issue