Update default MySQL version to 5.7.
PR: 238365 Submitted by: ale Exp-run by: antoine Approved by: portmgr (antoine)
This commit is contained in:
parent
c63bb569e8
commit
62d9035f5b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=505549
19 changed files with 93 additions and 137 deletions
|
@ -7,7 +7,8 @@
|
|||
#
|
||||
# version If no version is given (by the maintainer via the port), try to
|
||||
# find the currently installed version. Fall back to default if
|
||||
# necessary (MySQL-5.6 = 56).
|
||||
# necessary (MySQL-5.7 = 57, look at bsd.default-versions.mk for
|
||||
# possible values).
|
||||
# client Depends on the libmysqlclient library (default)
|
||||
# server/embedded
|
||||
# Depend on the server at run/build time. If none of these is
|
||||
|
|
|
@ -65,7 +65,7 @@ LLVM_DEFAULT?= 80
|
|||
# Possible values: 5.1, 5.2, 5.3
|
||||
LUA_DEFAULT?= 5.2
|
||||
# Possible values: 5.5, 5.6, 5.7, 8.0, 5.5m, 10.0m, 10.1m, 10.2m, 10.3m, 5.5p, 5.6p, 5.7p, 5.6w
|
||||
MYSQL_DEFAULT?= 5.6
|
||||
MYSQL_DEFAULT?= 5.7
|
||||
# Possible values: 5.26, 5.28, 5.30, devel
|
||||
.if !exists(${LOCALBASE}/bin/perl) || (!defined(_PORTS_ENV_CHECK) && \
|
||||
defined(PACKAGE_BUILDING))
|
||||
|
|
22
UPDATING
22
UPDATING
|
@ -6,6 +6,28 @@ You should get into the habit of checking this file for changes each time
|
|||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
|
||||
20190701:
|
||||
AFFECTS: users of databases/mysql56-(server|client)
|
||||
AUTHOR: ale@FreeBSD.org
|
||||
|
||||
The default MySQL version has been updated from 5.6 to 5.7.
|
||||
|
||||
If you compile your own ports you may keep 5.6 as the default version by
|
||||
adding the following lines to your /etc/make.conf file:
|
||||
|
||||
#
|
||||
# Keep MySQL 5.6 as default version
|
||||
#
|
||||
DEFAULT_VERSIONS+=mysql=5.6
|
||||
|
||||
If you wish to update to the new default version, you need to first stop any
|
||||
running server instance. Then, you will need to follow these steps, depending
|
||||
on installed packages.
|
||||
|
||||
# pkg set -o databases/mysql56-client:databases/mysql57-client
|
||||
# pkg set -o databases/mysql56-server:databases/mysql57-server
|
||||
# pkg upgrade
|
||||
|
||||
20190630:
|
||||
AFFECTS: users of net/samba410
|
||||
AUTHOR: timur@FreeBSD.org
|
||||
|
|
|
@ -19,7 +19,8 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
|
|||
libqjson-qt5.so:devel/qjson \
|
||||
libqca-qt5.so:devel/qca \
|
||||
libtag.so:audio/taglib \
|
||||
libtag-extras.so:audio/taglib-extras
|
||||
libtag-extras.so:audio/taglib-extras \
|
||||
liblz4.so:archivers/liblz4
|
||||
|
||||
USES= cmake compiler:c++11-lang desktop-file-utils \
|
||||
kde:5 mysql:client,embedded pkgconfig qt:5 shebangfix ssl
|
||||
|
|
25
audio/amarok/files/patch-cmake_modules_FindMySQL.cmake
Normal file
25
audio/amarok/files/patch-cmake_modules_FindMySQL.cmake
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- cmake/modules/FindMySQL.cmake.orig 2019-06-14 07:24:31 UTC
|
||||
+++ cmake/modules/FindMySQL.cmake
|
||||
@@ -31,21 +31,7 @@ if(MYSQLCONFIG_EXECUTABLE)
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE
|
||||
)
|
||||
|
||||
- execute_process(
|
||||
- COMMAND ${MYSQLCONFIG_EXECUTABLE} --libmysqld-libs
|
||||
- RESULT_VARIABLE MC_return_embedded
|
||||
- OUTPUT_VARIABLE MC_MYSQL_EMBEDDED_LIBRARIES
|
||||
- OUTPUT_STRIP_TRAILING_WHITESPACE
|
||||
- )
|
||||
-
|
||||
- if(NOT MC_MYSQL_EMBEDDED_LIBRARIES)
|
||||
- # At least on OpenSUSE --libmysql-libs doesn't exist, so we just use
|
||||
- # MYSQL_LIBRARIES for that. We'll see if that's enough when testing
|
||||
- # below.
|
||||
- set(MYSQL_EMBEDDED_LIBRARIES ${MYSQL_LIBRARIES})
|
||||
- else()
|
||||
- set(MYSQL_EMBEDDED_LIBRARIES ${MC_MYSQL_EMBEDDED_LIBRARIES})
|
||||
- endif()
|
||||
+ set(MYSQL_EMBEDDED_LIBRARIES "-L/usr/local/lib/mysql" -lmysqld -llz4)
|
||||
endif()
|
||||
|
||||
# Try searching manually via find_path/find_library, possibly with hints
|
|
@ -18,8 +18,9 @@ BUILD_DEPENDS= bash:shells/bash \
|
|||
${LOCALBASE}/lib/gnat/apq.gpr:databases/apq
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/gnat/apq.gpr:databases/apq
|
||||
|
||||
USES= ada tar:bzip2
|
||||
USE_MYSQL= yes
|
||||
USES= ada tar:bzip2 mysql
|
||||
|
||||
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
|
||||
HAS_CONFIGURE= yes
|
||||
WRKPATH= ${WRKDIR}/build
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
|
|
|
@ -17,6 +17,8 @@ LIB_DEPENDS= libconfig.so:devel/libconfig
|
|||
USE_OPENLDAP= yes
|
||||
USES= gmake mysql:client,server
|
||||
|
||||
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ateamsystems
|
||||
GH_TAGNAME= f6a1a5d
|
||||
|
|
|
@ -16,6 +16,7 @@ LIB_DEPENDS= libgroonga.so:textproc/groonga
|
|||
|
||||
USES= libtool mysql pkgconfig
|
||||
|
||||
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-mysql-source="$$(cd ${PORTSDIR}/${_MYSQL_SERVER}; ${MAKE} -V WRKSRC)" \
|
||||
--with-mysql-build="$$(cd ${PORTSDIR}/${_MYSQL_SERVER}; ${MAKE} -V BUILD_WRKSRC)" \
|
||||
|
|
|
@ -12,8 +12,11 @@ COMMENT= MySQL Simple Asynchronous Client
|
|||
|
||||
LICENSE= LGPL3
|
||||
|
||||
USES= mysql
|
||||
|
||||
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USE_MYSQL= yes
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -I${LOCALBASE}/lib
|
||||
|
|
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mysql-connector-odbc
|
||||
PORTVERSION= 5.3.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.3.13
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= MYSQL/Connector-ODBC/5.3
|
||||
PKGNAMESUFFIX= -${DRIVER_MANAGER}-mysql${MYSQL_VER}
|
||||
|
@ -13,25 +12,22 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= ODBC driver for MySQL${MYSQL_VER} / ${DRIVER_MANAGER}
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BUILD_DEPENDS= unixODBC>=2.2.14_1:databases/unixODBC
|
||||
LIB_DEPENDS= libodbc.so:databases/unixODBC
|
||||
|
||||
USES= cmake mysql
|
||||
CMAKE_ARGS= -DWITH_UNIXODBC=1
|
||||
|
||||
CMAKE_ARGS= -DWITH_UNIXODBC=1 -DDISABLE_GUI=1
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
IGNORE_WITH_MYSQL= 55 55m 55p 51 51m 51p
|
||||
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
DRIVER_MANAGER= unixodbc
|
||||
|
||||
PORTDOCS= ChangeLog INSTALL \
|
||||
README README.debug Licenses_for_Third-Party_Components.txt
|
||||
PORTDOCS= *
|
||||
|
||||
PLIST_FILES= bin/myodbc-installer \
|
||||
lib/libmyodbc5a.so \
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (mysql-connector-odbc-5.3.4-src.tar.gz) = a5f7a490f2958f2768d18b8a57f71909f9699a8619c82776b3ad1c02b8abce0d
|
||||
SIZE (mysql-connector-odbc-5.3.4-src.tar.gz) = 667340
|
||||
TIMESTAMP = 1560498109
|
||||
SHA256 (mysql-connector-odbc-5.3.13-src.tar.gz) = 6127639a503e80cff71e211d7534801a074e781624974807a279c7f6e6f0353a
|
||||
SIZE (mysql-connector-odbc-5.3.13-src.tar.gz) = 3009032
|
||||
|
|
|
@ -1,36 +1,30 @@
|
|||
--- CMakeLists.txt.orig 2014-06-18 22:50:16 UTC
|
||||
--- CMakeLists.txt.orig 2019-04-15 16:56:34 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -269,7 +269,7 @@ ENDIF(NOT DISABLE_GUI)
|
||||
@@ -431,7 +431,6 @@ ENDIF(NOT DISABLE_GUI)
|
||||
|
||||
ADD_SUBDIRECTORY(dltest)
|
||||
ADD_SUBDIRECTORY(installer)
|
||||
|
||||
-ADD_SUBDIRECTORY(test)
|
||||
+# ADD_SUBDIRECTORY(test)
|
||||
|
||||
##############################################################################
|
||||
#
|
||||
@@ -382,18 +382,17 @@ IF(WIN32)
|
||||
# For dynamic linking use the built-in sys and strings
|
||||
IF(NOT MYSQLCLIENT_STATIC_LINKING)
|
||||
@@ -501,8 +500,8 @@ cmake/sql.*\\\\.c$
|
||||
#------------ Installation ---------------------------
|
||||
|
||||
|
||||
-INSTALL(FILES LICENSE.txt DESTINATION .)
|
||||
-INSTALL(FILES README.txt DESTINATION .)
|
||||
+INSTALL(FILES LICENSE.txt DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
+INSTALL(FILES README.txt DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
|
||||
IF(WIN32)
|
||||
|
||||
@@ -542,7 +541,7 @@ IF(WIN32)
|
||||
|
||||
ELSE(WIN32)
|
||||
|
||||
- INSTALL(FILES ChangeLog DESTINATION .)
|
||||
- INSTALL(FILES README DESTINATION .)
|
||||
- INSTALL(FILES README.debug DESTINATION .)
|
||||
- INSTALL(FILES INSTALL DESTINATION .)
|
||||
+ INSTALL(FILES ChangeLog DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
+ INSTALL(FILES README DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
+ INSTALL(FILES README.debug DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
+ INSTALL(FILES INSTALL DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
IF(EXISTS "${CMAKE_SOURCE_DIR}/COPYING")
|
||||
- INSTALL(FILES COPYING DESTINATION .)
|
||||
ELSE()
|
||||
- INSTALL(FILES LICENSE.mysql DESTINATION .)
|
||||
+ INSTALL(FILES LICENSE.mysql DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
ENDIF()
|
||||
|
||||
ENDIF(WIN32)
|
||||
|
||||
-INSTALL(FILES Licenses_for_Third-Party_Components.txt DESTINATION .)
|
||||
+INSTALL(FILES Licenses_for_Third-Party_Components.txt DESTINATION ./share/doc/mysql-connector-odbc/)
|
||||
|
||||
INCLUDE(CPack)
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- driver/catalog_no_i_s.c.orig 2014-06-19 02:50:16.000000000 +0400
|
||||
+++ driver/catalog_no_i_s.c 2015-03-26 12:31:13.356945009 +0300
|
||||
@@ -1093,7 +1093,11 @@
|
||||
unsigned long *lengths;
|
||||
SQLRETURN rc= SQL_SUCCESS;
|
||||
|
||||
+#ifdef MARIADB_BASE_VERSION
|
||||
+ my_init_dynamic_array(&records, sizeof(MY_FOREIGN_KEY_FIELD), 0, 0, 0);
|
||||
+#else
|
||||
my_init_dynamic_array(&records, sizeof(MY_FOREIGN_KEY_FIELD), 0, 0);
|
||||
+#endif
|
||||
|
||||
/* Get the list of tables that match szCatalog and szTable */
|
||||
pthread_mutex_lock(&stmt->dbc->lock);
|
|
@ -1,37 +0,0 @@
|
|||
--- driver/desc.c.orig 2014-06-19 02:50:16.000000000 +0400
|
||||
+++ driver/desc.c 2015-03-26 12:34:50.610931661 +0300
|
||||
@@ -63,13 +63,21 @@
|
||||
but in desc_get_rec we manually get a pointer to it. This avoids
|
||||
having to call set_dynamic after modifying the DESCREC.
|
||||
*/
|
||||
+#ifdef MARIADB_BASE_VERSION
|
||||
+ if (my_init_dynamic_array(&desc->records, sizeof(DESCREC), 0, 0, 0))
|
||||
+#else
|
||||
if (my_init_dynamic_array(&desc->records, sizeof(DESCREC), 0, 0))
|
||||
+#endif
|
||||
{
|
||||
x_free((char *)desc);
|
||||
return NULL;
|
||||
}
|
||||
|
||||
+#ifdef MARIADB_BASE_VERSION
|
||||
+ if (my_init_dynamic_array(&desc->bookmark, sizeof(DESCREC), 0, 0, 0))
|
||||
+#else
|
||||
if (my_init_dynamic_array(&desc->bookmark, sizeof(DESCREC), 0, 0))
|
||||
+#endif
|
||||
{
|
||||
delete_dynamic(&desc->records);
|
||||
x_free((char *)desc);
|
||||
@@ -997,7 +1005,12 @@
|
||||
delete_dynamic(&dest->records);
|
||||
if (my_init_dynamic_array(&dest->records, sizeof(DESCREC),
|
||||
src->records.max_element,
|
||||
+#ifdef MARIADB_BASE_VERSION
|
||||
+ src->records.alloc_increment,
|
||||
+ 0))
|
||||
+#else
|
||||
src->records.alloc_increment))
|
||||
+#endif
|
||||
{
|
||||
return set_desc_error(dest, "HY001",
|
||||
"Memory allocation error",
|
|
@ -1,14 +0,0 @@
|
|||
--- driver/handle.c.orig 2014-06-19 02:50:16.000000000 +0400
|
||||
+++ driver/handle.c 2015-03-26 12:36:14.548929818 +0300
|
||||
@@ -403,7 +403,11 @@
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef MARIADB_BASE_VERSION
|
||||
+ my_init_dynamic_array(*param_bind, sizeof(MYSQL_BIND), elements, 10, 0);
|
||||
+#else
|
||||
my_init_dynamic_array(*param_bind, sizeof(MYSQL_BIND), elements, 10);
|
||||
+#endif
|
||||
memset((*param_bind)->buffer, 0, sizeof(MYSQL_BIND) *
|
||||
(*param_bind)->max_element);
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
--- driver/parse.c.orig 2014-06-19 02:50:16.000000000 +0400
|
||||
+++ driver/parse.c 2015-03-26 12:37:12.112907082 +0300
|
||||
@@ -129,8 +129,13 @@
|
||||
|
||||
/* TODO: Store offsets rather than ptrs. In this case we will be fine
|
||||
if work with copy of the originally parsed string */
|
||||
+#ifdef MARIADB_BASE_VERSION
|
||||
+ my_init_dynamic_array(&pq->token, sizeof(uint), 20, 10, 0);
|
||||
+ my_init_dynamic_array(&pq->param_pos, sizeof(uint), 10, 10, 0);
|
||||
+#else
|
||||
my_init_dynamic_array(&pq->token, sizeof(uint), 20, 10);
|
||||
my_init_dynamic_array(&pq->param_pos, sizeof(uint), 10, 10);
|
||||
+#endif
|
||||
}
|
||||
|
||||
return pq;
|
|
@ -1,12 +0,0 @@
|
|||
--- util/odbcinstw.c.orig 2015-03-26 15:10:03.189270855 +0300
|
||||
+++ util/odbcinstw.c 2015-03-26 15:10:43.503271192 +0300
|
||||
@@ -105,7 +105,8 @@
|
||||
x_free(section);
|
||||
x_free(entry);
|
||||
x_free(def);
|
||||
- x_free(ret);
|
||||
+ if (ret)
|
||||
+ free(ret);
|
||||
x_free(filename);
|
||||
|
||||
return rc;
|
|
@ -14,8 +14,9 @@ COMMENT= Message queue that works as a pluggable storage engine of MySQL
|
|||
FETCH_DEPENDS+= ${NONEXISTENT}:${_MYSQL_SERVER}:fetch
|
||||
BUILD_DEPENDS+= ${NONEXISTENT}:${_MYSQL_SERVER}:build
|
||||
|
||||
USES= gmake perl5 libtool
|
||||
USE_MYSQL= server
|
||||
USES= gmake perl5 libtool mysql:server
|
||||
|
||||
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
|
||||
USE_GCC= any
|
||||
USE_PERL5= run
|
||||
|
||||
|
|
|
@ -13,9 +13,10 @@ COMMENT= Simple n-gram (bi-gram) fulltext parser plugin for MySQL
|
|||
|
||||
LICENSE= LGPL21
|
||||
|
||||
USES= libtool mysql
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= libtool
|
||||
USE_MYSQL= yes
|
||||
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
|
||||
INSTALL_TARGET= install-strip
|
||||
WRKSRC= ${WRKDIR}/bi_gram
|
||||
|
||||
|
|
Loading…
Reference in a new issue