- Update to 2.0.7

PR:		ports/86270
Submitted by:	Ports Fury
This commit is contained in:
Pav Lucistnik 2005-09-17 20:27:45 +00:00
parent be4376de75
commit 631b8fd5c1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=143025
4 changed files with 26 additions and 29 deletions

View file

@ -5,29 +5,36 @@
# $FreeBSD$
PORTNAME= sagasu
PORTVERSION= 2.0.6
PORTREVISION= 3
PORTVERSION= 2.0.7
CATEGORIES= textproc gnome
MASTER_SITES= http://www3.sympatico.ca/sarrazip/dev/ \
http://demian.dyndns.org/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Sagasu is a GNOME tool to find strings in a set of files
COMMENT= A GNOME tool to find strings in a set of files
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= sagasu.1
post-patch:
@${REINPLACE_CMD} -e 's|[(]datadir[)]/doc/$$(PACKAGE)-$$(VERSION)|(prefix)/share/doc/$$(PACKAGE)|g' \
${WRKSRC}/Makefile.in
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED||g'
@${REINPLACE_CMD} -e \
's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED||g' ${WRKSRC}/src/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS INSTALL NEWS README THANKS TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (sagasu-2.0.6.tar.gz) = aa76b9ecaf9be537d5485aad39c40437
SIZE (sagasu-2.0.6.tar.gz) = 282513
MD5 (sagasu-2.0.7.tar.gz) = 0b2b672eb5b9680d961ee427e4852557
SIZE (sagasu-2.0.7.tar.gz) = 288645

View file

@ -1,10 +0,0 @@
--- src/ResultPage.cpp.orig Thu Oct 9 23:20:10 2003
+++ src/ResultPage.cpp Thu Oct 9 23:21:01 2003
@@ -22,6 +22,7 @@
#include "ResultPage.h"
+#include <assert.h>
#include <libintl.h>
#define _(String) gettext (String)
#define gettext_noop(String) String

View file

@ -1,11 +1,10 @@
bin/sagasu
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/INSTALL
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/README
%%DOCSDIR%%/THANKS
%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/THANKS
%%PORTDOCS%%%%DOCSDIR%%/TODO
share/gnome/applications/sagasu.desktop
share/gnome/help/sagasu/C/sagasu.html
share/gnome/help/sagasu/fr/sagasu.html
@ -14,6 +13,7 @@ share/gnome/pixmaps/sagasu.png
share/gnome/sagasu/COPYING
share/gnome/sagasu/sagasu-helper.pl
share/gnome/sounds/sagasu/sagasu.wav
share/locale/de/LC_MESSAGES/sagasu.mo
share/locale/fr/LC_MESSAGES/sagasu.mo
share/locale/ja/LC_MESSAGES/sagasu.mo
share/locale/ru/LC_MESSAGES/sagasu.mo
@ -23,4 +23,4 @@ share/locale/sr/LC_MESSAGES/sagasu.mo
@dirrm share/gnome/help/sagasu/fr
@dirrm share/gnome/help/sagasu/C
@dirrm share/gnome/help/sagasu
@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%