Add net/ndisc6.
ndisc6 is a small collection of tools to diagnose IPv6 networks, such as Neighbor/Router Solicitation userland tools, IPv6 tcptraceroute, and an echo/discard client. PR: ports/100335 Submitted by: Rémi Denis-Courmont <rdenis@simphalempin.com>
This commit is contained in:
parent
f9262ccb2b
commit
6329c1458f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=170423
6 changed files with 65 additions and 0 deletions
|
@ -316,6 +316,7 @@
|
|||
SUBDIR += nc6
|
||||
SUBDIR += ncp
|
||||
SUBDIR += ncplib
|
||||
SUBDIR += ndisc6
|
||||
SUBDIR += nemesis
|
||||
SUBDIR += nepenthes
|
||||
SUBDIR += nepim
|
||||
|
|
36
net/ndisc6/Makefile
Normal file
36
net/ndisc6/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# New ports collection makefile for: ndisc6
|
||||
# Date created: 12 July 2006
|
||||
# Whom: rdenis@simphalempin.com
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ndisc6
|
||||
PORTVERSION= 0.6.6
|
||||
CATEGORIES= net ipv6
|
||||
MASTER_SITES= http://www.remlab.net/files/ndisc6/archive/
|
||||
|
||||
MAINTAINER= rdenis@simphalempin.com
|
||||
COMMENT= IPv6 network diagnostic tools
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GETOPT_LONG=yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-suid-install --mandir=${MANPREFIX}/man
|
||||
|
||||
MAN1= tcpspray6.1
|
||||
MAN8= ndisc6.8 rdisc6.8 rltraceroute6.8
|
||||
MLINKS= tcptraceroute6.8 rltraceroute6.8 \
|
||||
tracert6.8 rltraceroute6.8
|
||||
|
||||
PORTDOCS= AUTHORS NEWS README
|
||||
|
||||
post-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in ${PORTDOCS}
|
||||
${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
net/ndisc6/distinfo
Normal file
3
net/ndisc6/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (ndisc6-0.6.6.tar.bz2) = c0708260bba1f5156aabf9a0f69699e1
|
||||
SHA256 (ndisc6-0.6.6.tar.bz2) = 53a06e6177ce47a74a529090b8440714acd8c533d01724ef8c591b358565f0a4
|
||||
SIZE (ndisc6-0.6.6.tar.bz2) = 97395
|
13
net/ndisc6/files/patch-src_tcpspray.c
Normal file
13
net/ndisc6/files/patch-src_tcpspray.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/tcpspray.c.orig Wed Jul 12 19:01:50 2006
|
||||
+++ src/tcpspray.c Sat Aug 5 16:31:01 2006
|
||||
@@ -48,6 +48,10 @@
|
||||
# include <getopt.h>
|
||||
#endif
|
||||
|
||||
+#ifndef SIZE_MAX
|
||||
+# define SIZE_MAX SIZE_T_MAX
|
||||
+#endif
|
||||
+
|
||||
static int family = 0;
|
||||
static unsigned verbose = 0;
|
||||
|
6
net/ndisc6/pkg-descr
Normal file
6
net/ndisc6/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
ndisc6 is a collection of diagnostic tools for IPv6 networks,
|
||||
including ICMPv6 Neighbor Discovery tools (rdisc6 and ndisc6),
|
||||
an UDP, TCP and ICMP-based IPv6 traceroute implementation and
|
||||
a simplistic bandwidth measurement program (tcpspray6).
|
||||
|
||||
WWW: http://www.simphalempin.com/dev/ndisc6/
|
6
net/ndisc6/pkg-plist
Normal file
6
net/ndisc6/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
bin/tcpspray6
|
||||
sbin/ndisc6
|
||||
sbin/rdisc6
|
||||
sbin/tcptraceroute6
|
||||
sbin/rltraceroute6
|
||||
sbin/tracert6
|
Loading…
Reference in a new issue