- Update to 20130203

- Add LICENSE info
- Add DESKTOP_ENTRIES
- OptionsNG

PR:		174989
Submitted by:	Sender Ghost <lightside  at  safebox.ru>
This commit is contained in:
Jose Alonso Cardenas Marquez 2013-03-24 19:11:38 +00:00
parent 53d6225015
commit 63308c40e8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315151
7 changed files with 45 additions and 82 deletions

View file

@ -6,15 +6,18 @@
#
PORTNAME= sauerbraten
PORTVERSION= 20100728
PORTREVISION= 2
PORTVERSION= 20130203
PORTREVISION= 0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2010_07_19
DISTNAME= ${PORTNAME}_2010_07_28_justice_edition_linux
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2013_01_04
DISTNAME= ${PORTNAME}_2013_02_03_collect_edition_linux
MAINTAINER= acm@FreeBSD.org
COMMENT= First person shooter based on Cube
LICENSE_COMB= multi
LICENSE= MIT ZLIB
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
@ -31,31 +34,34 @@ MANUAL_PACKAGE_BUILD= distfile exceeds pointyhat file size limits
PORTDATA= data packages
PORTDOCS= *
OPTIONS= CLIENT "Build client" on \
DEDICATED "Build dedicated server" on \
MASTER "Build master server" off
OPTIONS_MULTI= BUILD
OPTIONS_MULTI_BUILD= CLIENT DEDICATED MASTER
OPTIONS_DEFAULT= CLIENT DEDICATED
CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
MASTER_DESC= Build master server
SUB_FILES= sauer_client sauer_master sauer_server pkg-message
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && defined(WITHOUT_MASTER)
IGNORE= needs at least one executable (CLIENT, DEDICATED or MASTER)
.endif
.if !defined(WITHOUT_CLIENT)
.if ${PORT_OPTIONS:MCLIENT}
USE_GL= yes
USE_SDL= image mixer sdl
ALL_TARGET+= client
SAUER_BIN+= client
DESKTOP_ENTRIES="Sauerbraten" "${COMMENT}" \
"${PREFIX}/share/${PORTNAME}/data/cube.png" "sauer_client" \
"Game;" false
.endif
.if !defined(WITHOUT_DEDICATED)
.if ${PORT_OPTIONS:MDEDICATED}
ALL_TARGET+= server
SAUER_BIN+= server
.endif
.if !defined(WITHOUT_MASTER)
.if ${PORT_OPTIONS:MMASTER}
ALL_TARGET+= master
SAUER_BIN+= master
.endif
@ -77,7 +83,7 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR}
.endif
.if !defined(NOPORTDOCS)
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
@ -91,4 +97,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (sauerbraten_2010_07_28_justice_edition_linux.tar.bz2) = 185e5dbf41a4426af5f692e49afa69237e23976ef3b368f43ec6aa19fb3cc86c
SIZE (sauerbraten_2010_07_28_justice_edition_linux.tar.bz2) = 464652953
SHA256 (sauerbraten_2013_02_03_collect_edition_linux.tar.bz2) = 45c20521e3e56374490b2d9112a211538e801cf0161197f35476b30b7b58a78e
SIZE (sauerbraten_2013_02_03_collect_edition_linux.tar.bz2) = 589941180

View file

@ -1,8 +1,8 @@
--- src/Makefile.orig 2010-05-14 01:30:28.000000000 +0700
+++ src/Makefile 2010-09-24 18:44:00.000000000 +0700
--- src/Makefile 2012-08-28 00:30:07.000000000 -0500
+++ src/Makefile 2013-03-24 00:38:04.000000000 -0500
@@ -1,8 +1,7 @@
-CXXFLAGS= -O3 -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char
override CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
PLATFORM= $(shell uname -s)
-PLATFORM_PREFIX= native
@ -10,25 +10,25 @@
INCLUDES= -Ishared -Iengine -Ifpsgame -Ienet/include
@@ -20,8 +19,8 @@
CLIENT_INCLUDES= $(INCLUDES) -Iinclude
CLIENT_LIBS= -mwindows -Llib -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
@@ -36,8 +35,8 @@
endif
CLIENT_LIBS= -mwindows $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lSDL -lSDL_image -lSDL_mixer -lzlib1 -lopengl32 -lenet -lws2_32 -lwinmm
else
-CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
-CLIENT_LIBS= -Lenet/.libs -lenet -L/usr/X11R6/lib `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
-CLIENT_LIBS= -Lenet/.libs -lenet -L/usr/X11R6/lib -lX11 `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
+CLIENT_INCLUDES= $(INCLUDES) `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
+CLIENT_LIBS= -Lenet/.libs -lenet `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib -lSDL_image -lSDL_mixer -lz -lGL
endif
ifeq ($(PLATFORM),Linux)
CLIENT_LIBS+= -lrt
@@ -90,8 +89,8 @@
SERVER_INCLUDES= -DSTANDALONE $(INCLUDES) -Iinclude
SERVER_LIBS= -Llib -lzdll -lenet -lws2_32 -lwinmm
@@ -105,8 +104,8 @@
SERVER_LIBS= -mwindows $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lzlib1 -lenet -lws2_32 -lwinmm
MASTER_LIBS= $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lzlib1 -lenet -lws2_32 -lwinmm
else
-SERVER_INCLUDES= -DSTANDALONE $(INCLUDES)
-SERVER_LIBS= -Lenet/.libs -lenet -lz
+SERVER_INCLUDES= -DSTANDALONE $(INCLUDES) -I${LOCALBASE}/include
+SERVER_LIBS= -Lenet/.libs -lenet -lz -L${LOCALBASE}/lib
MASTER_LIBS= $(SERVER_LIBS)
endif
SERVER_OBJS= \
shared/crypto-standalone.o \

View file

@ -1,11 +1,10 @@
###############################################################################
1) First time, sauerbraten creates a ~/.sauerbraten directory with symlinks.
2) Config files are in the ~/.sauerbraten directory.
3) If you want add new bindings into ~/.sauerbraten/config.cfg, see
1) Config files are in the ~/.sauerbraten directory.
2) If you want add new bindings into ~/.sauerbraten/config.cfg, see
%%DATADIR%%/data/keymap.cfg.
4) Enjoy it ;)
3) Enjoy it ;)
###############################################################################

View file

@ -1,18 +1,4 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d ~/.sauerbraten ]
then
echo "Using existing ~/.sauerbraten directory."
else
echo "Creating ~/.sauerbraten directory."
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \;
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null
fi
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client "$@"
SAUER_OPTIONS="-q${HOME}/.sauerbraten"
cd %%DATADIR%% && exec %%PREFIX%%/libexec/sauer_client ${SAUER_OPTIONS} "$@"

View file

@ -1,18 +1,4 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d ~/.sauerbraten ]
then
echo "Using existing ~/.sauerbraten directory."
else
echo "Creating ~/.sauerbraten directory."
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \;
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null
fi
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_master "$@"
SAUER_OPTIONS="-q${HOME}/.sauerbraten"
cd %%DATADIR%% && exec %%PREFIX%%/libexec/sauer_master ${SAUER_OPTIONS} "$@"

View file

@ -1,18 +1,4 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d ~/.sauerbraten ]
then
echo "Using existing ~/.sauerbraten directory."
else
echo "Creating ~/.sauerbraten directory."
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \;
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null
fi
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server "$@"
SAUER_OPTIONS="-q${HOME}/.sauerbraten"
cd %%DATADIR%% && exec %%PREFIX%%/libexec/sauer_server ${SAUER_OPTIONS} "$@"