graphics/podofo: Simplify the patch with symbolic link
- Regenerate the patch file
This commit is contained in:
parent
18cca4c4e2
commit
6363066eb5
3 changed files with 7 additions and 182 deletions
|
@ -21,7 +21,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
|||
USES= cmake compiler:c++17-lang cpe gnome localbase:ldflags pkgconfig ssl
|
||||
USE_GNOME= libxml2
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include/fast_float
|
||||
CFLAGS+= -I${LOCALBASE}/include/fast_float -I${WRKSRC}
|
||||
CMAKE_ARGS= -DFONTCONFIG_LIBRARIES=${LOCALBASE}/lib/libfontconfig.so \
|
||||
-DOPENSSL_INCLUDE_DIR=${OPENSSLINC} \
|
||||
-DOPENSSL_LIBRARIES=${OPENSSLDIR}
|
||||
|
@ -49,5 +49,6 @@ post-patch:
|
|||
@${RM} -r ${WRKSRC}/3rdparty/date/
|
||||
@${RM} -r ${WRKSRC}/3rdparty/fmt/
|
||||
@${RM} -r ${WRKSRC}/3rdparty/utfcpp/
|
||||
@${LN} -s ${LOCALBASE}/include/utf8cpp ${WRKSRC}/3rdparty/utfcpp
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2023-03-25 11:01:27 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -21,7 +21,7 @@ set(PODOFO_VERSION_PATCH "0" CACHE STRING "Patchlevel
|
||||
@@ -21,7 +21,7 @@ endif()
|
||||
set(PODOFO_VERSION_MAJOR "0" CACHE STRING "Major part of podofo version number")
|
||||
set(PODOFO_VERSION_MINOR "10" CACHE STRING "Minor part of podofo version number")
|
||||
set(PODOFO_VERSION_PATCH "0" CACHE STRING "Patchlevel part of podofo version number")
|
||||
|
@ -9,7 +9,7 @@
|
|||
set(PODOFO_SOVERSION "1")
|
||||
|
||||
#
|
||||
@@ -149,6 +149,7 @@ endif()
|
||||
@@ -149,6 +149,7 @@ else()
|
||||
message("Libidn not found. AES-256 Encryption support will be disabled")
|
||||
endif()
|
||||
|
||||
|
@ -17,7 +17,7 @@
|
|||
find_package(JPEG)
|
||||
|
||||
if(JPEG_FOUND)
|
||||
@@ -157,7 +158,9 @@ endif()
|
||||
@@ -157,7 +158,9 @@ if(JPEG_FOUND)
|
||||
else()
|
||||
message("Libjpeg not found. JPEG support will be disabled")
|
||||
endif()
|
||||
|
@ -27,7 +27,7 @@
|
|||
find_package(TIFF)
|
||||
|
||||
if(TIFF_FOUND)
|
||||
@@ -166,7 +169,9 @@ endif()
|
||||
@@ -166,7 +169,9 @@ if(TIFF_FOUND)
|
||||
else()
|
||||
message("Libtiff not found. TIFF support will be disabled")
|
||||
endif()
|
||||
|
@ -37,7 +37,7 @@
|
|||
find_package(PNG)
|
||||
|
||||
if(PNG_FOUND)
|
||||
@@ -175,6 +180,7 @@ else()
|
||||
@@ -175,6 +180,7 @@ if(PNG_FOUND)
|
||||
else()
|
||||
message("LibPng not found. PNG support will be disabled")
|
||||
set(PNG_LIBRARIES "")
|
||||
|
|
|
@ -1,176 +0,0 @@
|
|||
--- src/podofo/main/PdfCMapEncoding.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfCMapEncoding.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <podofo/private/PdfDeclarationsPrivate.h>
|
||||
#include "PdfCMapEncoding.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include "PdfDictionary.h"
|
||||
#include "PdfObjectStream.h"
|
||||
--- src/podofo/main/PdfCharCodeMap.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfCharCodeMap.cpp
|
||||
@@ -8,7 +8,7 @@
|
||||
#include "PdfCharCodeMap.h"
|
||||
#include <random>
|
||||
#include <algorithm>
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
using namespace std;
|
||||
using namespace PoDoFo;
|
||||
--- src/podofo/main/PdfDifferenceEncoding.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfDifferenceEncoding.cpp
|
||||
@@ -9,7 +9,7 @@
|
||||
|
||||
#include <algorithm>
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
#include <podofo/private/charconv_compat.h>
|
||||
|
||||
#include "PdfArray.h"
|
||||
--- src/podofo/main/PdfEncoding.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfEncoding.cpp
|
||||
@@ -8,7 +8,7 @@
|
||||
#include "PdfEncoding.h"
|
||||
|
||||
#include <atomic>
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include <podofo/private/PdfEncodingPrivate.h>
|
||||
|
||||
--- src/podofo/main/PdfEncodingMap.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfEncodingMap.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <podofo/private/PdfDeclarationsPrivate.h>
|
||||
#include "PdfEncodingMap.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include "PdfDictionary.h"
|
||||
#include "PdfCMapEncoding.h"
|
||||
--- src/podofo/main/PdfFont.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfFont.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <podofo/private/PdfDeclarationsPrivate.h>
|
||||
#include "PdfFont.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include <podofo/private/PdfEncodingPrivate.h>
|
||||
#include <podofo/private/PdfStandard14FontData.h>
|
||||
--- src/podofo/main/PdfFontManager.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfFontManager.cpp
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
#include <podofo/private/FreetypePrivate.h>
|
||||
#include FT_TRUETYPE_TABLES_H
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include "PdfDictionary.h"
|
||||
#include <podofo/auxiliary/InputDevice.h>
|
||||
--- src/podofo/main/PdfFontType1.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfFontType1.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <podofo/private/PdfDeclarationsPrivate.h>
|
||||
#include "PdfFontType1.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include <podofo/auxiliary/InputDevice.h>
|
||||
#include "PdfArray.h"
|
||||
--- src/podofo/main/PdfIdentityEncoding.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfIdentityEncoding.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <podofo/private/PdfDeclarationsPrivate.h>
|
||||
#include "PdfIdentityEncoding.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include "PdfDictionary.h"
|
||||
#include "PdfFont.h"
|
||||
--- src/podofo/main/PdfImage.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfImage.cpp
|
||||
@@ -13,7 +13,7 @@ extern "C" {
|
||||
}
|
||||
#endif // PODOFO_HAVE_TIFF_LIB
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include <podofo/private/FileSystem.h>
|
||||
#include <podofo/private/PdfFiltersPrivate.h>
|
||||
--- src/podofo/main/PdfPage_TextExtraction.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfPage_TextExtraction.cpp
|
||||
@@ -11,7 +11,7 @@
|
||||
#include <deque>
|
||||
#include <stack>
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include "PdfDocument.h"
|
||||
#include "PdfTextState.h"
|
||||
--- src/podofo/main/PdfPainter.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfPainter.cpp
|
||||
@@ -9,7 +9,7 @@
|
||||
|
||||
#include <podofo/private/PdfDrawingOperations.h>
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include "PdfExtGState.h"
|
||||
#include "PdfFont.h"
|
||||
--- src/podofo/main/PdfString.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/main/PdfString.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <podofo/private/PdfDeclarationsPrivate.h>
|
||||
#include "PdfString.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
#include <podofo/private/PdfEncodingPrivate.h>
|
||||
|
||||
--- src/podofo/private/PdfEncodingPrivate.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/private/PdfEncodingPrivate.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include "PdfDeclarationsPrivate.h"
|
||||
#include "PdfEncodingPrivate.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
using namespace std;
|
||||
using namespace PoDoFo;
|
||||
--- src/podofo/private/utfcpp_extensions.h.orig 2023-03-25 11:01:27 UTC
|
||||
+++ src/podofo/private/utfcpp_extensions.h
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
#include <cstddef>
|
||||
#include <stdexcept>
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
namespace utf8
|
||||
{
|
||||
--- test/common/PdfTest.cpp.orig 2023-03-25 11:01:27 UTC
|
||||
+++ test/common/PdfTest.cpp
|
||||
@@ -8,7 +8,7 @@
|
||||
|
||||
#include "PdfTest.h"
|
||||
|
||||
-#include <utfcpp/utf8.h>
|
||||
+#include <utf8cpp/utf8.h>
|
||||
|
||||
using namespace std;
|
||||
using namespace PoDoFo;
|
Loading…
Reference in a new issue