add libshbuf 0.0.2

Library for Shared Buffer IPC
This commit is contained in:
Ying-Chieh Liao 2002-05-06 14:47:14 +00:00
parent 53688aac0f
commit 636e027b6e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=58607
8 changed files with 69 additions and 0 deletions

View file

@ -261,6 +261,7 @@
SUBDIR += libole2
SUBDIR += liboop
SUBDIR += libredblack
SUBDIR += libshbuf
SUBDIR += libshhmsg
SUBDIR += libshhopt
SUBDIR += libsigc++

24
devel/libshbuf/Makefile Normal file
View file

@ -0,0 +1,24 @@
# ex:ts=8
# Ports collection makefile for: libshbuf
# Date created: May 6, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= libshbuf
PORTVERSION= 0.0.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
.include <bsd.port.mk>

1
devel/libshbuf/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (libshbuf-0.0.2.tar.gz) = 1da7981daeb36e9b7ac968eb1f8266fd

View file

@ -0,0 +1,11 @@
--- src/internal.h.orig Mon May 6 22:38:42 2002
+++ src/internal.h Mon May 6 22:40:33 2002
@@ -72,7 +72,7 @@
pthread_t thread;
};
-#if defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)
+#if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED) || defined(__FreeBSD__))
/* union semun is defined by including <sys/sem.h> */
#else
/* according to X/OPEN we have to define it ourselves */

View file

@ -0,0 +1,10 @@
--- src/shbuf.c.orig Mon May 6 22:37:36 2002
+++ src/shbuf.c Mon May 6 22:38:02 2002
@@ -24,6 +24,7 @@
#include <signal.h>
#include <errno.h>
#include <stdio.h>
+#include <string.h>
#include "shbuf.h"
#include "internal.h"

View file

@ -0,0 +1 @@
Library for Shared Buffer IPC

14
devel/libshbuf/pkg-descr Normal file
View file

@ -0,0 +1,14 @@
libshbuf implements a new kind of IPC: the "shared buffer", a faster, more
flexible replacement for standard Unix FIFOs. It offers the following
advantages:
- Normally better latency and throughput
- Full access to the buffer at any time
- Connecting processes need not to be children of each other
- Arbitrary buffer lengths
- Memory mapped
- "Backlog"
The implementation is based on SysV shared memory, semaphores and message
queues. It makes use of POSIX pthreads.
WWW: http://libshbuf.sourceforge.net/

7
devel/libshbuf/pkg-plist Normal file
View file

@ -0,0 +1,7 @@
include/libshbuf/shbuf.h
include/libshbuf/shbuferr.h
@dirrm include/libshbuf
lib/libshbuf.a
lib/libshbuf.la
lib/libshbuf.so
lib/libshbuf.so.1