Cleanup a bit by passing necessary CMAKE_INSTALL_RPATH in Makefile
This commit is contained in:
parent
081053d015
commit
638eb974e9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416336
2 changed files with 2 additions and 13 deletions
|
@ -20,5 +20,6 @@ USES= cmake:outsource compiler:gcc-c++11-lib fortran pkgconfig
|
|||
|
||||
PLIST_FILES= bin/sdr-wspr share/applications/sdr-wspr.desktop \
|
||||
share/icons/sdr-wspr.svg
|
||||
CMAKE_ARGS= -DCMAKE_INSTALL_RPATH:STRING="${LOCALBASE}/lib/gcc${_GCC_VER}"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,18 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2015-04-21 14:32:18 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -2,6 +2,11 @@ cmake_minimum_required(VERSION 2.8.8)
|
||||
project(sdr-wspr)
|
||||
# required for original wspr code
|
||||
enable_language(Fortran)
|
||||
+# temporary ugly hack
|
||||
+string(REGEX MATCH "-rpath=.*" CMAKE_RPATH_ARG ${CMAKE_Fortran_FLAGS} )
|
||||
+string(SUBSTRING ${CMAKE_RPATH_ARG} 7 -1 CMAKE_RPATH)
|
||||
+set(CMAKE_INSTALL_RPATH ${CMAKE_RPATH} )
|
||||
+message(STATUS CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_RPATH})
|
||||
|
||||
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/cmake)
|
||||
include(InstallHeadersWithDirectory)
|
||||
@@ -63,34 +68,6 @@ ELSE(NOT LIBSDR_GUI_FOUND)
|
||||
@@ -63,34 +63,6 @@ ELSE(NOT LIBSDR_GUI_FOUND)
|
||||
ENDIF(NOT LIBSDR_GUI_FOUND)
|
||||
|
||||
# Set compiler flags
|
||||
|
|
Loading…
Reference in a new issue