add py-pow 0.6.1
Python OpenSSL Wrappers
This commit is contained in:
parent
54a14a2a75
commit
63b45c1017
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54556
7 changed files with 54 additions and 0 deletions
|
@ -181,6 +181,7 @@
|
|||
SUBDIR += py-gnupg
|
||||
SUBDIR += py-m2crypto
|
||||
SUBDIR += py-mhash
|
||||
SUBDIR += py-pow
|
||||
SUBDIR += py-rijndael
|
||||
SUBDIR += py-twofish
|
||||
SUBDIR += qident
|
||||
|
|
34
security/py-pow/Makefile
Normal file
34
security/py-pow/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: Python OpenSSL Wrappers
|
||||
# Date created: Feb 10, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pow
|
||||
PORTVERSION= 0.6.1
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_OPENSSL= yes
|
||||
|
||||
SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
|
||||
|
||||
do-build:
|
||||
@${SETUP_CMD} build
|
||||
|
||||
do-install:
|
||||
@${SETUP_CMD} install
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/POW.pdf ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/py-pow/distinfo
Normal file
1
security/py-pow/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (POW-0.6.1.tar.gz) = a1093b7b8c105869e0538fd4b8bb2228
|
11
security/py-pow/files/patch-POW.c
Normal file
11
security/py-pow/files/patch-POW.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- POW.c.orig Mon Feb 11 22:12:50 2002
|
||||
+++ POW.c Mon Feb 11 22:13:01 2002
|
||||
@@ -34,7 +34,7 @@
|
||||
/* */
|
||||
/*****************************************************************************/
|
||||
|
||||
-#include <python2.1/Python.h>
|
||||
+#include <Python.h>
|
||||
|
||||
#include <openssl/crypto.h>
|
||||
#include <openssl/rand.h>
|
1
security/py-pow/pkg-comment
Normal file
1
security/py-pow/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Python OpenSSL Wrappers
|
3
security/py-pow/pkg-descr
Normal file
3
security/py-pow/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Python OpenSSL Wrappers(POW) is a set of comprehensive wrappers for Python of
|
||||
the OpenSSL libraries. POW will provide a 'slim' interface which will still
|
||||
enable Python developers to fully utilise OpenSSL.
|
3
security/py-pow/pkg-plist
Normal file
3
security/py-pow/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
lib/%%PYTHON_VERSION%%/site-packages/POW.so
|
||||
%%PORTDOCS%%share/doc/pow/POW.pdf
|
||||
%%PORTDOCS%%@dirrm share/doc/pow
|
Loading…
Reference in a new issue