Update to latest commit.
This commit is contained in:
parent
5bdae5a56e
commit
63e7b6278b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=560294
6 changed files with 32 additions and 32 deletions
|
@ -20,23 +20,23 @@ lib/bind-tools/libbind9.so
|
|||
lib/bind-tools/libbind9.so.1701
|
||||
lib/bind-tools/libbind9.so.1701.0.3
|
||||
lib/bind-tools/libdns.so
|
||||
lib/bind-tools/libdns.so.1707
|
||||
lib/bind-tools/libdns.so.1707.0.0
|
||||
lib/bind-tools/libdns.so.1708
|
||||
lib/bind-tools/libdns.so.1708.0.0
|
||||
lib/bind-tools/libirs.so
|
||||
lib/bind-tools/libirs.so.1701
|
||||
lib/bind-tools/libirs.so.1701.0.0
|
||||
lib/bind-tools/libisc.so
|
||||
lib/bind-tools/libisc.so.1706
|
||||
lib/bind-tools/libisc.so.1706.0.0
|
||||
lib/bind-tools/libisc.so.1707
|
||||
lib/bind-tools/libisc.so.1707.0.0
|
||||
lib/bind-tools/libisccc.so
|
||||
lib/bind-tools/libisccc.so.1703
|
||||
lib/bind-tools/libisccc.so.1703.0.0
|
||||
lib/bind-tools/libisccfg.so
|
||||
lib/bind-tools/libisccfg.so.1702
|
||||
lib/bind-tools/libisccfg.so.1702.0.2
|
||||
lib/bind-tools/libisccfg.so.1703
|
||||
lib/bind-tools/libisccfg.so.1703.0.0
|
||||
lib/bind-tools/libns.so
|
||||
lib/bind-tools/libns.so.1705
|
||||
lib/bind-tools/libns.so.1705.0.0
|
||||
lib/bind-tools/libns.so.1706
|
||||
lib/bind-tools/libns.so.1706.0.0
|
||||
man/man1/arpaname.1.gz
|
||||
man/man1/delv.1.gz
|
||||
man/man1/dig.1.gz
|
||||
|
|
|
@ -48,13 +48,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
|
|||
# XXX: remove tar:bz2
|
||||
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
|
||||
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
|
||||
ISCVERSION= 9.17.7a0.2020.11.27
|
||||
ISCVERSION= 9.17.8a0.2021.01.04
|
||||
# XXX: Remove gitlab
|
||||
USE_GITLAB= yes
|
||||
GL_SITE= https://gitlab.isc.org
|
||||
GL_ACCOUNT= isc-projects
|
||||
GL_PROJECT= bind9
|
||||
GL_COMMIT= 90298dfc18376ff514ddfbded93c249c4063d7d4
|
||||
GL_COMMIT= 8c6db04f60a6702dabd6de92f8579b547619dbac
|
||||
|
||||
CPE_VENDOR= isc
|
||||
CPE_VERSION= ${ISCVERSION:C/-.*//}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1606733845
|
||||
SHA256 (isc-projects-bind9-90298dfc18376ff514ddfbded93c249c4063d7d4_GL0.tar.gz) = f2e9f57b58d591189f0b25f934661c0df41516aede35afc604128b4d8c54f7f3
|
||||
SIZE (isc-projects-bind9-90298dfc18376ff514ddfbded93c249c4063d7d4_GL0.tar.gz) = 4439081
|
||||
TIMESTAMP = 1609765171
|
||||
SHA256 (isc-projects-bind9-8c6db04f60a6702dabd6de92f8579b547619dbac_GL0.tar.gz) = dec3a4fd760887ed5951648fa55b05ab174cd3986db80cd17abea25ed6f06f96
|
||||
SIZE (isc-projects-bind9-8c6db04f60a6702dabd6de92f8579b547619dbac_GL0.tar.gz) = 4467364
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
Add the override-cache-ttl feature.
|
||||
|
||||
--- bin/named/config.c.orig 2020-11-11 21:48:13 UTC
|
||||
--- bin/named/config.c.orig 2021-01-04 06:21:13 UTC
|
||||
+++ bin/named/config.c
|
||||
@@ -181,6 +181,7 @@ options {\n\
|
||||
notify-source *;\n\
|
||||
|
@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
|
|||
provide-ixfr true;\n\
|
||||
qname-minimization relaxed;\n\
|
||||
query-source address *;\n\
|
||||
--- bin/named/server.c.orig 2020-11-11 21:48:13 UTC
|
||||
--- bin/named/server.c.orig 2021-01-04 06:21:13 UTC
|
||||
+++ bin/named/server.c
|
||||
@@ -4346,6 +4346,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
|
||||
@@ -4433,6 +4433,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
|
||||
}
|
||||
|
||||
obj = NULL;
|
||||
|
@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
|
|||
result = named_config_get(maps, "max-cache-ttl", &obj);
|
||||
INSIST(result == ISC_R_SUCCESS);
|
||||
view->maxcachettl = cfg_obj_asduration(obj);
|
||||
--- lib/dns/include/dns/view.h.orig 2020-11-11 21:48:13 UTC
|
||||
--- lib/dns/include/dns/view.h.orig 2021-01-04 06:21:13 UTC
|
||||
+++ lib/dns/include/dns/view.h
|
||||
@@ -152,6 +152,7 @@ struct dns_view {
|
||||
bool requestnsid;
|
||||
|
@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
|
|||
dns_ttl_t maxncachettl;
|
||||
dns_ttl_t mincachettl;
|
||||
dns_ttl_t minncachettl;
|
||||
--- lib/dns/resolver.c.orig 2020-11-11 21:48:13 UTC
|
||||
--- lib/dns/resolver.c.orig 2021-01-04 06:21:13 UTC
|
||||
+++ lib/dns/resolver.c
|
||||
@@ -6185,6 +6185,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
|
||||
@@ -6192,6 +6192,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
|
||||
}
|
||||
|
||||
/*
|
||||
|
@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
|
|||
* Enforce the configure maximum cache TTL.
|
||||
*/
|
||||
if (rdataset->ttl > res->view->maxcachettl) {
|
||||
--- lib/isccfg/namedconf.c.orig 2020-11-11 21:48:13 UTC
|
||||
--- lib/isccfg/namedconf.c.orig 2021-01-04 06:21:13 UTC
|
||||
+++ lib/isccfg/namedconf.c
|
||||
@@ -1998,6 +1998,7 @@ static cfg_clausedef_t view_clauses[] = {
|
||||
@@ -2034,6 +2034,7 @@ static cfg_clausedef_t view_clauses[] = {
|
||||
#endif /* ifdef HAVE_LMDB */
|
||||
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
|
||||
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
Exclude the "tools" from building and installing.
|
||||
|
||||
--- bin/Makefile.am.orig 2020-07-20 08:13:37 UTC
|
||||
--- bin/Makefile.am.orig 2021-01-04 06:21:13 UTC
|
||||
+++ bin/Makefile.am
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = named rndc dig delv dnssec tools nsupdate check confgen tests plugins
|
||||
|
@ -8,10 +8,10 @@ Exclude the "tools" from building and installing.
|
|||
|
||||
if HAVE_PKCS11
|
||||
SUBDIRS += pkcs11
|
||||
--- bin/tools/Makefile.am.orig 2020-07-20 08:13:37 UTC
|
||||
--- bin/tools/Makefile.am.orig 2021-01-04 06:21:13 UTC
|
||||
+++ bin/tools/Makefile.am
|
||||
@@ -9,11 +9,7 @@ LDADD = \
|
||||
$(LIBDNS_LIBS)
|
||||
$(LIBISC_LIBS)
|
||||
|
||||
bin_PROGRAMS = \
|
||||
- arpaname \
|
||||
|
|
|
@ -266,23 +266,23 @@ lib/libbind9.so
|
|||
lib/libbind9.so.1701
|
||||
lib/libbind9.so.1701.0.3
|
||||
lib/libdns.so
|
||||
lib/libdns.so.1707
|
||||
lib/libdns.so.1707.0.0
|
||||
lib/libdns.so.1708
|
||||
lib/libdns.so.1708.0.0
|
||||
lib/libirs.so
|
||||
lib/libirs.so.1701
|
||||
lib/libirs.so.1701.0.0
|
||||
lib/libisc.so
|
||||
lib/libisc.so.1706
|
||||
lib/libisc.so.1706.0.0
|
||||
lib/libisc.so.1707
|
||||
lib/libisc.so.1707.0.0
|
||||
lib/libisccc.so
|
||||
lib/libisccc.so.1703
|
||||
lib/libisccc.so.1703.0.0
|
||||
lib/libisccfg.so
|
||||
lib/libisccfg.so.1702
|
||||
lib/libisccfg.so.1702.0.2
|
||||
lib/libisccfg.so.1703
|
||||
lib/libisccfg.so.1703.0.0
|
||||
lib/libns.so
|
||||
lib/libns.so.1705
|
||||
lib/libns.so.1705.0.0
|
||||
lib/libns.so.1706
|
||||
lib/libns.so.1706.0.0
|
||||
@comment lib/named/filter-aaaa.so
|
||||
@comment man/man1/arpaname.1.gz
|
||||
@comment man/man1/delv.1.gz
|
||||
|
|
Loading…
Reference in a new issue