Add adns, an asynchronous DNS resolver library that provides a way to do

nslookups in a non-blocking manner. The adns distribution also comes with
some utilities similar to dig, host, nslookup, etc.

The port that I'm importing rips out the ${PORTOBJFORMAT} checking and
also trims the extra stuff in pkg/DESCR, which the original submission
contained.

PR:		17510
Submitted by:	Kostya Lukin <lukin@sapa.ivcme.elektra.ru>
Reviewed by:	billf, mharo
This commit is contained in:
Will Andrews 2000-04-02 05:37:29 +00:00
parent bcaf1bc702
commit 63eef36fd6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27277
14 changed files with 178 additions and 0 deletions

23
dns/adns/Makefile Normal file
View file

@ -0,0 +1,23 @@
# New ports collection makefile for: adns
# Version required: 0.7
# Date created: Mon Mar 3, 2000
# Whom: Kostya Lukin <lukin@okbmei.msk.su>
#
# $FreeBSD$
#
DISTNAME= adns-0.7
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.chiark.greenend.org.uk/users/ian/adns/
MASTER_SITE_SUBDIR= adns
MAINTAINER= lukin@okbmei.msk.su
GNU_CONFIGURE= yes
USE_GMAKE= yes
post-install:
strip ${PREFIX}/bin/adnstest ${PREFIX}/bin/adnslogres ${PREFIX}/bin/adnshost
.include <bsd.port.mk>

1
dns/adns/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (adns-0.7.tar.gz) = dbf31b805b3d993d116a2ef9e45b93ae

11
dns/adns/files/patch-aa Normal file
View file

@ -0,0 +1,11 @@
--- configure.orig Wed Nov 24 19:57:32 1999
+++ configure Mon Mar 20 18:35:47 2000
@@ -1457,7 +1457,7 @@
SHLIBFORLINK='libadns.so'
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
+SHLIBFILE='$(SHLIBSONAME)'
SHLIBCC='$(CC) $(CFLAGS) -fpic'
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'

30
dns/adns/files/patch-ab Normal file
View file

@ -0,0 +1,30 @@
--- dynamic/Makefile.in.orig Fri Oct 15 21:57:50 1999
+++ dynamic/Makefile.in Mon Mar 20 18:41:21 2000
@@ -24,7 +24,7 @@
srcdir= @srcdir@
VPATH= @srcdir@
-TARGETS= $(SHLIBFILE) $(SHLIBSONAME) $(SHLIBFORLINK)
+TARGETS= $(SHLIBFILE) $(SHLIBFORLINK)
include $(srcdir)/../settings.make
include $(srcdir)/../src/adns.make
@@ -32,16 +32,12 @@
install:
$(INSTALL_PROGRAM) $(SHLIBFILE) $(lib_dir)/$(SHLIBFILE)
- ln -sf $(SHLIBFILE) $(lib_dir)/$(SHLIBSONAME)
uninstall:
- rm -f $(lib_dir)/$(SHLIBFILE) $(lib_dir)/$(SHLIBSONAME)
+ rm -f $(lib_dir)/$(SHLIBFILE)
$(SHLIBFORLINK):
- ln -s $(SHLIBSONAME) $(SHLIBFORLINK)
-
-$(SHLIBSONAME):
- ln -s $(SHLIBFILE) $(SHLIBSONAME)
+ ln -s $(SHLIBFILE) $(SHLIBFORLINK)
$(SHLIBFILE): $(ALLOBJS)
rm -f $@

1
dns/adns/pkg-comment Normal file
View file

@ -0,0 +1 @@
Easy to use, asynchronous-capable DNS client library and utilities

15
dns/adns/pkg-descr Normal file
View file

@ -0,0 +1,15 @@
adns is a resolver library for C (and C++) programs. In contrast with
the existing interfaces, gethostbyname et al and libresolv, it has the
following features:
* It is reasonably easy to use for simple programs which just want
to translate names to addresses, look up MX records, etc.
* It can be used in an asynchronous, non-blocking, manner. Many
queries can be handled simultaneously.
Technical note: adns requires a real nameserver like BIND or
Dents running on the same system or a nearby one, which must be
willing to provide `recursive service'. I.e., adns is a `stub
resolver'.
WWW: http://www.chiark.greenend.org.uk/~ian/adns/

8
dns/adns/pkg-plist Normal file
View file

@ -0,0 +1,8 @@
bin/adnstest
bin/adnslogres
bin/adnshost
include/adns.h
lib/libadns.a
lib/libadns.so.0
@exec /sbin/ldconfig -m %D/lib
@unexec /sbin/ldconfig -R

23
net/adns/Makefile Normal file
View file

@ -0,0 +1,23 @@
# New ports collection makefile for: adns
# Version required: 0.7
# Date created: Mon Mar 3, 2000
# Whom: Kostya Lukin <lukin@okbmei.msk.su>
#
# $FreeBSD$
#
DISTNAME= adns-0.7
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.chiark.greenend.org.uk/users/ian/adns/
MASTER_SITE_SUBDIR= adns
MAINTAINER= lukin@okbmei.msk.su
GNU_CONFIGURE= yes
USE_GMAKE= yes
post-install:
strip ${PREFIX}/bin/adnstest ${PREFIX}/bin/adnslogres ${PREFIX}/bin/adnshost
.include <bsd.port.mk>

1
net/adns/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (adns-0.7.tar.gz) = dbf31b805b3d993d116a2ef9e45b93ae

11
net/adns/files/patch-aa Normal file
View file

@ -0,0 +1,11 @@
--- configure.orig Wed Nov 24 19:57:32 1999
+++ configure Mon Mar 20 18:35:47 2000
@@ -1457,7 +1457,7 @@
SHLIBFORLINK='libadns.so'
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
+SHLIBFILE='$(SHLIBSONAME)'
SHLIBCC='$(CC) $(CFLAGS) -fpic'
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'

30
net/adns/files/patch-ab Normal file
View file

@ -0,0 +1,30 @@
--- dynamic/Makefile.in.orig Fri Oct 15 21:57:50 1999
+++ dynamic/Makefile.in Mon Mar 20 18:41:21 2000
@@ -24,7 +24,7 @@
srcdir= @srcdir@
VPATH= @srcdir@
-TARGETS= $(SHLIBFILE) $(SHLIBSONAME) $(SHLIBFORLINK)
+TARGETS= $(SHLIBFILE) $(SHLIBFORLINK)
include $(srcdir)/../settings.make
include $(srcdir)/../src/adns.make
@@ -32,16 +32,12 @@
install:
$(INSTALL_PROGRAM) $(SHLIBFILE) $(lib_dir)/$(SHLIBFILE)
- ln -sf $(SHLIBFILE) $(lib_dir)/$(SHLIBSONAME)
uninstall:
- rm -f $(lib_dir)/$(SHLIBFILE) $(lib_dir)/$(SHLIBSONAME)
+ rm -f $(lib_dir)/$(SHLIBFILE)
$(SHLIBFORLINK):
- ln -s $(SHLIBSONAME) $(SHLIBFORLINK)
-
-$(SHLIBSONAME):
- ln -s $(SHLIBFILE) $(SHLIBSONAME)
+ ln -s $(SHLIBFILE) $(SHLIBFORLINK)
$(SHLIBFILE): $(ALLOBJS)
rm -f $@

1
net/adns/pkg-comment Normal file
View file

@ -0,0 +1 @@
Easy to use, asynchronous-capable DNS client library and utilities

15
net/adns/pkg-descr Normal file
View file

@ -0,0 +1,15 @@
adns is a resolver library for C (and C++) programs. In contrast with
the existing interfaces, gethostbyname et al and libresolv, it has the
following features:
* It is reasonably easy to use for simple programs which just want
to translate names to addresses, look up MX records, etc.
* It can be used in an asynchronous, non-blocking, manner. Many
queries can be handled simultaneously.
Technical note: adns requires a real nameserver like BIND or
Dents running on the same system or a nearby one, which must be
willing to provide `recursive service'. I.e., adns is a `stub
resolver'.
WWW: http://www.chiark.greenend.org.uk/~ian/adns/

8
net/adns/pkg-plist Normal file
View file

@ -0,0 +1,8 @@
bin/adnstest
bin/adnslogres
bin/adnshost
include/adns.h
lib/libadns.a
lib/libadns.so.0
@exec /sbin/ldconfig -m %D/lib
@unexec /sbin/ldconfig -R