- Update to 2.0.2

- Allow Python concurrent installation
- Use do-test target instead regression-test
This commit is contained in:
Sofian Brabez 2016-11-30 22:38:21 +00:00
parent cbccebf220
commit 641274001c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=427465
3 changed files with 18 additions and 7 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= paramiko
PORTVERSION= 2.0.0
PORTREVISION= 1
PORTVERSION= 2.0.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,18 +11,19 @@ MAINTAINER= sbz@FreeBSD.org
COMMENT= Python SSH2 protocol library
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa
USES= python
USE_PYTHON= distutils autoplist
USE_PYTHON= autoplist concurrent distutils
CONFLICTS_INSTALL= py??-paramiko1-*
OPTIONS_DEFINE= EXAMPLES
regression-test: extract
do-test: extract
@(cd ${WRKSRC} && ${PYTHON_CMD} test.py)
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1464139163
SHA256 (paramiko-2.0.0.tar.gz) = 51219ecaf88aa1cea9952b3c4ddcc0c1316f015d23d77edb7aee78a3468ef0e2
SIZE (paramiko-2.0.0.tar.gz) = 1372885
TIMESTAMP = 1480541457
SHA256 (paramiko-2.0.2.tar.gz) = 411bf90fa22b078a923ff19ef9772c1115a0953702db93549a2848acefd141dc
SIZE (paramiko-2.0.2.tar.gz) = 1190464

View file

@ -0,0 +1,11 @@
--- tests/test_packetizer.py.orig 2016-11-30 22:24:28 UTC
+++ tests/test_packetizer.py
@@ -114,7 +114,7 @@ class PacketizerTest (unittest.TestCase)
class TimeoutError(Exception):
pass
- def timeout(seconds=1, error_message=os.strerror(errno.ETIME)):
+ def timeout(seconds=1, error_message='Timer expired'):
def decorator(func):
def _handle_timeout(signum, frame):
raise TimeoutError(error_message)