Nagcon is a console application interfacing to Nagios 2.0 which gives

you an overview of all services with troubled services.

WWW: http://www.vanheusden.com/nagcon

PR:		ports/95096
Submitted by:	Douglas K. Rand <rand@meridian-enviro.com>
This commit is contained in:
Pav Lucistnik 2006-04-02 01:04:36 +00:00
parent 6d8cb2fed2
commit 642d243a1b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=158617
6 changed files with 63 additions and 0 deletions

View file

@ -78,6 +78,7 @@
SUBDIR += libsmi
SUBDIR += mbrowse
SUBDIR += mrtg
SUBDIR += nagcon
SUBDIR += nagios
SUBDIR += nagios-plugins
SUBDIR += nagios-radauth-plugin

20
net-mgmt/nagcon/Makefile Normal file
View file

@ -0,0 +1,20 @@
# ports collection makefile for: nagcon
# Date created: Wed Mar 29 20:41:02 CST 2006
# Whom: Douglas K. Rand <rand@meridian-enviro.com>
#
# $FreeBSD$
#
PORTNAME= nagcon
PORTVERSION= 0.0.13
CATEGORIES= net-mgmt
MASTER_SITES= http://www.vanheusden.com/nagcon/
EXTRACT_SUFX= .tgz
MAINTAINER= rand@meridian-enviro.com
COMMENT= Nagios 2.0 console monitor
USE_GMAKE= YES
PLIST_FILES= bin/nagcon
.include <bsd.port.mk>

3
net-mgmt/nagcon/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (nagcon-0.0.13.tgz) = 204a2a397a5c00e14be5ff97f7660658
SHA256 (nagcon-0.0.13.tgz) = 7a1cdb5b17e71410d2378b2096c59d9b4a773f9c6aa7fbbc66f10114a836231d
SIZE (nagcon-0.0.13.tgz) = 10667

View file

@ -0,0 +1,15 @@
--- ./br.h.orig Tue Mar 28 20:54:02 2006
+++ ./br.h Tue Mar 28 20:56:02 2006
@@ -8,6 +8,12 @@
#define likely(x) __builtin_expect((x),1)
#define unlikely(x) __builtin_expect((x),0)
+/* FreeBSD uses open/stat/lseek/off_t rather than open64/stat64/lseek64/off64_t */
+#define stat64 stat
+#define lseek64 lseek
+#define open64 open
+#define off64_t off_t
+
class buffered_reader
{
private:

View file

@ -0,0 +1,20 @@
--- ./nc.cpp.orig Tue Mar 28 20:58:16 2006
+++ ./nc.cpp Wed Mar 29 20:39:15 2006
@@ -182,7 +182,7 @@
version();
printf("-f file what file to monitor (usuallly:\n");
- printf(" /usr/local/nagios/var/status.log, look for status_file in\n");
+ printf(" /var/spool/nagios/status.dat, look for status_file in\n");
printf(" the nagios.cfg file\n");
printf("-i x check interval (in seconds)\n");
printf("-a list also the services for hosts that are down\n");
@@ -208,7 +208,7 @@
WINDOW *win;
int sw;
- char *statuslog = "/usr/local/nagios/var/status.log";
+ char *statuslog = "/var/spool/nagios/status.dat";
int interval = 5;
char list_all_problems = 0;
char always_notify = 0;

View file

@ -0,0 +1,4 @@
Nagcon is a console application interfacing to Nagios 2.0 which gives
you an overview of all services with troubled services.
WWW: http://www.vanheusden.com/nagcon