audio/gogglesmm: Upgrade version 0.13.2 => 0.13.3

PR:		193154
Submitted by:	Ports Fury
This commit is contained in:
John Marino 2014-09-16 21:49:12 +00:00
parent 47c5d1d6d4
commit 644dab49e2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=368349
6 changed files with 29 additions and 86 deletions

View file

@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= gogglesmm
PORTVERSION= 0.13.2
PORTREVISION= 1
PORTVERSION= 0.13.3
CATEGORIES= audio
MASTER_SITES= GH
MAINTAINER= ports@FreeBSD.org
COMMENT= Music collection manager and player
@ -18,9 +18,9 @@ LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
GH_COMMIT= ea16b55
GH_COMMIT= 259f253
USES= compiler:c++11-lang desktop-file-utils gmake pkgconfig
USES= compiler:c++0x desktop-file-utils gmake pkgconfig
USE_SQLITE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= LINK="${CXX}" \
@ -31,7 +31,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --fox-prefix=${LOCALBASE} \
--without-rsound --without-mpcdec
INSTALLS_ICONS= yes
CFLAGS+= -Wno-error=return-type
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
@ -86,6 +85,12 @@ VORBIS_CONFIGURE_OFF= --without-off --without-vorbis
WAVPACK_LIB_DEPENDS= libwavpack.so:${PORTSDIR}/audio/wavpack
WAVPACK_CONFIGURE_OFF= --without-wavpack
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 34
USE_GCC= yes
.endif
post-patch:
@${REINPLACE_CMD} -e \
's|share/man|man|' ${WRKSRC}/configure
@ -112,4 +117,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gogglesmm/libgap_*.so
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
SHA256 (gogglesmm-0.13.2.tar.gz) = d6f577c06b420dcab813a56672c07434b034f30aad0cfc379b9b2a6c20d75e3f
SIZE (gogglesmm-0.13.2.tar.gz) = 1336120
SHA256 (gogglesmm-0.13.3.tar.gz) = e52695d3e2d328e047ba127bdc960e3935f2f19cfeb8bf99ecc202826ca09ea8
SIZE (gogglesmm-0.13.3.tar.gz) = 1336269

View file

@ -1,30 +0,0 @@
--- src/gap/ap_reactor.cpp.orig
+++ src/gap/ap_reactor.cpp
@@ -98,17 +98,27 @@
#ifndef WIN32
FXint n;
if (timeout>=0) {
+#ifdef _GNU_SOURCE
struct timespec ts;
ts.tv_sec = timeout / 1000000000;
ts.tv_nsec = timeout % 1000000000;
+#endif
do {
+#ifdef _GNU_SOURCE
n = ppoll(pfds,nfds,&ts,NULL);
+#else
+ n = poll(pfds,nfds,-1);
+#endif
}
while(n==-1 && errno==EINTR);
}
else {
do {
+#ifdef _GNU_SOURCE
n = ppoll(pfds,nfds,NULL,NULL);
+#else
+ n = poll(pfds,nfds,0);
+#endif
}
while(n==-1 && errno==EINTR);
}

View file

@ -1,10 +1,19 @@
--- src/gap/ap_socket.cpp.orig
+++ src/gap/ap_socket.cpp
@@ -18,6 +18,7 @@
********************************************************************************/
#include "ap_defs.h"
#include "ap_socket.h"
+#include "ap_utils.h"
@@ -41,14 +41,14 @@
#ifndef SOCK_CLOEXEC
if (!ap_set_closeonexec(device)){
::close(device);
- return BadHandle;
+ return;
}
#endif
#ifndef WIN32
#ifndef SOCK_NONBLOCK
if (access&FXIO::NonBlocking && !ap_set_nonblocking(device)){
::close(device);
- return BadHandle;
+ return;
}
#endif
}

View file

@ -1,30 +0,0 @@
--- src/gap/ap_utils.cpp.orig
+++ src/gap/ap_utils.cpp
@@ -247,17 +247,27 @@
nfds=2;
}
if (timeout) {
+#ifdef _GNU_SOURCE
struct timespec ts;
ts.tv_sec = (timeout / 1000000000);
ts.tv_nsec = (timeout % 1000000000);
+#endif
do {
+#ifdef _GNU_SOURCE
n=ppoll(fds,nfds,&ts,NULL);
+#else
+ n=poll(fds,nfds,-1);
+#endif
}
while(n==-1 && (errno==EAGAIN || errno==EINTR));
}
else {
do {
+#ifdef _GNU_SOURCE
n=ppoll(fds,nfds,NULL,NULL);
+#else
+ n=poll(fds,nfds,0);
+#endif
}
while(n==-1 && (errno==EAGAIN || errno==EINTR));
}

View file

@ -1,11 +0,0 @@
--- src/gap/plugins/ap_oss_plugin.cpp.orig
+++ src/gap/plugins/ap_oss_plugin.cpp
@@ -117,7 +117,7 @@
#ifdef SNDCTL_DSP_COOKEDMODE
/// Turn off automatic resampling.
FXint enabled=(config.flags&OSSConfig::DeviceNoResample) ? 0 : 1;
- if (ioctl(fd,SNDCTL_DSP_COOKEDMODE,&enabled)==-1)
+ if (ioctl(handle,SNDCTL_DSP_COOKEDMODE,&enabled)==-1)
GM_DEBUG_PRINT("[oss] unable to set cooked mode\n");
#endif