Lurker is not just another mailing list archiver. It is capable of handling
gigabytes of mail without slowing down. Lurker has been designed to scale to support sites with thousands of concurrent users and hundreds of new messages a second. If you run a high-volume mailing list archive, you should seriously consider lurker for this alone. To facilitate finding interesting data, lurker supports: * full keyword search by body, subject, author, ... * a graphical representation of message relationships * charts of the current activity about a topic * searching lists or queries around an estimated time * signature verification to confirm the author * messages markup to find related information As one would expect, lurker also supports file attachments, multiple languages, message threading, gpg key photo ids, a transactional database, automatic timezone detection, render caching, xml customization with xslt and css, multiple front-ends (3-tier deployment), and many other buzz words. WWW: http://lurker.sourceforge.net/ PR: ports/154459 Submitted by: Kevin Rauwolf <sweetpea-freebsd at tentacle.net> Feature safe: yes
This commit is contained in:
parent
2977c952cb
commit
649d2374fa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=268663
7 changed files with 199 additions and 0 deletions
|
@ -245,6 +245,7 @@
|
|||
SUBDIR += lmtp2nntp
|
||||
SUBDIR += lmtpd
|
||||
SUBDIR += lookout
|
||||
SUBDIR += lurker
|
||||
SUBDIR += mahogany
|
||||
SUBDIR += mail-notification
|
||||
SUBDIR += mail2procmailrc
|
||||
|
|
55
mail/lurker/Makefile
Normal file
55
mail/lurker/Makefile
Normal file
|
@ -0,0 +1,55 @@
|
|||
# New ports collection makefile for: lurker
|
||||
# Date created: 01 Feb 2011
|
||||
# Whom: Kevin Rauwolf <sweetpea-freebsd@tentacle.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lurker
|
||||
PORTVERSION= 2.3
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= SF:0 \
|
||||
SF/${PORTNAME}/mimelib/${MIMELIB_VERSION}/:1
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:0 mimelib-${MIMELIB_VERSION}.tar.gz:1
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= sweetpea-freebsd@tentacle.net
|
||||
COMMENT= A mailing list archiver
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
MIMELIB_VERSION= 3.1.1
|
||||
USE_ICONV= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-mimelib-local \
|
||||
--with-default-www-dir=${PREFIX}/www/lurker \
|
||||
--with-cgi-bin-dir=${PREFIX}/www/lurker
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
MAN1= lurker-index.1 lurker-list.1 lurker-params.1 \
|
||||
lurker-regenerate.1 lurker-search.1 lurker-prune.1
|
||||
|
||||
post-extract:
|
||||
@cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
|
||||
${DISTDIR}/mimelib-${MIMELIB_VERSION}.tar.gz ${EXTRACT_AFTER_ARGS}
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/INSTALL ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/FAQ ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/ChangeLog ${DOCSDIR}
|
||||
.endif
|
||||
@${CHOWN} -R www:www ${PREFIX}/www/lurker
|
||||
${INSTALL_DATA} ${WRKSRC}/lurker.conf ${PREFIX}/etc/lurker/lurker.conf.sample
|
||||
@if [ ! -f ${PREFIX}/etc/lurker/lurker.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/lurker/lurker.conf.sample ${PREFIX}/etc/lurker/lurker.conf ; \
|
||||
fi
|
||||
${INSTALL_DATA} ${WRKSRC}/apache.conf ${PREFIX}/etc/lurker/apache.conf.sample
|
||||
@if [ ! -f ${PREFIX}/etc/lurker/apache.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/lurker/apache.conf.sample ${PREFIX}/etc/lurker/apache.conf ; \
|
||||
fi
|
||||
.include <bsd.port.mk>
|
4
mail/lurker/distinfo
Normal file
4
mail/lurker/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
SHA256 (lurker-2.3.tar.gz) = d174d16d62c32ee5899cb346544b35ccde1b70e8a81aa971e52ec8818365d038
|
||||
SIZE (lurker-2.3.tar.gz) = 320420
|
||||
SHA256 (mimelib-3.1.1.tar.gz) = 831f553639944d23ef7fc6d27a98c88b7a1afa4626b8feef98e8932403ec6e6c
|
||||
SIZE (mimelib-3.1.1.tar.gz) = 194838
|
18
mail/lurker/files/patch-Makefile.am
Normal file
18
mail/lurker/files/patch-Makefile.am
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.am.orig 2009-10-19 06:56:31.000000000 -0700
|
||||
+++ Makefile.am 2011-02-02 00:55:58.000000000 -0800
|
||||
@@ -3,15 +3,6 @@
|
||||
|
||||
install-data-local:
|
||||
$(mkinstalldirs) $(DESTDIR)$(default_config_dir)
|
||||
- @echo
|
||||
- @echo "*** PLEASE READ ***"
|
||||
- @echo
|
||||
- @echo "Lurker config files have not been installed (for your protection)"
|
||||
- @echo "If you would like the default config files installed, run:"
|
||||
- @echo " make install-config"
|
||||
- @echo
|
||||
- @echo "*** PLEASE READ ***"
|
||||
- @echo
|
||||
|
||||
install-config:
|
||||
$(mkinstalldirs) $(DESTDIR)$(localstatedir)/lib/$(PACKAGE)
|
18
mail/lurker/files/patch-Makefile.in
Normal file
18
mail/lurker/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.in.orig 2009-10-30 11:51:39.000000000 -0700
|
||||
+++ Makefile.in 2011-02-02 00:56:35.000000000 -0800
|
||||
@@ -615,15 +615,6 @@
|
||||
|
||||
install-data-local:
|
||||
$(mkinstalldirs) $(DESTDIR)$(default_config_dir)
|
||||
- @echo
|
||||
- @echo "*** PLEASE READ ***"
|
||||
- @echo
|
||||
- @echo "Lurker config files have not been installed (for your protection)"
|
||||
- @echo "If you would like the default config files installed, run:"
|
||||
- @echo " make install-config"
|
||||
- @echo
|
||||
- @echo "*** PLEASE READ ***"
|
||||
- @echo
|
||||
|
||||
install-config:
|
||||
$(mkinstalldirs) $(DESTDIR)$(localstatedir)/lib/$(PACKAGE)
|
21
mail/lurker/pkg-descr
Normal file
21
mail/lurker/pkg-descr
Normal file
|
@ -0,0 +1,21 @@
|
|||
Lurker is not just another mailing list archiver. It is capable of handling
|
||||
gigabytes of mail without slowing down. Lurker has been designed to scale to
|
||||
support sites with thousands of concurrent users and hundreds of new messages a
|
||||
second. If you run a high-volume mailing list archive, you should seriously
|
||||
consider lurker for this alone.
|
||||
|
||||
To facilitate finding interesting data, lurker supports:
|
||||
|
||||
* full keyword search by body, subject, author, ...
|
||||
* a graphical representation of message relationships
|
||||
* charts of the current activity about a topic
|
||||
* searching lists or queries around an estimated time
|
||||
* signature verification to confirm the author
|
||||
* messages markup to find related information
|
||||
|
||||
As one would expect, lurker also supports file attachments, multiple languages,
|
||||
message threading, gpg key photo ids, a transactional database, automatic
|
||||
timezone detection, render caching, xml customization with xslt and css,
|
||||
multiple front-ends (3-tier deployment), and many other buzz words.
|
||||
|
||||
WWW: http://lurker.sourceforge.net/
|
82
mail/lurker/pkg-plist
Normal file
82
mail/lurker/pkg-plist
Normal file
|
@ -0,0 +1,82 @@
|
|||
bin/lurker-index
|
||||
bin/lurker-list
|
||||
bin/lurker-params
|
||||
bin/lurker-prune
|
||||
bin/lurker-regenerate
|
||||
bin/lurker-search
|
||||
etc/lurker/apache.conf
|
||||
etc/lurker/lurker.conf
|
||||
@unexec if cmp -s %D/etc/lurker/lurker.conf.sample $D/etc/lurker/lurker.conf; then rm -f $D/etc/lurker/lurker.conf; fi
|
||||
etc/lurker/lurker.conf.sample
|
||||
@exec if [ ! -f %D/etc/lurker/lurker.conf ] ; then cp -p $D/%F %B/lurker.conf; fi
|
||||
@unexec if cmp -s %D/etc/lurker/apache.conf.sample $D/etc/lurker/apache.conf; then rm -f $D/etc/lurker/apache.conf; fi
|
||||
etc/lurker/apache.conf.sample
|
||||
@exec if [ ! -f %D/etc/lurker/apache.conf ] ; then cp -p $D/%F %B/apache.conf; fi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/FAQ
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
www/lurker/bounce.cgi
|
||||
www/lurker/imgs/a.png
|
||||
www/lurker/imgs/b.png
|
||||
www/lurker/imgs/bar.png
|
||||
www/lurker/imgs/c.png
|
||||
www/lurker/imgs/d.png
|
||||
www/lurker/imgs/e.png
|
||||
www/lurker/imgs/f.png
|
||||
www/lurker/imgs/g.png
|
||||
www/lurker/imgs/h.png
|
||||
www/lurker/imgs/i.png
|
||||
www/lurker/imgs/j.png
|
||||
www/lurker/imgs/k.png
|
||||
www/lurker/imgs/next.png
|
||||
www/lurker/imgs/paperclip.png
|
||||
www/lurker/imgs/prev.png
|
||||
www/lurker/imgs/reply.png
|
||||
www/lurker/imgs/root.png
|
||||
www/lurker/imgs/trash.png
|
||||
www/lurker/index.html
|
||||
www/lurker/jump.cgi
|
||||
www/lurker/keyword.cgi
|
||||
www/lurker/lurker.cgi
|
||||
www/lurker/lurker.docroot
|
||||
www/lurker/ui/ca.xml
|
||||
www/lurker/ui/common.js
|
||||
www/lurker/ui/common.xsl
|
||||
www/lurker/ui/da.xml
|
||||
www/lurker/ui/de.xml
|
||||
www/lurker/ui/default.css
|
||||
www/lurker/ui/el.xml
|
||||
www/lurker/ui/en.xml
|
||||
www/lurker/ui/es.xml
|
||||
www/lurker/ui/fi.xml
|
||||
www/lurker/ui/fr.xml
|
||||
www/lurker/ui/gl.xml
|
||||
www/lurker/ui/hu.xml
|
||||
www/lurker/ui/it.xml
|
||||
www/lurker/ui/ja.xml
|
||||
www/lurker/ui/lang.xml
|
||||
www/lurker/ui/lang.xsl
|
||||
www/lurker/ui/list.xsl
|
||||
www/lurker/ui/message.xsl
|
||||
www/lurker/ui/mindex.xsl
|
||||
www/lurker/ui/nl.xml
|
||||
www/lurker/ui/pl.xml
|
||||
www/lurker/ui/pt-BR.xml
|
||||
www/lurker/ui/pt.xml
|
||||
www/lurker/ui/search.xsl
|
||||
www/lurker/ui/splash.xsl
|
||||
www/lurker/ui/thread.xsl
|
||||
@dirrm www/lurker/zap
|
||||
@dirrm www/lurker/ui
|
||||
@dirrm www/lurker/thread
|
||||
@dirrm www/lurker/splash
|
||||
@dirrm www/lurker/search
|
||||
@dirrm www/lurker/mindex
|
||||
@dirrm www/lurker/message
|
||||
@dirrm www/lurker/mbox
|
||||
@dirrm www/lurker/list
|
||||
@dirrm www/lurker/imgs
|
||||
@dirrm www/lurker/attach
|
||||
@dirrm www/lurker
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm etc/lurker
|
Loading…
Reference in a new issue